Stardew Valley Mobile: Known Issues and Fixes

Discussion in 'Support' started by Katzeus, Oct 23, 2018.

  1. usgrant

    usgrant Space Hobo

    “User loses progress if the system kills the app before the user sleeps” is absolutely a bug. Being able to correctly recover from process death is a cornerstone of mobile application design, and it does not speak well of the developers of the mobile port if this wasn’t even considered. I won’t play unless this is fixed, and if it’s not even on the roadmap to be fixed, I just want my money back.
     
    • Dorotchi

      Dorotchi Poptop Tamer

      I also had problems with the magnet ring & not being able to pick up items anymore. Swapped a magnet ring out for another magnet ring in the mines (thought it might have been a better ring but it was the same). After that, nothing could be picked up. Makes the game unplayable :( Saw the explanation about the negative pickup radius, but thought I'd report the bug anyway.
       
        heathraawr likes this.
      • Pros599

        Pros599 Seal Broken


        This absolutely isn’t a bug, and you should blame Apple for this bug. This has everything to do with the whole suspend/resume process of the iOS process management. In some cases, you can actually suspend and resume without issues, hours later... however, if iOS needs to make room in the memory, Stardew Valley gets killed due to its resource usage.

        The game was never meant to have mid-day savings. That’s by design. Think of animal crossing for example - in fact, you can’t quit without saving, otherwise there are consequences.

        Don’t blame developers for being lazy when they’re absolutely following best practices and build beautiful software. Better yet, please drop your iOS device in fire - complaining about a bug in a $7.99 micro-transactionless game is a serious low.
         
        • Costaku

          Costaku Space Hobo

          I had a crash on winter the first, when to tap on the latter and the game crashed, it happens again on the 5th I was on level 74 and it crashed again.
           
          • XAVDABRAV

            XAVDABRAV Space Hobo

            I’m playing on an IPhone XS Max, played for around 17 hours in game and I’m on the 5th of winter in my first year. My game crashes whenever I try to go into floor 53 in the mines.
             
            • Kankenn

              Kankenn Space Hobo


              I can’t pick up things that drop eg.stone woods. It happened after I throw away a magnet ring in the mine after my bag was full. And then I equiped a glow ring instead. // I got 2 magnet rings so I throw away one of them. Please fix it. I can’t play any more.
              It happened in Late of Summer Year1 may be 28 or 29
               
              • Typhoon

                Typhoon Spaceman Spiff

              • Chapin2816

                Chapin2816 Space Hobo

                I have tried this twice and every time I get to the ladder floor 55 of the mines, the game crashes.
                 
                • mark_tyler

                  mark_tyler Space Hobo

                  It is not possible (at least i dont know how) to move crafted chest around after it is placed (maybe some other objects too)
                   
                    Last edited: Oct 28, 2018
                  • Redlionfarm

                    Redlionfarm Space Hobo

                    Hey, I play on my iPad Pro and every time I’ve tried to update my chicken coop to the large coop, the app crashes during saving at the end of the day. Each day I do without trying to update the coop saves fine, it only happens when I try to upgrade. I’m loving the game! I’m hoping this issue can get fixed soon. Thanks guys!
                     
                    • Avapoppington

                      Avapoppington Intergalactic Tourist

                      I can't gather items from the ground anymore on the iOS version like other people have posted before me.
                      Please fix soon as the game has become unplayable
                       
                      • alpheus0

                        alpheus0 Intergalactic Tourist

                        I’m on an iPhone XR, and I know it’s already been reported but I’m having the same issue where the padding resets every time I launch the game and puts the menu behind the screen notch. Ideally y’all could make some sort of default so the screen notch won’t get in the way of anything


                        Sent from my iPhone using Tapatalk
                         
                        • EricEWade

                          EricEWade Intergalactic Tourist

                          i, having the magnet ring issue. I had a small magnet ring, then found a regular one. Equipped both (to save space in backpack). Sold small ring and kept the other equipped. Went to bed and woke up to a new day where I can’t pickup anything off the ground.
                           
                          • drdarkgamer

                            drdarkgamer Poptop Tamer

                            I imported a save from PC to my Phone, and the it worked just fine it just had one glitch where I cannot press the button which allows the inventory menu to be open and the objectives excalmation Mark wasn’t showing, I got that issue on an IPhone 7, and it was only specifically on this save game, I hope you push an update that can fix that
                             
                              Creepystormtroop likes this.
                            • ItIsMichael

                              ItIsMichael Space Hobo

                              Hello, I have also found few issues:

                              1) On 14th day of Fall, year 1, I was in mines, I was currently walking, and the game crashed, out of nothing.

                              2) My cat time to time lies exactly in the door of my house, so I can not get in; it happens randomly and independently on anything else.

                              3) In community center, every time I enter, one of the small green creatures jumps into the Pantry golden scroll (top left), and after this happens, it won’t let me open the scroll. I need to re-enter the building, then it will jump to the left, disappear, and then I can use the scroll.

                              4) When donating to the museum, there are spots in inventory that will close the menu instead of selecting an item to donate when clicked.

                              Played on iPhone X with the newest iOS.
                               
                              • Mdahl

                                Mdahl Space Hobo

                                Hello, I believe I have more details/information about the issue of after un-equipping the magnet ring items can’t be picked up. I might have even found in the code where it is going wrong, and how to fix it. Or rather, I found someone else who believes to have found the solution to it. I googled this bug because I experienced it myself on my IPad Air 1, and seemingly found the answer on how to fix it on a reddit page made for this problem. The guy who found the solution of how to fix it said, and I quote:

                                “I’m working off a Mac so it might be different for you, but here’s what I did:
                                - Plug phone into computer, open iTunes, connect phone to itunes, and click the phone’s icon in the top left of the toolbar.
                                - Go to file sharing, click SV, select your save file (I only have one file, so I clicked the only folder I saw), save that folder.
                                - Go to that folder on your computer, and open the one that says playername-2001... (the file that doesn’t say savegameinfo), open with text edit or similar program. Find <magneticradius> with cmd +F (ctrl + F on windows).
                                -The number your character should have is 128 without rings or anything, so if it’s anything other than that change it (mine said -64). After changing that number, save that file and close it. Rename your save folder and the document to something else (I just changed increased the last number by one). Sync your phone and try the save.”

                                Just figured it might be good to share this information if it hasn’t been brought to your attention already. And here is the link to the reddit page if you want to look into it a bit more, but the quote above pretty much encapsulates most of what is said about it.

                                Link: https://www.reddit.com/r/StardewValley/comments/9rl02m/ios_picking_up_items_bug/

                                I would give you my save file, but as of the moment, my computer with ITunes on it is on the fritz, so I can’t plug my iPad in to get to the file. But I hoped this helped a little in figuring out the problem.
                                 
                                  mumeawii likes this.
                                • sinyiing

                                  sinyiing Space Hobo

                                  Ever since I picked up the small magnet ring, I couldn’t pick up anything that on the ground. Even after I equipped it, took it off or throw it away, it remain the same that I couldn’t pick up items.
                                   

                                    Attached Files:

                                    mumeawii likes this.
                                  • Typhoon

                                    Typhoon Spaceman Spiff

                                  • Typhoon

                                    Typhoon Spaceman Spiff

                                    From reddit, somebody else experiencing a crash when reaching a certain level in the mines, this seems to be reported more and more often for various mine levels and needs fixing badly -

                                    anyone experiencing force closing on stardew valley ios when you get to a new level like 95? i spent so much time getting to level 90 in the mine and as soon as i hit level 95 the game closed by itself and i lost everything..

                                    https://www.reddit.com/r/StardewValley/comments/9s9kl1/stardew_valley_force_closing/
                                     
                                    • Caipa

                                      Caipa Poptop Tamer

                                      Hit the chest with the axe, then pick it up.
                                       
                                        Katzeus likes this.

                                      Share This Page