1. Lose your pre-order key? Try using Humble's key resender. Also, please check the support FAQs before posting: http://playstarbound.com/help/
  2. Hey Guest! Our new game Wargroove has released! Check out the forums or wiki for more information!
    Dismiss Notice

Closed Client-Server Connection is no longer valid

Discussion in 'Support' started by Javalin, Dec 5, 2013.

Thread Status:
Not open for further replies.
  1. SirCloud

    SirCloud Void-Bound Voyager

    I run a public server for SB and im having the same problem, also I tried the wiping the universe thing also, that didnt fix it. Theres something buggy about this release for servers. BUMP
     
  2. proveisso

    proveisso Void-Bound Voyager

    sorry, I skipped everything to post =p found this link on the bug database. I just got this error while playing in single-player for more than an hour! o_O
     
  3. Vinnlander

    Vinnlander Aquatic Astronaut

    Has anyone yet resolved this issue for MP? I whenever I connect to the servers I run externally I get kicked with this error after seconds or sometimes minutes of play. Only way I can stay playing is when I play SP or host the server locally.
     
  4. Veloxia

    Veloxia Void-Bound Voyager

    Not that I know of. It's 22/12 and still, I get kicked from my own server every 20-60 minutes.
     
  5. Ark Rotarl

    Ark Rotarl Void-Bound Voyager

    I'm having this issue now with single player and no real explicable cause outside of fiddling around with a mod I was working on. I can create my character with my newly modded race, but selecting this character leads to this crash after a good 30 seconds. Please, is there ANY answer yet to this issue? It's driving me nuts, I'm on the verge of completing my mod and this hang-up's killing the testing phase for my mod.
     
  6. JagerBaBomb

    JagerBaBomb Aquatic Astronaut

    I've started using the Fight for the Universe ship building/customization mod and this happens to me when I go to use the large matter manipulator (it originally ate 7x7 chunks but I bumped it to 8x8).

    Is this just some kind of general error? It should be mentioned that the matter manipulator is set to fire every .0025 seconds, so maybe having it fire that often at that size is causing a server crash issue or something? Just shots in the dark.
     
  7. Usiemon

    Usiemon Scruffy Nerf-Herder

    I'm running a dedicated server, and having this issue as well.

    The details are as follows.

    <What happens>
    Whenever I connect to my server with local IP address, the game says
    "CLIENT-SERVER CONNECTION IS NO LONGER VALID"
    and closes the connection.
    The duration that I can stay connected is variable.
    Sometimes I can play for an hour, sometimes 2 seconds.

    <System>
    Internet connection: Cable(gives a global address, no port regulation. Effective uplink speed: 10Mbps, downlink: 20Mbps)
    Router:BUFFALO WZR-HP-G302H(1-year-old, has both ethernet and wireless)
    Server machine:Intel NUC D54250WYK(Wired to the router, OS:Ubuntu server 13.10 64 bit)
    Client machine: A shop-made built-to-order one(Wireless connection to the router, OS: Windows 7 64 bit)

    <Setup>
    Router: Doing static network address translation to the server(port 21025, 21026, and 20127. Both TCP and UDP)
    Server machine: Static IP address, OS firewall disabled
    Client machine: Static IP address, OS firewall enabled(tried disabling Windows Firewall, didn't help)

    <Note>
    Deleting my server from http://starbound-servers.net seems to mitigate this problem a bit, but still it's not a reliable solution. I had the very same problem after good 1.5 hours.
    I tried both linux 32 and linux 64 server programs and ended up having the same problem.
     
    Last edited: Dec 31, 2013
  8. Nerixel

    Nerixel Aquatic Astronaut

    This seems to happen when there's a disconnect between the server and the client, as well as that password problem. I get this, but only once a night in over 6 hours of playing.

    From what I've seen, it's either got some delay between connecting to the server and the kick, or you are instantly kicked. If it's the first problem, it's likely your internet disconnecting for just a little bit. This might only affect Starbound as it might have lower timeouts set, unlike other programs. So, while other programs and games would wait for a bit longer before auto-disconnecting you, Starbound disconnects you before the connection has a chance to find itself again.
    If it's the second, there's already been a solution listed above.
     
  9. Usiemon

    Usiemon Scruffy Nerf-Herder

    Thanks Tadpole, that explains half of this problem.
    The remaining fact is, although you restart your server right after facing this issue, it remains at least for a few minutes.

    I had this very problem and started again the server, and then after 2 seconds it killed my client with the message "CLIENT-SERVER CONNECTION IS NO LONGER VALID".
    There seems to be other factors than server spec and bandwidth to this matter.
     
  10. Nerixel

    Nerixel Aquatic Astronaut

    It's just unusual, because it's affecting only some people. Normally this would affect either everyone or no-one. I've gotten this message once or twice before, but it was around a time of the day that my internet starts dropping out a little, so I didn't think much of it.
     
  11. SeriousConcentrate

    SeriousConcentrate Big Damn Hero

    I get this message whenever I try to play with ANY custom race in single-player. I can create a character just fine, but when I try to play them I get this message. Weird, because it doesn't do that for the standard six races, only custom ones. Anyone know what the deal is? I'd like to use the kobolds. -__-
     
  12. pumpkin1887

    pumpkin1887 Void-Bound Voyager

    I have that mod and much more custom races and i tried them.

    At first when i had a few they worked ,not sure about the kobolds.
    All of the normal races work.
    Here are the mods that work and don't work.
    I am using xbawk charecter menu.

    Don't Work: Bunnykin,Grey_race,kaenid,Lord,amfin,insectlids,alterian,pure,kokido,halfwarps,mephetor,elf,lombax,dimentrex,ethereal,kitsune,kobold,vulpes,kangaru,felin,betakins (novakins mod),Na'vi,xionian, and argonian.
    Ones that wont show up on the creation screen: leporid and SoME
    Do the only one that works with them Varan.

    If you know which ones are incompatible please let me know!

    EDIT: i removed most mods i have and gone back to the base of them and most are they are working after i removed the varan.... but the kobolds are not working :(

    EDIT 2!:Well sorry to say all but varan and kobold wont work ,leporid and SoME i gave up on and wont try because you cant find them on creation screen and varan just wont let other races work other than that all of them work.

    Making the working races into a modpack and see how that goes.... wish me Luck! :D
     
    Last edited: Jan 5, 2014
  13. pumpkin1887

    pumpkin1887 Void-Bound Voyager

    Sorry for this odd post but from my last post above it seems that it wont work at all....
    I think you need to modify it a bit because it might be some issue with the game or its just not working.
    Sorry for this news to you but it means there is something to fix and that would be apart of modding trial and error ,as they say "If at first you don't succeed try ,try again."

    And just one question how are you making a race? ,i have looked everywhere for a tutorial on how to make one but i cant find one :(

    Any ways good luck on your Race! :up:
     
  14. Spicycinnabon

    Spicycinnabon Intergalactic Tourist

    I just did that, and I'm still getting the error. My screen shows black except for the hotbar, and the buttons on the right. I stay on and can chat for about 45-75 seconds and then I disconnect.

    Update: If I try to play a character I've played single player on, it can't even join. If I make a new character the above happens.
     
  15. CaptainKobold

    CaptainKobold Pangalactic Porcupine

    Hey pumpkin1887 and SeriousConcentrate! Sorry to hear you're having trouble playing as kobolds! They're slippery little beasts and I'll be honest, I've had some of the client-server issues myself. I'd like to say I've got a totally foolproof solution, but I actually haven't found one yet! For me, generally, if I close the little popup and then go back in, it seems to work most of the time, but that's clearly not helpful.

    If you see any errors in your starbound.log related to the kobolds, please let me know and I'll try to squash the bug! I'd love for you to be able to play as a kobold!

    Edit: I did a little bit of research and I may have found the solution! Unfortunately, I'm currently away from a computer that actually has Starbound, so I'm not able to test it at the moment. If anyone attempting to run the kobold mod and getting that could check the log and let me know if there is a line saying "UniverseServer exception caught", I should be able to fix the problem and reupload today or tomorrow.

    Kawa describes the solution to the problem here if you are looking to fix it in your own file! Hopefully that solves it, though admittedly I can't be sure as I can't test it at the moment.
     
    Last edited: Jan 7, 2014
    kagebouzu likes this.
  16. SeriousConcentrate

    SeriousConcentrate Big Damn Hero

    Thank you very much, CaptainKobold. ^^^ I have to go to work in a few but I'll look into that link when I get back and see if that fixes matters.
     
  17. CaptainKobold

    CaptainKobold Pangalactic Porcupine

    Absolutely! Tonight I'm also going to take a look at it and upload a new version that should fix this problem (hopefully).

    As a side note, it could totally be that the other mod makers don't know there is a problem currently! It may be helpful to let them know or at least check their thread to see if they know about it!
     
  18. CaptainKobold

    CaptainKobold Pangalactic Porcupine

    I think the updated Kobold mod should now work for people having client-server issues! There was a problem in one of the codexes which was ruining everything.
     
  19. •ÐJFerno™

    •ÐJFerno™ Void-Bound Voyager

    Same here
     
  20. RyuujinZERO

    RyuujinZERO Supernova

    @CaptainKobold A lot of race mods, including mine seem to be causing a tiny minority of people to have this error too, and it always cites the codex as the cause in the error log, but I don't understand why it only affects a tiny tiny minority of players and I can't see anything wrong with the codex
     
Thread Status:
Not open for further replies.

Share This Page