1. Please be advised of a few specific rules and guidelines for this section.

RELEASED The Empress' New Clothes - invisible cosmetic items

Discussion in 'Weapons, Armor and Clothes' started by slime_monster, Dec 7, 2013.

  1. Knae

    Knae Big Damn Hero

    i've had a problem using this in mulitplayer servers. If i beamed to a planet with any of the stuff equipped, no monsters will spawn except mini-bosses and dungeons monsters. Also these monster act like i'm invisible, letting me walk pass and open chests. Furthermore, I can't attack anything, but i can open stuff, chop wood and dig up ore. Anyone else had this happen before?
  2. slime_monster

    slime_monster Space Spelunker

    Wow - I can't even imagine how that would happen -can you un-install the mod and see if that still happens? do you have any other mods installed? If you could give me an X, Y I'm more than happy to go check and see if that happens to me
  3. Knae

    Knae Big Damn Hero

    I actually posted it at "In-game Support" thinking it was the new patch making mods screw up in multiplayer. These are the mods i was using at the time:
    -Logic Gates
    -LIssar's Hair Mods
    -Empress New Clothes

    When i first got the problem, i disabled all my mods through bootstrap.config( which i assume is telling Starbound to just not load the mod files). Then multiplayer worked fine. When i did this, all my mod items became green generic blocks. That was fine, and sorta expected. What i did next was enable each mod one by one, then logging into my friend's server each time and trying to kill something. Each time it was fine. At this point, I had all my mods activated and multiplayer was working fine. "Maybe it was a one time thing" I thought. Then i proceeded to remake some of my mod items.

    When i beamed down to a planet in my friend's server and starting wandering around, i realized that i had forgotten to make the empress helmet. This was when teh problem appeared again. If i beam down with the helmet equipped, the problem occurs. Everything is fine so long as i don't equip it before i land in the planet, meaning if i beam down and THEN equip it, it's ok.

    I just tested it on my own local server( multiplayer connected to my own server) and it works fine, so it could just be the server needing the files as well. Also, I installed all my mods through a mod folder in the Starbound folder and modifying bootstrap.config and player.config.
  4. slime_monster

    slime_monster Space Spelunker

    Thanks for the detailed reply - I'll try and replicate it tonight. Having it on the server should really help - but I have no idea what would be causing this :) What happens if you beam down to a planet that you have a friend already on, or a friend beams down to you when you are experience this bug?
  5. Knae

    Knae Big Damn Hero

    it was just me with the problem. Me and my friend were on the same planet at the time, It maybe that i couldn't see him either, but i'm not too sure cause he tends to go far ahead.i haven't tried asking him to beam down after me. I'll give that a go when i see him again
  6. Bob The Guardian

    Bob The Guardian Intergalactic Tourist

    in order to avoid this very problem you have hypothesized you could simply make the checkbox only appear when equiping the headgear. (would you like to see this headgear?) y/n
  7. Med

    Med Phantasmal Quasar

    Whoa. :ninja:
  8. DaWrecka

    DaWrecka Pangalactic Porcupine

    Is there a reason this mod doesn't use a player.config? Because all it took was a couple of minutes and I had a working file that didn't require me to edit a game file, which is a sure path to things breaking.

    "__merge" : [],
    "defaultBlueprints" : {
        "tier1" : [
        { "item" : "invishat" },
        { "item" : "invischest" },
        { "item" : "invispants" },
        { "item" : "invisback" }
    slime_monster likes this.
  9. slime_monster

    slime_monster Space Spelunker

    Because when I wrote this, there was no way of doing this :) I agree the new system is much better, I'm just updating the mod now :)

    EDIT - updated :)
    Last edited: Jan 17, 2014
  10. EvgEniRus

    EvgEniRus Void-Bound Voyager

    Very nice ;)
    What about a checkbox, I think this idea isn't worth digging into.
    For example, Terraria has Familiar clothes for the same purpose, except that characters in Terraria have slightly more "built-in" clothing than underwear :)
    Also, this functionality perfectly fits the purpose of cosmetic slots, that is, defines what you see instead of armour.

    Also encountered this while browsing mods, if anyone is interested:
    Last edited: Jan 27, 2014
  11. YamahaMom86

    YamahaMom86 Poptop Tamer

    I'm not sure if it's because I'm terrible with files and computering (lol) in general... but this doesn't work for me. =/ Granted, I'm on Furious Koala, now. Not sure if this mod just isn't compatible or if I'm just bleh. HELP ME. I MUST GET RID OF THE HELMET. IT KILLS ME. :)
  12. slime_monster

    slime_monster Space Spelunker

    It currently doesn't work with this version :( working on it now!
  13. slime_monster

    slime_monster Space Spelunker


    Ok, it is working again :) New version uploaded here - if you have any issues with install, please let me know :)
  14. YamahaMom86

    YamahaMom86 Poptop Tamer

    Thanks, Works like a charm :) Love it
    slime_monster likes this.
  15. slime_monster

    slime_monster Space Spelunker

    Glad you enjoy it :) Feel free to spread the word about it :)
    YamahaMom86 likes this.
  16. TessVerres

    TessVerres Aquatic Astronaut

    Just to post it here: You may want to update the mod for Enraged for those who use it if you're not working on it already. Last post was on the 2nd so I thought I'd be nice and inform ya.
    Trips, Schala and Zedrik like this.
  17. Mini_Knox

    Mini_Knox Void-Bound Voyager

    slime I have put all the files in the mods directory, but when I launch the game, the blueprint doesn't show up. Any idea why?
  18. 16BitPotato

    16BitPotato Void-Bound Voyager

    This mod is causing a crash on startup for me.
  19. redxlaser15

    redxlaser15 Big Damn Hero

    Even if I get this mod, how do I install mods if they aren't connected to my steam account?

Share This Page