Stardew Valley Mobile: Known Issues and Fixes

Discussion in 'Support' started by Katzeus, Oct 23, 2018.

  1. Katzeus

    Katzeus Community Manager Chucklefish

    Typhoon likes this.
  2. Typhoon

    Typhoon Spaceman Spiff

    That's some great news, thanks Katzeus.

    How about full support for MFi controllers, will that also be in the aforementioned patch?


    BTW, minor typo on the page that you linked to - near the bottom of the page under Show controls toggle button, the text

    "This checkbox when enable"

    should read:

    "This checkbox when enabled"
     
      Last edited: Nov 1, 2018
      Katzeus likes this.
    • Katzeus

      Katzeus Community Manager Chucklefish

      The devs have said that's being worked on - but I'm not sure if it'll be in the next update or not

      Good eye - fix'd
       
        Typhoon likes this.
      • Typhoon

        Typhoon Spaceman Spiff

        Thanks very much Katzeus, everyone involved in this is doing a very fine job.

        Now that I've had the time to read the page properly I see some more minor typos on the Wiki page that you linked to, sorry! First main line on the page reads as -

        The mobile version of the game has a number of different controls options


        should be -

        The mobile version of the game has a number of different control options


        Second line reads as -

        Control styles can be selected opening the menu

        should be -

        Control styles can be selected by opening the menu


        Under Tap-to-move & Auto-Attack

        it reads as -

        Tap on an items to action them

        should be

        Tap on items to action them

        and below that -

        Auto-attack - when in Mines if a weapon is selected


        should be -

        Auto-attack - when in the Mines if a weapon is selected


        I'd also add a couple of commas to the last two lines on the page so that they read -

        • When the toggle button is on, the control method is set to whatever method has been selected from the drop down.
        • When the toggle button is off, the controls switch to Tap-to-move & Auto-Attack.

        https://stardewvalleywiki.com/Mobile_Controls

        Sorry, wrong thread to post the above really but I couldn't think of anywhere better.
         
          Last edited: Nov 1, 2018
        • Typhoon

          Typhoon Spaceman Spiff

          BTW, will the SteelSeries Nimbus be supported when MFi support is fully implemented?
           
          • G0ed

            G0ed Space Hobo

            Hello, this is my first bug report here on the forums. I just started Stardew this weekend for the first time with the iOS release and have been loving it. I just updated to 1.03 today and have noticed more freezing and frame rate bugs since the update.

            Before the update, I went to the secret woods on the 5th of winter and had no combat issues when fighting the slimes. After the update I went to the secret woods on the 7th of winter and the in-game time froze up as I entered what should have been auto-combat. The snow still fell and I was able to switch tools in the toolbar but couldn’t move or perform actions. The slimes were also frozen in place.

            After switching items/tools several times, I was finally able to engage in combat. Video attached.


            TL;DR
            Auto-combat freezes time in the game after 1.03 update for mobile on iOS11.4.1 iPhone 7. The snow animation is still happening and you can switch tools, but the combat is not happening.
             
            • G0ed

              G0ed Space Hobo

              The frame drops to unplayable levels during Ice Fishing Competition (Winter of first year).

              Stardew Valley Mobile: 1.03
              iOS 11.4.1
              iPhone 7

               
              • G0ed

                G0ed Space Hobo

                The frame rate at The Stardrop Saloon sometimes drops considerably. This is a bug that happened before and after the 1.03 update. It doesn’t happen every night.

                Stardew Valley Mobile: 1.03
                iOS 11.4.1
                iPhone 7

                 
                • Typhoon

                  Typhoon Spaceman Spiff

                • TigPT

                  TigPT Space Hobo

                  iOS 12.1 (16B92)
                  iPhone 7 (Model 1660, 1778, 1779, 1780)

                  Here are the bugs I've found:

                  1. No audio after receiving phone call.

                  If you are playing and receive a phone call, when you go back to the game the audio is dead, you need to kill the app and relaunch to gain audio again, (but remember to go sleep before so you save your game).

                  2. No localization in boundles

                  The text in boundles is not localized, witch make it hard to match with items names that are (please use string calls that are localized in boundles on the community center and in the boundles quick menu so we can match itens not just by image and trying to translate them myself, sometimes is hard).

                  3. Museum sometimes lags

                  When you enter the museum, sometimes it lags a lot, maybe because there are so many placeholders for minerals to render, and its impossible to interact with Gunther. If you quick Museum the game is fluid again. If you stay inside museum sometimes it even crashes. (look for some leaks on that map)

                  4. Cat sometimes is in front of the door
                  Cat sometimes is in front of the door sleeping (inside the house) and don't let me get in to sleep, that can be very frustrating, much more then chickens in front of there house, since if no sleep, no save.

                  If you need me to screen record any of this bugs, just tell me.

                  Hope this help you identify some more bugs.

                  PS - Game is great, great port also, keep up the good work.
                   
                    Last edited: Nov 2, 2018
                  • Typhoon

                    Typhoon Spaceman Spiff

                    This is quite normal across all versions of the game on all platforms - it's quite normal behavior for a cat (or a dog, or chicken!). :) To get past the animal keep walking against it for a few seconds and then you'll move through/past it.
                     
                    • Typhoon

                      Typhoon Spaceman Spiff

                    • TigPT

                      TigPT Space Hobo

                      I will try it next time. It will work even if you are not visually walking? It happens to enter my house and I'm near door and cat the block after, so my character not even walk since there are no free map block to go to.
                       
                      • TigPT

                        TigPT Space Hobo

                        I think that save only sleeping is a feature not bug, but like you said, if game is in background, nothing can stop iOS from cleaning it from RAM, and the only alternative is to "emulate permanente pause, by implementing a save mechanism when applicationWillResignActive() and the load it when app is opened, or making sure pets don't fall a sleep in some blocks.
                        Also, try to avoid crashes, but that doesn't even need to be mentioned.
                         
                        • amandaecg

                          amandaecg Space Hobo

                          iOS 12.1
                          iPad 5
                          Version 1.03 installed of game

                          I am on Day 23 of Winter in the first year. The game has crashed 3 times now on this day while in the mines, and it was at different times each time but always while in the mines.

                          Definitely super frustrating and hope the next update will fix this ☹️ I love this game so much and this is the first thing that has been frustrating for me
                           
                          • TigPT

                            TigPT Space Hobo

                            Almost all my crashes are about high CPU usage. Here is an example.

                            CPU: 144 seconds cpu time over 178 seconds (81% cpu average), exceeding limit of 80% cpu over 180 seconds

                            Code:
                            Date/Time:       2018-11-01 15:34:44 +0000
                            End time:        2018-11-01 15:34:58 +0000
                            OS Version:      iPhone OS 12.1 (Build 16B92)
                            Architecture:    arm64
                            Report Version:  27
                            Incident Identifier: 7F0211C1-72B9-4253-86F2-32EA06AC4B06
                            
                            Data Source:     Microstackshots
                            Shared Cache:    0x1e0f8000 3F1A1801-A180-36D4-AF97-EA25553663F7
                            
                            Command:         StardewValley
                            Path:            /private/var/containers/Bundle/Application/16FF1B67-98D4-48B9-8113-84E1BF40C1FB/StardewValley.app/StardewValley
                            Identifier:      com.chucklefish.stardewvalley
                            Version:         1.027 (1.805)
                            Beta Identifier: D0DB8BD2-F336-4107-971B-7725897CC672
                            PID:             1940
                            
                            Event:           cpu usage
                            Action taken:    none
                            CPU:             144 seconds cpu time over 178 seconds (81% cpu average), exceeding limit of 80% cpu over 180 seconds
                            CPU limit:       144s
                            Limit duration:  180s
                            CPU used:        144s
                            Duration:        14.17s
                            Steps:           15
                            
                            Hardware model:  iPhone9,3
                            Active cpus:     2
                            Boot args:        
                            
                            
                             

                              Attached Files:

                              amandaecg and Typhoon like this.
                            • amandaecg

                              amandaecg Space Hobo

                              Thank you for the information
                               
                              • Davidovich

                                Davidovich Void-Bound Voyager

                                One small bug to report. I apologize if it's been reported. I looked and didn't see it - I entered the fishing contest while at the Stardew Valley fair, fall, year 1, and it froze. The timer ran out and it continued to freeze and I had to force quit. Another issue to report on iPhone, which is related to not being able to see, "New Record." Because the iPhone version is zoomed in, it makes it difficult to search trash cans because NPC's can be out of the field of view but can be close enough to see you rifling through the trash cans. Now, I'm finding myself searching around a can completely for characters before actually searching in the trash. I've been caught several times, unfortunately. Thanks! iPhone 8, iOS 12.1
                                 
                                  Last edited: Nov 2, 2018
                                  Typhoon likes this.
                                • marisse

                                  marisse Space Hobo

                                  Hello. I am still getting crashes in the mines. The most recent was just now, a few seconds after I got the ‘you’re getting drowsy’ text at about 12am in game time. I had a podcast playing.

                                  A couple of times I’ve seen my character move extremely slowly after entering houses(blacksmith, saloon, library). I would tap and the character would literally be inching forward. Just in the houses, able to move about fine after exiting them.

                                  On the second year’s egg festival, there have been eggs I couldn’t tap. Do the locations change every year ? I can see the eggs but tapping on them don’t register on the counter at all. I realise they’re ostensibly all the ones I’ve tapped before in year 1.

                                  A tiny ask but could there be a manual save button please ? I’ve lost count how many days of progress I’ve lost to crashes. Please please please.
                                   
                                  • Drunk Wombat

                                    Drunk Wombat Poptop Tamer

                                    Update:

                                    It appears the crash happens when constructing slime hutch. Although the crash has also occurred on other occasions when not starting construction of slime hutch, it is consistently crashing when I start construction. I tried a few times starting the day and only constructing slime hutch then going to sleep and it crashed every time. It's frustrating because I feel like I can't really progress anymore, game is pretty much unplayable right now.

                                    Another update:

                                    So I’ve been able to continue and save ok without building the slime hutch and everything seems ok. Will try building slime hutch in spring and see if it works.

                                    Last Update (hopefully):

                                    Been able to talk to Robin and build slime hutch all ok with no crash in a different season. Seems the crash happened only in winter upon sleep if you speak to Robin for anything during the day.
                                     
                                      Last edited: Nov 7, 2018

                                    Share This Page