1. Hey Guest! Our new game Wargroove has released! Check out the forums or wiki for more information!
    Dismiss Notice

Bug/Issue Receiving cat- infinite loop

Discussion in 'Support' started by PrototypeRaven, Feb 24, 2019.

Tags:
  1. PrototypeRaven

    PrototypeRaven Big Damn Hero

    Hi guys!
    I've recently started a new game and am at day 21 of the first spring.
    I recently got Marnie standing in front of the house after I leave, showing me the cat.
    The dialog plays as normal, and when I accept it and give the cat a name, the screen fades to black.
    A second later I can see the game again, with Marnie still standing there, the cat still being there, and the dialog playing out from the beginning, like an infinite loop.

    If I say No, I can play normally, then Marnie leaves with the cat. Using this method I successfully triggered the pet-dialog again a few days later, but the problem still persists..
    I also waited a while, and on the wiki it says it has to be between 6 and 9:30 am, but even after that Marnie's still waiting for me outside. I don't think that would work either though, since she'd just show up a while later, probably with the same looping-problem.
    Edit: I created the game as a new coop-game with 1 hut. Not sure if that's relevant. The bug happens both when I start it as singleplayer and as coop.

    Any ideas? I don't have backup-saves, though I'll most certainly start doing those from now on..
    I could play without a pet, but I'd really like one :D
    I also don't think this is a save-file-issue, rather a bug in the code, no?
     
      Last edited: Feb 24, 2019
    • MysticTempest

      MysticTempest Ketchup Robot

      A couple years back another player had a similar issue of the infinite loop pet event. For them, I found that the issue was crafted cobblestone path all over the floor of their farmhouse.

      See the bug report I created here: https://community.playstarbound.com...pen-beta-available.130058/page-6#post-3111766

      Do you by any chance have flooring covering your farmhouse? The bug may have been accidentally reintroduced or perhaps it's something else altogether.
       
        WilliamZ likes this.
      • PrototypeRaven

        PrototypeRaven Big Damn Hero

        Yessssss that worked! Thank you!!
        I had indeed a wooden floor inside. It wasn't covering the tile just where you enter, but I don't think you can put a floor there.
        Just removing the whole floor didn't worked, it still looped; but when I removed the whole floor and spent the whole day inside then slept, that did it. I think the same bug might be at play again here in some form, yes.
        Thanks again :)
         
          MysticTempest likes this.
        • MysticTempest

          MysticTempest Ketchup Robot

          Glad to hear that worked for you! ^-^

          As for needing to sleep a day in-game after removing the flooring; that makes sense. When I found the proper fix the first time, I had save-edited the file manually and removed all the flooring data.
          So, I loaded up the game straight into a day which didn't have flooring. But, it appears that the event is using the data loaded at the beginning of the day, instead of checking at the time of the event.

          But, thanks for confirming. I'll see about making another bug report for this, linking to this thread.
           

          Share This Page