Modding Help How to fix mods broken in Stardew Valley 1.2

Discussion in 'Mods' started by Pathoschild, Apr 12, 2017.

Tags:
Thread Status:
Not open for further replies.
  1. FarmerRen

    FarmerRen Void-Bound Voyager

    I have a ton of those...
    should I unpack the new files and update/repack them manually?
     
    • Borodin

      Borodin Master Astronaut

      Well, whether it's an earthbound Tardis or not, ExtendedFridge should be fixable. The code is the same as that used in all mods, and there are no user-generated art resources involved.
       
      • demonhunter352

        demonhunter352 Subatomic Cosmonaut

        If they're mods others have made, i'd check for updates first. Then, I guess if you feel confident, you can try updating them yourself.
         
        • Pathoschild

          Pathoschild Cosmos Killer

          (Abigail ftw.) Chest Pooling works fine for me with your save. Can you post a comment in the Chest Pooling thread which describes the problem? Attach your SMAPI log and save, and include a list of steps to follow that causes the issue (e.g. go to a specific chest, put a specific item in it, error occurs).

          @demonhunter352 @FarmerRen: Thanks for testing! I can't update the submods since they're not SMAPI mods, so I forwarded what you found to the Entoarox Framework thread. :)

          That type of error is often caused by XNB issues. Try this:
          1. Verify your game integrity. This will remove any XNB mods, but SMAPI mods won't be affected.
          2. Check if the problem still happens. If it does, reply and skip the rest of these steps.
          3. Reinstall any XNB mods you want to keep one at a time until the problem comes back.
          4. Remove whichever XNB mod caused the problem.
           
          • demonhunter352

            demonhunter352 Subatomic Cosmonaut

            With regards to the Advanced Location Loader crashes, for the time being, it appears that using ALL 1.2.8 instead of the current 1.2.10 is a usable workaround. Thanks to @starboundish for finding that! My current list of savefiles aren't advanced enough to see if this will cause issues when the modified locations become available in-game, but at least the game stopped crashing when loading a save.

            EDIT: Bleeeeh. It only worked for one session. Loaded up the next day and boom. Crashing again.
             
              Last edited: Apr 28, 2017
            • ekffie

              ekffie Subatomic Cosmonaut

            • BabeRuthless

              BabeRuthless Tentacle Wrangler

              Hi everyone! For some reason my chests and windows are acting weird. Chests that aren't the original brown color are transparent in color instead of blue, pink, orange, etc. All of my chests can open and be used perfectly fine, its just the appearance that's funky. Also, the appearance of my windows is messed up too. I can see the light rays where the windows should be, but can't see the physical windows themselves!

              Here are pictures of my problem: link
               
              • Entoarox

                Entoarox Oxygen Tank

                Get the proper version of xnb_node to unpack your files rather then the old broken one.
                 
                • nicolemarie37

                  nicolemarie37 Intergalactic Tourist

                • chazwhiz

                  chazwhiz Space Hobo

                  Strange... will do - Can issues like this be platform specific? Works on Windows, error on Mac, etc?
                   
                  • Xuomi

                    Xuomi Phantasmal Quasar

                    Seasonal Immersion still works for SMAPI 1.10 and SDV 1.2. It doesn't work with zip files anymore so you need to extract them into a folder called ContentPack instead.

                    You should check through the official thread because this has been stated multiple times now.
                     
                      Last edited: Apr 27, 2017
                    • shymelody

                      shymelody Void-Bound Voyager

                      Turns out it WAS an XNB mod, though I can't exactly place which one it was, considering I hadn't bookmarked every single one that I had installed, and have likely missed a few in my re-installation. The ones I did re-install were fine, and I'm still surfing nexusmods to see if I missed anything. Perhaps I might've messed up some files in my hasty installation, I'll edit this if I find out. Thank you so much for the help! :nod:
                       
                      • Pathoschild

                        Pathoschild Cosmos Killer

                        It sounds like you have broken or out-of-date XNB textures. See "Missing or broken textures" in the Stardew Valley 1.2 problems & fixes thread on Reddit for a possible fix.
                         
                        • Clotho

                          Clotho Subatomic Cosmonaut

                          More Pets mod?
                          https://pastebin.com/A5ps3KYN

                          I went to the bus stop to look for the box, but it wasn't there. Clicking frantically also didn't help. :slowpoke:

                          Also, I have like 5 billion dig spots that appear on my maps and, no, I don't have a mod for that. I just updated everything. Any idea what might be doing that?
                           
                          • Pathoschild

                            Pathoschild Cosmos Killer

                          • Clotho

                            Clotho Subatomic Cosmonaut

                            oh god... i just formatted my hard drive so i've been scrambling to get everything back up... i'll just go back to my corner.
                             
                            • FarmerRen

                              FarmerRen Void-Bound Voyager

                              I just reverified my files and that was the only thing that fixed me. My problem after all this fixing with removing the Advanced Location Loader, then trying to play in vanilla cause it kept locking up anyway- I still froze and it was the XMB files I SELF MODIFIED.
                              I'm attempting to fix over 105 textures I changed in the original game by downloading portrait mods and the like by splitting them open using ExtractXMB and joining the image file with the new .yaml file.
                              Hopefully it will work out...
                              I can't find the Farmhouse extended I got off Nexus anymore because the author updated it to have other extra stuff too and I just want to keep what I have.
                              Talk about a lot of work...ehh.
                               
                              • Elrohir_of_Rivendell

                                Elrohir_of_Rivendell Void-Bound Voyager

                                You are a force of nature Pathoschild! Thank you so much for updating and managing these mods (and so quickly and effectively)! I came on for the first time since the official 1.2 update expecting most of my mods to be outdated and unplayable, but found most of the affected ones fixed up here. :):laugh:
                                 
                                  Pathoschild likes this.
                                • Chimpanzee

                                  Chimpanzee Yeah, You!

                                  After updating to SV 1.2 and SMAPI 1.10, my mailbox and journal don't seem to be working properly. I load my game (26th Spring, Year 2) and have a notification above my mailbox but when I click on it, nothing happens - the bubble just disappears. I also have an ! in the corner indicating that I have a quest but when I click on it, my Journal is empty and the ! disappears.

                                  I had BirthdayMail installed but I've removed that (and all the other mods) from my mods folder but that didn't fix the problem.

                                  Anyone have any ideas? I'm worried that I'm missing a quest.
                                   
                                  • MysticTempest

                                    MysticTempest Ketchup Robot

                                    Zip up your savefile, and upload it here. Even if you remove the mail mod, the glitchy letter is already in your save data. We can see which letter it is exactly with the save.

                                    Save file locations:
                                    Windows: %AppData%\StardewValley\Saves\
                                    OSX: /Users/yourusername/.config/StardewValley/Saves
                                    Linux: ~/.config/StardewValley/Saves/
                                     
                                    Thread Status:
                                    Not open for further replies.

                                    Share This Page