1. Lose your pre-order key? Try using Humble's key resender. Also, please check the support FAQs before posting: http://playstarbound.com/help/

Tutorial Fixing Lost/Corrupted Universes and Player Files

Discussion in 'Support' started by Trinosaur, Jul 28, 2016.

  1. GCU GreyArea

    GCU GreyArea Orbital Explorer

    I just wanted to thank Iris and Trinosaur for their help and attempts to fix my save files for me, ultimately they are too corrupted to be salvaged but I have a very simple and very important lesson I have learned that I wish to pass onto any who will listen: Backup, backup backup.

    It was something so simple that I had overlooked and I have had to learn the hard way, so, my advice: Learn to do it, do it often and protect your universe(s)! An ounce of prevention is better than a pound of cure. <3
     
  2. Gigadroid

    Gigadroid Space Spelunker

    Honestly, I think Chucklefish should implement the same .bak system that they're using with .player files. When my character got corrupted due to a BSOD, I just simply took the latest .bak and made it to my .player file. It should be AT LEAST that simple (note that going into save file location itself not by choice is already a no-no for games).

    Every time a Save & Quit is pressed, a .bak is made (up to 3) of the universe file, .player file, .world file and every other important data file. This can be a temporary fix to their poor save system while they give themselves some breathing room.

    It also shouldn't take more than 2 days to fix this (they're potentially losing players for days or even weeks by letting this issue continue).
     
  3. Nekobi

    Nekobi Void-Bound Voyager

    Yup, they lost me, for example.

    If I saw this post earlier I would not lose my universe... Forever. (See: http://community.playstarbound.com/threads/starbound-1-2-vault-update.127778/page-3#post-3075762)
    But I acted poorly, and with haste I destroyed everything of my own! *slow clap*

    They HAVE to fix this bug, I didn't even know it happened to so much people... It's crazy and terrifying. This doesn't seem so hard to fix (maybe it is, everyone don't know how the game exactly works after all)...

    I'm a bit mad at them. This isn't their faults, I know, but... I had so much hope in this game long ago, when I knew the game even before we could pre-order it... I don't want to play it anymore, sadly.
    I tried the 1.2... Nope, didn't have fun, sorry, and with the bug, I don't think I want to play ever again... Every time I'll come back, I will think of my lost save.


    EDIT:
    I totally agree with you, I think this would be the best solution for now (plus telling people it could happen and how to fix it, with a visible message. Rather than leaving a slightly hidden thread filled with people, unanswered by the devs, who are trying to help...)
     
    Last edited: Dec 17, 2016
  4. Galactic Avatar

    Galactic Avatar Scruffy Nerf-Herder

    Leh sigh, it happened to me again. comp went out for a second due to power outage and bookmarks were lost. Good news: It was a new character I had only actually been on one planet and had just moved to another one (don't even have fuel yet). So it wont be that hard to 'repair'.

    Except for the fact that now I have to find a forest planet, get tungsten, go to a moon, get fuel, and during all of that hope my comp doesn't go out again. Or I will have to repeat said process ad infinitum.

    I really wish they would fix this issue or at least acknowledge it. I took a long break from the game hoping they had fixed it. It appears they have not.

    Edit: It's worse than I thought. It wiped everything for both characters I have and I didn't realize it. So I copied over my back up files for my main PC.... sigh..... and it will take me forever to find all the stuff I need to find (expecially teleporter locations.

    I think im going to have to just stay away from Starbound until I can get a more reliable PC or they fix this issue.
     
    Last edited: Dec 30, 2016
  5. LightcasterDL

    LightcasterDL Space Spelunker

    OK, so this has happened to me twice so far due to power issues (I live in Canada and it is winter, so they happen). First time I simply followed the steps to return to my home world, and everything seemed to work fine after that (I hadn't done too much at that point yet.) but this time none of my farm animals were producing (per the known issue) so I tried killing them with a lava ball, as well as by spawning lava (after restoring my save), only for the game to ctd. Tried re-opening the game, ctd every time. I AM using the Frackin' Universe mod, and I AM also running my own server with this mod on it, but is there anything I can do? I backed up my storage folder before trying anything and sent the info on to chucklefish, but I'm not really sure how to use JSON (Haven't looked into it yet, I do know how to navigate the cmd and know basic Java, so I believe I could figure it out if I had to, but don't feel like it right now as I am already busy doing other things). If anyone comfortable with JSON wants to take a look at my saves I would be more than happy to provide them, and would be very grateful! :p
     
  6. Mojo77

    Mojo77 Intergalactic Tourist

    Hi all,

    I experienced a power cut and when i restarted my character was still there but i was on my way to a random planet and i had lost all of my bookmarks. Through unfinished quests i was able to track down my home planet and the surrounding planets and all of my flags were still there so i just had to find them to activate them again. Quests were still there but the direction arrow no longer worked. I thought that was all i lost until i realised my outpost bookmark also wasnt there and when i went to the outpost all of the shops were shut and the characters that had joined the outpost, Nuru, Koichi and Tonauac were no longer there either. I read through this thread and i have just completed the erchius mining mission again and when i went back to the outpost a couple of the shops had opened but there was no Nuru etc.

    Does anyone know how i can get these characters back to the outpost?

    Also my fluffalos and tenants dont seem to be working either.

    Thanks a lot.
     
  7. TheBlackSun

    TheBlackSun Orbital Explorer

    Super late, but whatever: Usually you can use the tutorial in the first post to fix that kind of stuff. What happened there is your universe got corrupted, and a new one was created where none of your progress ever happened. The planets are saved seperately though, so all the stuff you built was still there. Same for your ship, inventory and character. If you follow the tutorial and replace the UUID in your player file with the new one, every bookmark should be back, and using commands to restore outpost missions does the rest.

    However,
    I've got a very strange issue where my bookmarks won't show even after having the right UUID replaced for the bookmarks. The universe content, as in the worlds / planets, have been transferred to another server but the outpost missions have been reset to allow new players to play these. The world files have been migrated, the bookmarks have the new universe UUID, yet they don't show up. And I cannot just find all of these again. I've tried to find one asteroid base for the past hour, not a chance. I need to have coordinates in the world, or an editor where I can see the whole world to locate the base, but trying to "just find" it is as helpful as trying to get a complete picture of Lady Liberty through a magnifying glass while leaning against its base.
     
  8. stephanyortega

    stephanyortega Space Hobo

  9. stephanyortega

    stephanyortega Space Hobo

    When looking for the coords of the planets are you looking in giraffe_storage or storage? The coords of giraffe_storage will not work.
    Spaze Apparel D475 Sweater
     

Share This Page