1. Thanks for visiting! These forums are for the original Risk of Rain, if you're interested in discussing the newly released Risk of Rain 2 head over to that game's steam discussion forum
    Dismiss Notice

Bug Thread Risk of Rain 1.0.0

Discussion in 'General Discussion' started by Vizjun, Nov 8, 2013.

  1. needsomemiracle

    needsomemiracle Scruffy Nerf-Herder

    The same happens around 7:45 in Rawrquaza's latest letsplay (part 72).
    • GeminiTrinity

      GeminiTrinity Space Hobo

      I've only played co-op so far, but my monster kills remain at 0 whereas my boss kills go up as normal.
      • Raruna

        Raruna Space Spelunker

        Incredibly annoying problem: me and my friend could play together on, but on Steam, it refuses to work.
        To make matters worse we had to use god damn Hamachi to get anything working in that early build, and as soon as we tried it on the launch version, it doesn't work anymore. Been trying to get this stuff to work since yesterday, getting mad as hell about video games ):<
        • Burby

          Burby Phantasmal Quasar

        • SPLlT

          SPLlT Big Damn Hero

          Was playing multiplayer with some other friends then this happened:

          I think we killed a monster when this happened.
          This is what my error log says
          ERROR in
          action number 1
          of Other Event: Animation End
          for object oEfExp:
          Error in code at line 1:
            if used=1
          at position 4: Unknown variable used
          • Masterrulax

            Masterrulax Subatomic Cosmonaut

            Or you chould just use Hamachi/Evolve client lol
            Disable Firewall or Allow the program tru it.
            • SPLlT

              SPLlT Big Damn Hero

              Actually a friend and I tried to use evolve and it didn't work out for us.
              • Raruna

                Raruna Space Spelunker

                Sadly, this isn't the issue. The new build does not agree with my BR router from Vivo. In the earlier build I could host through Hamachi despite the game saying the 11100 port was closed. In the new one, I cannot.
                It's really bothersome, because since yesterday I've been trying to get this thing working, and when I do find a solution, it doesn't work on the full game!

                Edit: WELL THEN!
                Not even is working now. Fun times all around.
                Edit Edit: Somehow it worked now with my friend hosting 6u9?!?
                  Last edited: Nov 11, 2013
                • Shrooblord

                  Shrooblord Void-Bound Voyager

                  Hey guys! Looking great. I loved the intro!

                  Anyway, on to bug reporting:
                  The stages still have some missing geometry - in the first Forest stage, there's holes in the walls in several locations where I'm pretty sure there shouldn't be. They look like some tiles weren't filled in properly. ;)
                  • NoGod

                    NoGod Void-Bound Voyager

                    If you rebind the controls the game shows the default controls at the start of the game when you click on Play instead of the new ones. It does tend to show all the proper ones for prompts later that I have seen. Kind of surprised at the default controls actually. It's like it was set up for a left-handed player. IT might make sense to have a swap for a right handed player too. PErsonally, I changed the movement keys to WASD and made the arrows into the weapon keys. After playing massive amounts of games like Binding of Isaac I find using the arrow keys to move to be really difficult and backwards.
                    • needsomemiracle

                      needsomemiracle Scruffy Nerf-Herder

                      Wow, talk about hailstorm.
                        Alucard I likes this.
                      • yonatan

                        yonatan Aquatic Astronaut

                        whenever i play and i am fighting enemies from a teleporter my character stops being able to move unless i use my mouse and click the screen i know it sounds like it doesn't matter but it ends up killing 90% of my runs i can even have full hp but in the time i am clicking i get swarmed and die it has stopped me from beating the game twice its infuriating so devs can you please fix this(i realize this might be a problem with the keyboard or the mouse and not the game but its worth a shot just t try to fix it) this is seriously ruining the game for me and it makes me sad because i love this game so much when it's working.
                        • Vession

                          Vession Title Not Found

                          I used a shrine late into a long playthrough as commando, and this happened:
                          Without all the clutter, it's easier to tell that those long green lines are broken healing drones:
                          Before this happened, I used the shrine in the top right. The game froze for a bit and I was teleported to where you see my commando in the first picture, and fought on for about 2-3 minutes at 3~ fps until I was able to pick all the money up. The fps has evened out at about 7-8 now. I'm able to repair the drones, though they DO cost $54908 each... also, those golems are headless. Looks like there's an alien inside wearing it as a suit.
                          On to the next level, everything seemed fine. Then it happened again, the game became unresponsive and I ended the process 5 minutes later... and lost my scores. Damn.
                            Last edited: Nov 11, 2013
                          • Stovepipes

                            Stovepipes Void-Bound Voyager

                            Should a new thread be created for v1.0.1 or should we continue to use this one?
                            • TheGamaniac

                              TheGamaniac Master Chief

                              E: Both of these bugs are from version 1.0.1.

                              If a character picks up 2 Chargefield Generators, the item stops working entirely. I'm not yet sure if it happened because i picked one up while the effect of the first was still going, as this is the first time i've had more than one.

                              The Huntress' Strafe is missing Tiny Imps even after their size increase. It's not much of an issue for her since she still has Cluster Bomb and Laser Glaive to work with, but it's still around.
                                Last edited: Nov 11, 2013
                              • Chrystolis

                                Chrystolis Tentacle Wrangler

                                Was playing Engineer tonight and had the stopwatch item (The name escapes me at the moment, but it's the watch that freezes time for 7 seconds). On stage 3 (it was the arctic stage), I had Ifrit spawn as the boss in the very upper-right corner of the map. When I used the watch to freeze time, he'd been moving to the right, and then he glitched and kept sliding to the right, even though he was frozen in time by the watch. He quickly slid off the right side of the stage, and it counted him as dead immediately when he did. Can't complain at the results, but wanted to report the issue :]
                                • Ch1nGFuX

                                  Ch1nGFuX Starship Captain

                                  Killing a boss with Lights Out unlocked on Bandit by killing a Colossus (Rock Golem boss).
                                  • Saishy

                                    Saishy Void-Bound Voyager

                                    - Players who already have a monster log will not see them but still be able to grab it.
                                    - Sometimes unlocking an achievement will unlock for some people in the party and not for others. (Notably, I unlocked the sniper 10 kill in one-shoot for 2 people in my party but not for myself and another friend)
                                    - Changing your active item will sometimes not update for other clients, meaning that for everyone you still have your old item and your new item is still on the floor to be picked. (Neither the new item can be picker nor the effects of the old item works for other clients)
                                    - When time is stopped, elite teleporting mobs will still teleport around. (Notably, yellow parents still doing teleport attacks while not playing animations)
                                    - (Anomaly?) If you lag you can take damage from monsters that are not near you.
                                    • TheFatWhiteOne

                                      TheFatWhiteOne Space Hobo

                                      So I have this weird problem where my game crashes whenever I attempt to join the mushroom level (2nd level), my game crashes. As you could imagine this makes the game essentially unplayable. I made a thread late last night over here: http://community.playstarbound.com/...shing-upon-entering-the-mushroom-level.32483/

                                      I checked through this thread and found nothing to be of any relation to this issue.

                                      Here are some of the things I have tried (copy and pasted from my linked forum post):
                                      -Reinstalled the game
                                      -Used steam's "Verify Integrity of Game Cache" function (nothing came up)
                                      -Restarted my computer
                                      -Reinstalling the vcredit file inside of the _Commonredist folder
                                      • SPLlT

                                        SPLlT Big Damn Hero

                                        Was playing multiplayer with some other friends then this happened:
                                        Another player activated the teleporter before my it had loaded for me.
                                        Perhaps my character had difficulty changing maps?
                                        This is what my error log says
                                        ERROR in
                                        action number 1
                                        of End Step Event
                                        for object oTurtle:
                                        Error in code at line 12:
                                        if (x>(lava_parent.x+min(1228,lava_parent.width_b*16))-100) || x<(lava_parent.x+40) //|| place_meeting(x,y,oNoClimb)=1
                                        at position 21: Unknown variable x

                                        Edit: Image URL fixed.
                                        Image should show players stuck on the top left corner of the screen, unable to move.
                                          Last edited: Nov 12, 2013

                                        Share This Page