Wineskin wrapper for Mac

Discussion in 'Support' started by DandoCalrissian, Mar 8, 2016.

  1. Isaia

    Isaia Poptop Tamer

    Hi everyone,
    First of all I want to thank Dando and everyone involved in making this possible, otherwise I wouldn't have been able to play the game at all.
    I was able to play the game until Fall season, but the first day of fall when I turned my game on I kept getting this message everytime I would load my save file:
    Screen Shot 2016-03-15 at 3.20.40 AM.png

    I tried re-doing winetricks and reloading the game all over again but it doesn't seem to be helping.
    I am Mac OS X 10.10.5
    I'm very new to code and am not sure how it works, and would appreciate help, it's been bugging me because I feel like i'm overlooking a simple step that I'm very unaware of. Thank you and hope you all have a good day.
     
      Last edited: Mar 17, 2016
      Martianhunter likes this.
    • DandoCalrissian

      DandoCalrissian Astral Cartographer

      You will want to install those as they are the redistributables needed to get things running properly in Wine for Stardew!

      Double-check the Windows EXE text field and, if it's blank, set it up to point to the right exe file per the instructions for Steam or GOG, depending on what you're using.

      That is strange! Did you install Steam already in the wrapper? If not, try trashing the wrapper and re-downloading to start fresh. Sometimes starting at step one can solve all the problems :)

      Hm, odd... You can try navigating to /Users/myname/.cache/winetricks/dotnet40 and renaming that exe file and see if it will install after doing that as it will force a re-download of the exe file. If that doesn't work, try pressing the Update Winetricks button in the bottom-right of the Winetricks page to see if that helps. It's possible the exe got corrupted for some reason and Winetricks is complaining about it. You will need that to install properly in order to play, so resolving this issue is important.

      Arg, I just want this to work for you! Try opening the wrapper and pressing the Set Screen Options button and unchecking the Use Mac Driver instead of X11 box (I think that's what it's called) and see if you can run the game after that. If not, try installing Steam by setting the Windows EXE field to point at the SteamSetup.exe file and then hitting Test Run and see if it installs that way. That has worked for me in the past with weird installers, so it's definitely worth a shot!
      I see some glsl errors which makes me think some of the graphics settings may have gotten messed up in the wrapper. Your best bet is to start a fresh wrapper and see if that helps.
       
        Isaia likes this.
      • Isaia

        Isaia Poptop Tamer

        Hi Dando
        Hi Dando, thanks for helping everyone out,
        I wonder if other people have been having the same problem as I have,
        if it helps the error in Wine seems to be:
        and I saved the bug in txt

        Unhandled exception: 0xe0434352 in 32-bit code (0x7b82d9b2).

        I'm not sure what this means (RIP) but I'm wondering if this has anything to do with it. :O
         
        • Pfeily

          Pfeily Space Hobo

          First Run, perfect. Was playing the game for 6 hours yesterday.
          Today I tried to load my savegame and it always crashs and im back in steam.
          Creating a new game works but i cant load my savegame :(
          any ideas?

          Other Question: How can i find my Save file on mac to keep my save game ? :)
           
            Last edited: Mar 17, 2016
          • BL4ck

            BL4ck Space Spelunker

            Hi, after i playing game for 4 hours. I exit game and when i play again my save game is deleted @@".... Is there have this problem like me?
             
            • Pfeily

              Pfeily Space Hobo

              Same. Its not deleted. I can see the save game but if i want to load it, it crashs.
               
              • carter1l

                carter1l Space Hobo


                Hey Dando,

                Thanks for getting back to me! I copied and pasted the appropriate text for steam as per your instructions. Once its in the Windows EXE Window all I have to do is exited out of it right? Theres no "apply" button or anything right?
                 
                • PurpleLine

                  PurpleLine Void-Bound Voyager


                  I feel like I am having a similar issue with my game as well.
                  I made it to the second year no problem but then all of a sudden when I would go to bed for the night this error popped up before it would calculate my earnings. But if I put nothing in my box I could save and proceed to the next day as normal. Also that day I proposed to the NPC I wanted to marry and Penny had a cutscene when I entered town that day, I don't know if these things may have caused a problem...

                  I am positive I followed the directions exactly, I tried to update winetricks as the response to this post suggested but I'm not sure if it worked or if anything happened.

                  Anyway, thank you all for your help and making it possible to play this game, I have really enjoyed it so far!
                   
                  • shiraface

                    shiraface Yeah, You!

                    I tried doing the steps in Lion, and was having a lot of issues, but I just updated to El Capitan last night, and got it to work perfectly! I tested it out with my bf's steam + game before I bought my own copy. Here's hoping I won't run into future issues. Thanks so much for this! :nuruhappy:
                     
                    • csnaught

                      csnaught Intergalactic Tourist

                      Thank you for all your work. I hope you will be able to help me figure this out... I have been having trouble with the first step, DLLs not implementing correctly, it says it wants to open a window but can't find a driver. Only a problem with the last 4 on the list, doesn't seem to matter what order I do them in. This is happening with the wrapper linked in the first post, but not when using a "plain" version of Wineskin -- when I use that "plain" version I can get as far as starting Stardew via Steam before it tells me there is a problem with my graphics card. I'm running OS X 10.7.5. My head is spinning. Any suggestions would be appreciated!
                       
                      • annia316

                        annia316 Void-Bound Voyager

                        I have the same problem from time to time. My save file disappears from the loading menu. I have to restart the wrapper like 10 times until it works again. I noticed, when you get the little text tipps on the start screen (when the logo of concerned ape appears) the load files are working and when the tipps are missing the load files won't appear either :( Very strange.
                         
                          BL4ck likes this.
                        • sadhammer

                          sadhammer Lucky Number 13

                          Hi guys,

                          I was finally successful after hours trying fruitlessly. I am on Lion/10.7.5. The problem I had seemed to be that tasks that required a window to open (Steps like installing Steam and installing some of the winetricks) would not work. For some reason, Wine could not open the installer windows. Winetricks would hang when trying to install items like XNA and the dotnet40.

                          Things suddenly started working for me after I used "Rebuild Wrapper". I would suggest to @csnaut and anyone else having issues on Lion try that. (I know close to nothing about Wineskin and I don't know if it was a coincidence that things started working after I did this.)

                          Thanks so much Dando!!
                           
                            csnaught likes this.
                          • MrPlazmaDude

                            MrPlazmaDude Space Hobo

                            -Edit 2 (fixed): I got it working. Maybe I miss read something, but I was able to get it all working fine by installing each dll separately. When I checked all of the dependency dll boxes the first time, I was having troubles.

                            I followed all of the steps including prep and even a few solutions you already helped others with but I'm still having issues getting the game to launch. Steam launches just fine, the game downloaded, but when I click play, it says Running, Syncing, then it doesn't do anything from there.

                            I also went through the steps you provided for pandahatbear on page 1:

                            No luck after that. Thanks a bunch.

                            -Edit: Added the winetricks dll install log. I decided to try and blow away the wrapper and try again. This was the output.
                             

                              Attached Files:

                              Last edited: Mar 19, 2016
                            • csnaught

                              csnaught Intergalactic Tourist

                              Thank you sadhammer! "Rebuild Wrapper" solved the window-opening problem for me too.
                              I got all the way into Steam before running into the same loading-syncing-nothing error that MrPlazmaDude described. Re-ran those three DLLs, tried again and... "No suitable graphics card found. Could not find a Direct3D device that supports the XNA framework Hi-Def profile." Sounds like what pandahatbear described earlier in the thread but it seemed like that had been resolved? --- ETA I tried changing wineskin screen options to "use Mac driver instead of X11" as suggested elsewhere; no luck, same "no graphics card" error.
                              Attaching logs -- I could only figure out how to save them as pdf, so I hope that is okay.
                              Thank you to everyone who has contributed to this treasure trove of information so far. I hope to get this figured out because I really want to play... :)
                               

                                Attached Files:

                                Last edited: Mar 21, 2016
                              • Clete2

                                Clete2 Space Hobo

                                First of all, THANK YOU for making this wrapper! It's great!

                                Do you have any tips to decrease lag in the game? When the screen is panning (like when I am running around town or in my farm), it's stuttering a good deal. The computer is not maxed out in CPU power and definitely not GPU (I have a NVIDIA GeForce 330M, not great, but it can handle this game). Any tips for improving performance?

                                Decreasing lighting quality does not help.
                                 
                                • Ainey33

                                  Ainey33 Orbital Explorer

                                  How did you make StormLoader.exe run :)
                                   
                                  • annia316

                                    annia316 Void-Bound Voyager

                                    I noticed that I forgot to install the msxml3 .. the one where you gotta download a file from the website first. But the game still worked fine for me before the problems with the save file started. This didn't change anything though. I easily restarted the game 15 times today and my save file never appeared again. I tried to start a new game and stardew valley crashed :( So I am pretty clueless now.
                                     
                                    • LeonBlade

                                      LeonBlade Phantasmal Quasar

                                      You just do everything like normal to install it, and in the wrapper settings instead of having it run the EXE for the game, you just have it run StormLoader.exe
                                       
                                      • Ainey33

                                        Ainey33 Orbital Explorer

                                        Did you make your own build?
                                         
                                        • LeonBlade

                                          LeonBlade Phantasmal Quasar

                                          Yes, what error do you get when you try to run it?
                                           

                                          Share This Page