1. This forum is primarily for mobile related issues - for support for PC/Console visit the support section of forums.stardewvalley.net

Wineskin wrapper for Mac

Discussion in 'Support' started by DandoCalrissian, Mar 8, 2016.

  1. DandoCalrissian

    DandoCalrissian Astral Cartographer

    Hi everyone! I, like many of you, have been working hard to get our beloved Stardew Valley working properly on a Mac. Well, with @MonokelPinguin's explanation of the directx patch, and @jeregrine, @haxd, and @huecester's huge efforts and successes, I managed to get the Steam version running! This also led me to compile a Wineskin engine and bundle everything up to make it easier for those who are having troubles getting things up and running.

    So, without further delay, here is how you can set up the Wineskin wrapper!

    NOTE: If your wrapper is working fine, don't worry about the updates. They are strictly for compatibility at the moment.

    My wrapper was not updating the game in Steam even though the patch downloaded, but I was able to resolve it by doing the following:
    1. Right-click the game in Steam and select Properties
    2. Click on the Local Files tab and press Verify Integrity of Game Cache
    3. It will show a progress bar, once it is done, exit out of these windows and run the game
    You should now be in v1.05! I'm not sure what to do for GOG, so you may need to just re-download the game and install it again in order to upgrade to v1.05.​


    Get your wrapper prepared! (DO THIS FIRST OTHERWISE THE GAME WILL NOT RUN!)
    1. Download the wrapper here: https://www.mediafire.com/?cktru580l85r14n
    2. Unzip the file
    3. Double-click the file
    4. Deal with your Mac complaining at you about Unknown Developer claims (see the Some Notes! bullet below)
    5. After opening the wrapper, select Advanced, click Tools, and then Winetricks
    Select the following to install (all can be found in the dlls section) and then press Run:

    The bolded ones are very important!

    You wrapper is now ready for Stardew Valley!​

    To install using Steam (if you haven't done the "Prepare your wrapper" steps, go back and do them!)
    1. Close the Winetricks window (if open), and click Configuration on the Wineskin window
    2. Use the Install Software button, select Choose Executable, and then point it to a downloaded copy of SteamSetup.exe you obtained from www.steampowered.com clicking on the Windows button under the green install button, or by using this direct link: https://steamcdn-a.akamaihd.net/client/installer/SteamSetup.exe

    3. Sign into Steam
    4. Download Stardew Valley
    5. Run Stardew Valley
    6. Click through any errors or install prompts that pop up. There is one regarding a Directx library not being found and then a brief install of xna, but then it should be smooth sailing after that.
    7. Once the game is confirmed running properly, quit Stardew Valley and Steam
    8. On the Wineskin window in the Windows EXE field, either press browse and find the Steam.exe yourself, or copy this into the "Windows EXE" text field: /Program Files/Steam/Steam.exe

    9. You can now exit the wrapper and open the game normally by double-clicking the wrapper
    10. Play the game! Love the game! Spend "too many" hours playing the game!
    11. (Optional) Give Dando (me!) a high-five!

    To install using GOG (thanks @huecester and @animaster!) (if you haven't done the "Prepare your wrapper" steps, go back and do them!)
    1. Download and unzip the file from GOG
    2. Right-click the wrapper and choose "Show Package Contents"

    3. Double-click the 'Wineskin" app
    4. Press "Install Software"

    5. Press "choose Setup Executable"

    6. Find the GOG installer for Stardew Valley and double-click it

    7. At the end of the installation process, you will be asked to install "Microsoft XNA Framework 4.0". Proceed through the installation as normal (Error messages will pop up and you can ignore them)
    8. After it's done it should go back to the Wineskin "Install Software" window. Press Cancel in the bottom right corner
    9. DO NOT click the "Launch Game", but click on "Exit" for now to close the installer.
    10. Press "Advanced"

    11. Either press browse and find the Stardew Valley.exe yourself, or copy this into the "Windows EXE" text field: /GOG Games/Stardew Valley/Stardew Valley.exe

    12. Click on "Test Run" to test whether you can successfully run this game

    13. After you confirm that Stardew Valley can be run properly, you can "Quit Game" and close this "Wineskin Advanced" window
    14. Now you can close down the Wineskin app and launch the game as you would any other by double-clicking the wrapper

    Stardew Valley Mac Wrapper X-Box Controller Guide (thanks /u/Panx, /u/c99koder, and /u/moonwalkinonthesun!)

    1. Download the Stardew Valley wrapper, if you haven't already, and follow all the listed steps to get Stardew Valley successfully running on your Mac.

    2. Make sure your X-Box controller generally works with your Mac. I used the most recent version of the TattieBogle 360Controller driver (https://github.com/360Controller/360Controller/releases), and can confirm it works with a third-party Rock Candy controller.

    3. Get X360CE v. -- I downloaded it here(http://www.emutopia.com/index.php/item/905-x360ce-2-1-2-191). Unwrap it to an easily accessible directory (the unwrapped file should calledX360ce.exe)

    4. Right-click on the Stardew Valley wrapper (it should be a chicken icon if you haven't changed anything) and choose "Show Package Contents." From there, double-click on the Wineskin icon to boot Wineskin up.

    5. Once Wineskin is booted, choose "Install Software" from the main menu. Then, click "Choose Setup Executable" and navigate to theX360ce.exe file you unwrapped earlier. This should launch the X360 configuration tool.

    6. If the tool boots up properly, it should offer to create 2 files:X360ce.ini and xinput1_3.dll. There's a small chance it might throw an error here: Could not load file or assembly 'Microsoft.DirectX.DirectInput." Personally, I got this error from installing the "xinput" dll with Wineskin by accident. If that error pops up, go to Step 7. Otherwise, go to Step 8.

    7. If you get the error mentioned in Step 6, you have a few options for fixing it. The best way is to download the DirectX runtime package (http://www.microsoft.com/en-us/download/details.aspx?id=8109) and the Visual Studio 2013 runtime package (http://www.microsoft.com/en-us/download/details.aspx?id=40784), and then install them via Wine, in the same way you ran theX360ce.exe previously. Alternatively, you can find additional instructions for fixing the error here (https://appdb.winehq.org/objectManager.php?sClass=version&iId=31736). This second fix requires you to use Winetricks to first install dotnet35 dotnet40 vcrun2010, and then doing a second, separate install of directx9. For me at least, I had to delete my entire Stardew Valley wrapper, re-download it, install the first 3 libraries (dotnet35 dotnet40 vcrun2010), then install directx9, and finally install the rest of the required dll's listed in Dando's thread before I was able to get X360CE to run after I'd borked the process by accidentally installing xinput.

    8. Once you haveX360CE running properly, allow it to automatically create the two files you'll need:X360ce.ini and xinput1_3.dll. From here, you can map each input button by clicking the corresponding dropdown menu, selecting Record and pressing the appropriate button on your controller; however, I just used the inputs from c99koder's PNG (https://www.dropbox.com/s/zns01nbibdsm54o/Screenshot 2016-03-09 10.55.18.png?dl=0) and everything mapped perfectly. For the record, I'm using a Rock Candy X-Box 360 controller, not an official X-Box controller, so I believe these mappings are entirely general.

    9. Once you have the mappings set, hit Save. This will update theX360ce.ini file, which will be saved to the same directory as theX360ce.exe file. An xinput1_3.dll file will also be created in the same location. Copy both yourX360ce.ini file and your xinput1_3.dll file, and then navigate to to your Stardew Valley .exe directory (typically, it will require you to "Show Package Contents" on the chicken icon like before, then go to drive_c/Program Files/Steam/steamapps/common/Stardew Valley) and paste both files.

    10. Launch Wineskin again (Right-click the chicken, "Show Package Contents," then double-click Wineskin), click "Advanced," then click the "Tools" tab, and then open the "winecfg" utility. Click the "Libraries" tab, and add a new override for "xinput1_3". Click the "Edit" button, and set the load order of the newly created override to "Native". Click "Apply" to apply your changes.

    11. Close out of Wineskin, then launch Stardew Valley as normal (double-clicking the poor, harassed, repeatedly clicked chicken) -- your controller should now work just fine! :)

    Some Notes!
    • Your Mac is probably going to complain about the file being from an unknown developer (unless you have disabled said complaining). You can get around this by going to System Prefereces > Security & Privacy and either clicking the Open Anyway button if you just tried to open the file, or you can click the lock in the bottom-left and set the 'Allow apps downloaded from' option to Anywhere, open the app, and then set it back after it's all up and running. Either way should work fine and really you should probably be used to the message if you've been using a mac for more than a day or two.
    • I will do my best to help accommodate anyone who is having troubles, but I do have a day job and family and can't be lurking the forums 24/7 (as much as I would like to :D). Plus, I want to play Stardew, too!
    • There is no way I can guarantee that this will work for everyone, but I will do my best to fix what I can to try and make it as compatible as possible. If it just doesn't work after troubleshooting, then you're going to have to wait for an official Mac version or get set up with some fancy Bootcamp action.
    • Lastly: I cannot be held responsible for any damage that comes from using this wrapper! This is just a disclaimer to cover myself in the event that the wrapper makes your computer catch fire, throw your cat, spills coffee in your lap, etc. More than likely nothing will happen other than being able to play an awesome game on your Mac :D


    "X isn't working" or "I'm getting Y error"
    Make sure you went through the "Prepare your wrapper" section of the installation instructions! If you skip that, you're going to have issues running the game. You can still go back and perform those steps if they were skipped. If that doesn't seem to do the trick, delete the wrapped and start over starting with the "Prepare your wrapper" section.

    The Steam Store page, achievements page, etc. are all blank!

    This is a known issue with Wine at the moment and there is no solid solution as of right now. Just go to the Library tab and you can install and play Stardew Valley as expected. If you haven't purchased Stardew on Steam yet, either use the Steam website or the Mac Steam client to purchase it and then install it using Steam in the wrapper.


    I found that using the Mac driver instead of X11 will allow the game to scale properly when adjusting window size. You can enable this by doing the following:
    1. Ensure that the game is closed fully. If it isn't closed, the change will not take effect
    2. Right-click the wrapper, click Show Package Contents, and double-click Wineskin
    3. Click Set Screen Options
    4. Check the box next to Use Mac Driver instead of X11 and hit done
    This lets the game scale properly for me when changing the window size and reduces the flickering in Steam to almost none. If this doesn't work for you, just uncheck the option and move along!​

    If you're having trouble installing dotnet40 and/or xna40 (thanks @animaster!)

    For those who attempt to install dotnet40 and xna40 and are having trouble, you can try installing the "msxml3" first. I had a problem with dotnet40 installation on another wrapper (not this game though) and installing the msxml3 before (re)installing dotnet40 and xna40 resolved that issue.

    I don't have any sound! (thanks @Longbottom!)

    If you're finding yourself without sound, try the following steps:
    1. Right-click Stardew Valley.app and click Show package contents
    2. Double click Wineskin then click Advanced
    3. Enable Use Start.exe (tiny checkbox under the Windows EXE field)

    If you don't see your issue listed above and are having troubles getting things to run...

    Get some logs! You can do this by following these steps:
    1. Right-click the wrapper, click Show Package Contents, and select Advanced
    2. Click Test Run at the bottom of the window
    3. Try to run Stardew Valley as you normally would
    4. Exit the program and you will be prompted to view your logs. Do so, save them, and attach them with your issue as a reply

    I hope you all enjoy this! Thanks to everyone for being awesome and working together to make this thing happen <3
      Last edited: Mar 15, 2016
    • lurker_lord

      lurker_lord Intergalactic Tourist

      Hi Dando,

      Thanks for the post. It really works!
      Now I can use Steam to install/play the game. The problem is, once I quit the stardew valley + steam and restart it again, all the saving are gone. If I only quit stardew valley but keep the steam alive, the savings are still there when I restart stardew. So the problem seems to be once steam is exited, there is no savings.

      Do you know what might go wrong? thanks
      • DandoCalrissian

        DandoCalrissian Astral Cartographer

        Hm, that is one I haven't heard yet! I'm personally able to save, exit, and come back with the last save being available. Cloud saving is also working properly in Steam so I can play on my PC when I get home on the same save.

        Where do you have the wrapper saved? It could potentially be a permissions issue if it isn't saved in your home directory or saved somewhere that you're allowed write access. You may also want to just try a good ol' fashioned restart of your computer and see if that helps.
        • Pizza Elemental

          Pizza Elemental Space Hobo

          Thanks for this, fantastic work! I have a couple notes that might be helpful to others:

          I had trouble installing msxml3 in winetricks, had to go download that manually from http://download.cnet.com/Microsoft-XML-Parser-MSXML-3-0-Service-Pack-7-SP7/3000-7241_4-10731613.html, enable hidden folders, and then drop it in the msxml3 folder in the wineskin's package contents as per Wine's instructions. Not sure if that's normal procedure or just me.

          Also I was not able to install dotnet20sp2, it always crashed out. Doesn't seem to affect anything, however.
            Fendra_Farmer likes this.
          • Longbottom

            Longbottom Void-Bound Voyager

            I'm happy to report SUCCESS on Mac OS X 10.11.3 with the GOG version!

            Here's what I did (bolded instructions are ones that I added based on Dando's)

            1. Download and unzip the wrapper
            2. Right click wrapper > Show package contents
            3. Double click Wineskin
            4. Click Install Software
            5. Choose setup executable > GOG Stardew installer
            6. The installer gets to XNA setup I CLICKED CANCEL then FINISH and the GOG installer completed with its usual errors (just click OK until they go away)
            7. Click Exit on the GOG installer DO NOT LAUNCH YET!
            8. The Wineskin screen had me click OK to confirm the path of the executable
            9. Open the Wineskin Advanced panel
            10. Point the Windows EXE to your "/GOG Games/Stardew Valley/Stardew Valley.exe"
            11. Click the Tools tab
            12. Click Winetricks
            13. Install the following in order:
              1. msxml3 (will have you go to a website and download the file, then place it in a directory and install via the Winetricks window again)
              2. dotnet40
              3. xna40 (you may get an error about not supported by blah blah blah just ignore it)
            14. Do a test run!
            I hope this helps. This is on a Macbook Air with Intel HD Graphics 5000.

            Note: The game runs fine (for Wine anyway), however I seem to have no audio. If anyone has any suggestions, let me know!

            Edit: Fix for no audio/sound in Wine: Right-click Stardew Valley.app > Show package contents > Double click Wineskin > Advanced > Enable Use Start.exe

            Everything is working!
              Last edited: Mar 8, 2016
            • aureatation

              aureatation Big Damn Hero

              Hi! Reporting here that it works on my late 2011 Macbook Pro, 10.10.5 Yosemite with Intel HD Graphics 3000.

              Major thanks for providing this! I can't wait to start playing. Nostalgia from Harvest Moon, here I come!
              • DandoCalrissian

                DandoCalrissian Astral Cartographer

                I'm glad it's working for you! Did you have to perform the bolded steps even though those should have been installed in the "Prepare your wrapper" section? As for the no sound, I would say go through the list in the "Prepare your wrapper" section and just try to install them all again and see if it helps.

                EDIT: Added your steps to get audio working to the Troubleshooting section!
                  Last edited: Mar 8, 2016
                  Longbottom likes this.
                • WinnieStuff

                  WinnieStuff Seal Broken

                  I can confirm that the mac driver option fixes the "zoomed issue" on my macbook pro! I now can access resolution options in the game settings when I choose Full Screen.

                  Just a PSA, once I switch to full screen, the game does seem to take over my mac - even if I switch back to windowed mode, I can no longer get to dashboard or other applications. That sacrifice, however, is totally worth it - being zoomed out makes this feel like an entirely different game! (And I will just read the forums, the reddit, and the wiki on my phone) ;)

                  Thanks again, Dando! More high fives for you!!!!
                    DandoCalrissian likes this.
                  • diav

                    diav Void-Bound Voyager

                    I purposely made an account to thank you because I was having difficulties getting this to run on my MacBook Pro (late 2013, 10.10.5) and your instructions helped!

                    Many thanks to you and Dando!!
                      DandoCalrissian likes this.
                    • Longbottom

                      Longbottom Void-Bound Voyager

                      I actually just skipped the wrapper prep completely. I'm not sure if installing those dx versions are necessary as part of the process but it might be worth doing just in case.

                      No problem dude, have fun!
                        diav likes this.
                      • DandoCalrissian

                        DandoCalrissian Astral Cartographer

                        Ah, yeah, that's why you had to do those bolded steps. Dotnet40, msxml3, and xna40 are included in that list to install in Winetricks in that first section. Good to know that you can just go an install them at any point if they are missed, though!
                        • Longbottom

                          Longbottom Void-Bound Voyager

                          The issue I had was that the game would not launch at all on my setup without installing those dependencies on their own. The exact error for reference:

                          [ERROR] FATAL UNHANDLED EXCEPTION: System.TypeLoadException: A type load exception has occurred.
                            at StardewValley.Program.Main (System.String[] args) [0x00000] in <filename unknown>:0
                          Again it's probably just my setup (I heard there were some issues with getting Stardew Valley working properly on a Homebrew Wine install like mine), but maybe other people have the same problem! Anyway thanks again for doing all of this legwork in getting Stardew Valley working in Wine! :)
                            Last edited: Mar 8, 2016
                            DandoCalrissian likes this.
                          • kmk4

                            kmk4 Space Hobo

                            Hello, I followed your directions up to the run stardew valley part, but it is not letting me run it. Says the platform is unsupported. I did the "prepare your wrapper" steps, is there something I missed? I have OSX 10.8.5. Any help would be much appreciated!
                            • DandoCalrissian

                              DandoCalrissian Astral Cartographer

                              What step are you getting that error on? Did you end up going through the Steam or GOG installation setup?
                              • kmk4

                                kmk4 Space Hobo

                                Steam, not GOG. I bought the game and get the error when I try to install it. It's step 5 of your list (the second step 5).

                                Edit: Sorry, I mean step 4.
                                • DandoCalrissian

                                  DandoCalrissian Astral Cartographer

                                  Are you able to run Steam through the Wineskin wrapper successfully? It sounds like you may be running Steam for Mac rather than through the wrapper as I get the error "Stardew Valley is not available on your current platform" when I try to install it on my normal Steam install on my Mac.
                                  • kmk4

                                    kmk4 Space Hobo

                                    Oh dear, I feel silly. You were correct, I'm all good now! Thanks!
                                      DandoCalrissian likes this.
                                    • pandahatbear

                                      pandahatbear Seal Broken

                                      I have successfully loaded Steam and downloaded Stardew Valley. It is initialising and then says running and then syncing next to the name in the library but the game never loads. It just immediately returns to the steam library menu. I think I have managed to upload the log from the test run. I'm on a 2012 MacBook Pro on OS X 10.9.5. I've tried restarting the laptop. Any suggestions?

                                        Attached Files:

                                      • DandoCalrissian

                                        DandoCalrissian Astral Cartographer

                                        I see an error in there that looks like you may be missing some key things from the Winetricks install. Try these steps and then try again:
                                        1. Right-click the wrapper, click Show Package Contents, and then double-click on Wineskin
                                        2. Select Advanced, click Tools, and then Winetricks
                                        Select the following to install (all can be found in the dlls section) and then press Run:
                                        • pandahatbear

                                          pandahatbear Seal Broken

                                          Okay, I think it was xna40 that wasn't installed cause I needed to download msxml3 first separately. However, now its telling me that my graphics card is a problem. Is this another known issue? All I can find are people with PCs struggling with integrated graphics cards and I am not particularly computer literate.

                                            Attached Files:

                                          Share This Page