1. Please be advised of a few specific rules and guidelines for this section.

RELEASED Weapon Fusion Station v2.2

Fuses two weapons into one, keeping the best of both worlds.

  1. Aedris

    Aedris Void-Bound Voyager

    I am running a small dedicated server for my friends, and I love this mod.
    To make it easier for players to join and use your mod, may I include it in a small pack of mods?
    I will include credit for you along with a link back to the original mod within the pack.
    Thank you for your modding work!
     
  2. Avito

    Avito Subatomic Cosmonaut

    update please
     
  3. RaiRai The Raichu

    RaiRai The Raichu Scruffy Nerf-Herder

    Had a crash with the latest version of this mod and Starbound.

    Combined an Ixodoom Claw with a random hammer that had frost damage. Took the frost element and took the visuals of the Claw and whenever I'd hit an enemy with the claw, I'd crash.
    https://pastebin.com/qUaKY150

    Seems to be the part of the log corresponding to the crash. Hope this can get sorted out because that was my favorite weapon :C Not sure if this mod is still being updated but I hope to see it happen so I can put it back in my playthrough!
     
  4. LordRuin

    LordRuin Scruffy Nerf-Herder

  5. matthew57778

    matthew57778 Subatomic Cosmonaut

  6. sbelmont85

    sbelmont85 Intergalactic Tourist

    === I've got this working with FU on v1.4 starbound ===

    There is an updated version on Steam here: https://steamcommunity.com/sharedfiles/filedetails/?id=1157737831 It says it's "Weapon Fusion Station For 1.3" I've reviewed the code by unpacking it and it removes support for staffs and wands due to issues. I've also added the following code to fix and make it compatible with FU longswords. It now works with FU on v1.4

    In the WFstation.lua ADD the following:

    -----------------------------------------------------------
    function longswordCompatabilityFix() -- FU compatability fix, remove additional fields from Longswords (prevent crash on attack)
    local weaponLongsword = {"fucommonlongsword","fuuncommonlongsword","furarelongsword"}

    local weaponNameID = finalWeapon.name

    for i=1, #weaponLongsword do -- check if weapon is an FU longsword
    if string.upper(weaponNameID) == string.upper(weaponLongsword) then
    finalWeapon.parameters.rarity = nil
    finalWeapon.parameters.reinforceLevel = nil
    finalWeapon.parameters.tooltipFields = nil
    finalWeapon.parameters.primaryAbility.damageConfig = nil
    end
    end
    end
    -----------------------------------------------------------

    Then AND IN function btnInfuseWeapon() .... ADD longswordCompatabilityFix() after the renameWeapon() line and your done.

    -----------------------------------------------------------
    ....
    ....
    renameWeapon()
    longswordCompatabilityFix()

    -----------------------------------------------------------

    Tested and this fully fixes WFS to work with FU in v1.4 of starbound.
     

Share This Page