Modding Help Updating mods for Stardew Valley 1.4

Discussion in 'Mods' started by Pathoschild, Jul 2, 2019.

  1. minervamaga

    minervamaga Pangalactic Porcupine

  2. SarahMadain

    SarahMadain Void-Bound Voyager

  3. Neckwhiskers

    Neckwhiskers Void-Bound Voyager

    Not really sure what to make of what is in the file but I'm pretty sure the issue has something to do with being able to respec from the dog statue. I switched to painless mode, prestiged, and spent my point in a tier 1 profession and then that night it prompted me to choose a tier 2 profession.
     
    • minervamaga

      minervamaga Pangalactic Porcupine

    • minervamaga

      minervamaga Pangalactic Porcupine

    • Chaos Reaper

      Chaos Reaper Void-Bound Voyager


      even with putting the unoffical updates of PyTK in my mod folder, still getting this ~
      [PyTK] This mod failed in the GameLoop.DayStarted event. Technical details:
      System.NullReferenceException: Object reference not set to an instance of an object.
      at PyTK.PyTKMod.<>c.<Entry>b__22_0(Object s, DayStartedEventArgs e) in C:\Users\Courtney\Documents\Stardew\Modding\Stardew-Valley-Mods-master-Routine\Stardew-Valley-Mods-master\PyTK\PyTKMod.cs:line 82
      at StardewModdingAPI.Framework.Events.ManagedEvent`1.Raise(TEventArgs args) in C:\source\_Stardew\SMAPI\src\SMAPI\Framework\Events\ManagedEvent.cs:line 88~
      and it still the same thing i get before i have put the unoffical update of PyTK in my mod folder
       
      • Allayna

        Allayna Pangalactic Porcupine

        On Year 2, Spring 10, it's a Wednesday, with Pizza as the cooking re-run, the mod tells me there's a new recipe, I've confirmed i already know it.
         
        • Wingyl

          Wingyl Void-Bound Voyager

          It's PyTK. It still uses a complicated old system of removing and reinjecting custom objects to get around a save file limitation that no longer exists (it was genius at the time, but now it could be safely phased out). I'm not surprised they didn't manage to entirely fix that weird error, given the sheer number of things the unofficial updater team that does PyTK unofficial updates tried in previous versions that didn't work or even crashed.
           
          • chad115

            chad115 Void-Bound Voyager

            anyone have any idea about the mod prismatic tools...the unofficial update dosen't work, on page 7, that is...
             
            • Bonster42

              Bonster42 Aquatic Astronaut

              What doesn't work about it?
               
              • Pathoschild

                Pathoschild Cosmos Killer

                Hi! Your update floods the SMAPI log and developer console with endless debug messages written directly to the console:

                upload_2019-12-17_21-51-41.png

                I don't see that in the original code; is that something you added?

                Edit: it seems to be in the RawInputSharp.dll file. Replacing that file with the one from the official download fixes it. Any chance you can post a new unofficial update to fix that?
                 
                  Last edited: Dec 18, 2019
                • Mizzion

                  Mizzion Phantasmal Quasar

                  Could you send me a save where this happens? It shouldn't be happening that way.
                   
                  • Pathoschild

                    Pathoschild Cosmos Killer

                    Thanks! Here's the same update, but corrected the unofficial version number so players get update alerts correctly.
                     

                      Attached Files:

                      Last edited: Dec 18, 2019
                    • KurohaNeko

                      KurohaNeko Aquatic Astronaut

                    • kaochisa

                      kaochisa Aquatic Astronaut

                      Hi, I'm still having an issue with getting special mead to work when using automate. It just defaults to regular mead instead. Most other items seem to work perfectly, though. Thanks to everyone who's been working on the unofficial update for this; it's one of my favorite mods so I really appreciate all of your hard work!
                       
                        ShowToddSomeLove likes this.
                      • Allayna

                        Allayna Pangalactic Porcupine

                        Here's the save. I did go in and make sure it did it again.
                         

                          Attached Files:

                        • AlexStardew

                          AlexStardew Intergalactic Tourist

                          Hey, man, since you are super cool well-known SV modder and manage all the updates, can you do something with Unofficial update for Convenient Chests from strobelight? There is known issue: craft from chest isn't working.
                          Thanks for your updates and mods anyway.
                           
                          • Asra Fantasy

                            Asra Fantasy Aquatic Astronaut

                            Were you able to fix the missing prismatic tools? I don't really care about the sprinklers that much.
                             
                            • Melindee

                              Melindee Zero Gravity Genie

                              https://smapi.io/log/qEUfvM69

                              Can someone help me here? I have no response at all from Nexus and I can't update without SMAPI crashing. Even with the unofficial update, PyTK doesn't seem to be working at all and SMAPI is reporting all kinds of critical errors.

                              I have tried reinstalling SMAPI, resetting my game files, making sure all my mods are updated, fixing simple manifest errors and NOTHING. This is seriously getting annoying. Thank you.
                               
                              • Asra Fantasy

                                Asra Fantasy Aquatic Astronaut

                              Share This Page