Modding Help Updating mods for Stardew Valley 1.3

Discussion in 'Mods' started by Pathoschild, Apr 15, 2018.

  1. Pathoschild

    Pathoschild Cosmos Killer

  2. Kai_76

    Kai_76 Space Hobo

    Hi! Im looking for an update on Eemie's paths mod :< If anyone has one or know of one I would really appreciate it!

    Also I tried adding the Eemie's Medieval modern buildings but i saw that there was an unofficial update for it so I downloaded that instead, but when i launch the game it doesnt run. "Eemie's medieval buildings 1.0 because it requires mods which aren't installed (Pathoschild.ContentPatcher)." Does anyone know which mods im missing? Do i need to download the original file too perhaps?

    Sorry im kinda new to this whole thing, any help is really appreciated :>

    Edit: omg I think I might be dumb, it kinda tells me right there what mod im missing aka the content patcher mod by Pathoschild >.< Im downloading that now so hope it works! Anyways, im still looking for an update for the path mod tho :3

    Edit2: It worked! Umm for the eemies paths mod, I think what im looking for is actually an update that makes it work with content patcher? So i wont have to replace an xnb file. Im really not sure >.<


    EDIT3: Okay so Ignore everything I just said because I figured all of it out! I was looking in the wrong places, but after a while I finally found that someone already did make Eemie's paths compatible with the content patcher so now all the mods I wanted work! <3
     
      Last edited: Jan 10, 2019
    • revalleria

      revalleria Seal Broken

      Wow, i didnt know we have an update..
      there is no error now , Thank you ^^
       
        Moragaine likes this.
      • Phoenix_Fire

        Phoenix_Fire Space Hobo

        Can someone update Foraging at the Farm? I know a link was already posted but SMAPI keeps telling me to update it anyways! The folders for the 2 versions I have both tried that don't work is Forage at the Farm 1.8 and 1.9. I only need to use them until MTN adds back in these spots on custom maps. TYSM! ^^
         
        • minervamaga

          minervamaga Aquatic Astronaut

          You can use Farm Type Manager instead. It combines the features from Foraging at the Farm and Mining at the Farm, as well as some additional features.
           
          • Phoenix_Fire

            Phoenix_Fire Space Hobo

            Didn't know this one existed. Thanks again!
             
            • Pathoschild

              Pathoschild Cosmos Killer

              Here's Prismatic Tools updated for Stardew Valley 1.3.33 and the upcoming SMAPI 3.0, with the sprinkler light fixed. I sent a pull request to the author.
               

                Attached Files:

                Head_Case, blouwho? and drjonzw like this.
              • drjonzw

                drjonzw Void-Bound Voyager

                And Pathoschild said: "Let there be light!" And there was light (from prismatic sprinklers)

                Thank you! It's working great now. I also noticed that the sprinkler radius is displaying properly now too. Not sure if you did that or if it was in the latest update to UI Info Suite. Thanks for everything you do for the community!
                 
                  blouwho? and Pathoschild like this.
                • euchred

                  euchred Void-Bound Voyager

                  Heyo, I was hoping to get updates to these mods. I loaded up a cheat save to see if they were in the game, and they don't show up; I still don't know what the "error items" in Pierre's shop are for me, but so far it seems all of my mods load in so these are just a few that don't. I scoured through all the lists to see if there were unofficial updates but my eyes hurt from being on the computer all day trying to figure this out so if these do have updates that are more up to date than the original posts, forgive me OTL

                  https://www.nexusmods.com/stardewvalley/mods/1792
                  https://www.nexusmods.com/stardewvalley/mods/1594
                  https://www.nexusmods.com/stardewvalley/mods/2108

                  https://www.nexusmods.com/stardewvalley/mods/1861
                  https://www.nexusmods.com/stardewvalley/mods/2090
                  https://www.nexusmods.com/stardewvalley/mods/2773

                  https://www.nexusmods.com/stardewvalley/mods/2349
                   
                  • nomnomcheerios

                    nomnomcheerios Space Spelunker

                    Bump.
                    Been having the same issue, but on 2.7 oddly enough.
                    https://log.smapi.io/DXxEUMSR
                     
                      Last edited: Jan 10, 2019
                    • rosei21

                      rosei21 Starship Captain

                      Are you using get get dressed or Kisekae if it is Kisekae I used mine tonight so it is working and as far as I am aware get dressed is broken and no longer used
                       
                        blouwho? likes this.
                      • euchred

                        euchred Void-Bound Voyager

                        I figured out what was causing it. Longevity was causing the "Error Items" and making Shane do this while at work: https://imgur.com/kSN4IDd

                        I mean I would have a panic attack stocking shelves too if I worked for Joja lol

                        It makes sense that this mod was my issue though, because I have never experienced some of the other features, so I guess the fact that sprites changed at all, or stuff like onions or cotton showed up as crops were the luck of what the game wanted to still load.

                        I'd put up a request to make it a content patcher mod though, as I realized after looking into it more thoroughly, is that Longevity is a "replace all files" mod and not something you just drop into the mods folder. Which, DERP if I would have just read the installation guide, I'd have never had this issue in the first place. But I thought I'd share how I solved it in case anyone else didn't read like me OTL
                         
                        • mikuuuu

                          mikuuuu Space Hobo

                          hi everyone! kisekae isn't working for me on multiplayer mode, it keeps crashing either my game or my partner's game. i have the unofficial 2.1.2 version downloaded that was posted i believe on this forum. if anyone could maybe post an update to it or help that'd be great ty!
                           
                            breatemata likes this.
                          • Lukain

                            Lukain Aquatic Astronaut

                            Last edited: Jan 11, 2019
                            blouwho? likes this.
                          • Rudens211

                            Rudens211 Intergalactic Tourist

                          • revalleria

                            revalleria Seal Broken

                            Hey guys . is the lastest version of part of community doesnt have a config file now?
                             
                            • SaltySam_

                              SaltySam_ Intergalactic Tourist

                            • Pathoschild

                              Pathoschild Cosmos Killer

                              @Lukain A mod is 'open-source' when its human-editable source code is public and has a license which lets other modders change & republish it. Updating closed-source mods is harder (since we need to reconstruct the original code) and usually illegal (since the modder has a copyright on their code). On mods.smapi.io, broken mods will say "↻ broken, not updated yet" (open-source) or "✖ broken, not open-source" (closed source). Of the ones you listed, Cat Gifts and Campfire Cooking are open-source but Intravenous Coffee isn't.

                              @Rudens @SaltySam_ If a mod is listed on mods.smapi.io, there's no need to request them specifically. We're working to update all open-source mods, but it'll take a while. :)
                               
                                Rudens211, SaltySam_ and sh4d0wpl4y like this.
                              • Pathoschild

                                Pathoschild Cosmos Killer

                                Here's Campfire Cooking updated for Stardew Valley 1.3.33 and the upcoming SMAPI 3.0 (still compatible with current versions). I sent a pull request to the author.
                                 

                                  Attached Files:

                                  Rudens211 likes this.
                                • tnt_2018

                                  tnt_2018 Intergalactic Tourist

                                  Attached Files:

                                Share This Page