Tiled not cannot delete sprite without deleting the entire map.

Discussion in 'Mods' started by M4cGyver, Aug 21, 2019.

  1. M4cGyver

    M4cGyver Intergalactic Tourist

    Overview:
    I'm working on a custom map and under the modding documentation it say; "Delete the tilesheet images (SMAPI will load the vanilla tilesheets automatically if they're not present in the same folder)." Whenever I try to delete the tilemap sprite from Tiled, the program removes all of the tiles associated with that specific map (ex the entire map). How do I remove the sprite and keep the tiles also?

    Granted I could be misinterpreting the instruction and if I am can someone reword it for me?

    Edit: Messed up the title
    Tiled cannot delete sprite without deleting the entire map.
     
      Last edited: Aug 21, 2019
    • prants

      prants Void-Bound Voyager

      Heyo I got tripped up by this too lol (I'm new to map making)
      The instructions for that step are referring to deleting the tilesheet files in the assets folder of your map mod, not from within Tiled itself. When you load the map in the game, any tilesheets that are already in the vanilla game (like spring_town etc) get automatically loaded in by SMAPI from the .xnbs that are already in the game's content folder (even if you were using .pngs for your tilesheets). So when you have the map's mod folder in your StardewValley/Mods, the only thing you need in the assets folder is your .tbin and any non-vanilla tilesheets.
       
      • M4cGyver

        M4cGyver Intergalactic Tourist

        Alrighty, then how do I make the sprite path of the .tbin (I'm using this file format not .xnbs) file so it's not set to a definite position. I keep getting this error and I have no idea how to fix it.

        [The Grand Bizzar] Mod crashed on entry and might not work correctly. Technical details:
        StardewModdingAPI.Framework.Exceptions.SContentLoadException: The Grand Bizzar failed loading content asset 'assets/bazzar2.tbin' from ModFolder: there's no matching file at path 'W:\Program Files (x86)\Steam\steamapps\common\Stardew Valley\Mods\The Grand Bizzar\assets\bazzar2.tbin'..
        at StardewModdingAPI.Framework.ModHelpers.ContentHelper.Load[T](String key, ContentSource source) in C:\source\_Stardew\SMAPI\src\SMAPI\Framework\ModHelpers\ContentHelper.cs:line 109
        at The_Grand_Bizzar.Bazzar..ctor(Mod m) in C:\Users\M4cGyver\Documents\SV\current\The Grand Bizzar\The Grand Bizzar\Bazzar.cs:line 29
        at The_Grand_Bizzar.Engine.Entry(IModHelper helper) in C:\Users\M4cGyver\Documents\SV\current\The Grand Bizzar\The Grand Bizzar\ModEntry.cs:line 36
        at StardewModdingAPI.Framework.SCore.LoadMods(IModMetadata[] mods, JsonHelper jsonHelper, ContentCoordinator contentCore, ModDatabase modDatabase) in C:\source\_Stardew\SMAPI\src\SMAPI\Framework\SCore.cs:line 824

        Whenever I remove the sprite image from the folder the mod works fine loading in the sprite
         
          Last edited: Aug 22, 2019

        Share This Page