Stardew Valley Multiplayer Beta: Known Issues & Fixes 2

Discussion in 'Support' started by Katzeus, Jun 4, 2018.

  1. BaronKiko

    BaronKiko Space Hobo

    I have been playing stardew with a friend and we encountered a pretty game breaking issue during the fall fair event. I, as the host, can play the mini-games just fine however after some mini-games my friends client crashes. It happened once after playing the shooting game and twice during the wheel of fortune. We could simply skip the event however we want the extra stamina that I have been told is the reward. We have decided to put a hold to our play through until this is resolved.
    The save files and the crash logs are available here (https://drive.google.com/open?id=1ZB28RQ0-mVoOoeNEMQ1Utn7wmovpO8qv). To reproduce the issue you will need two instances of the game, one to host and and another to join. We watered our crops and moved onto the fair however I am pretty sure watering isn't necessary. We were playing the mini-games at the same time so that may be required to reproduce but really you should just need to play some mini-games as the client and it will eventually crash, never took more than 10 mins but usually less than 3-5 mins. It happened 3 times in a row so hopefully you can easily reproduce. The logs say that the combatlevel field was missing, not sure why that is as I don't have the code to poke through. Hopefully it's as simple as checking the field exists before use.
    Finally we are both using steam copies (not sure if you can get the game elsewhere) so if you need us to test if it's resolved then either the steam copy needs to be updated or you can send us a build with any relevant fixes and I will try pin down my friend to test. Regardless thank you for reading and for any help I may receive.

    Edit: Totally missed 2 key pieces of info, we are both on windows and the crash is the dreaded "Application is not responding", waiting doesn't make it respond however the connection is lost so even if it did respond he would have to wait for me to finish the event before rejoining.
     
      Last edited: Jun 7, 2018
    • yamina-chan

      yamina-chan Void-Bound Voyager

      Right, this one's a weird one again.
      Set in the current release of the Beta.

      I have the Steam Version of the game installed. If I run the game through stream directly, I can reach my savefiles and load into the game fine.
      If I launch the game from the executable directly (as you sometimes do when you're offline or whatever) then I'll enter a load loop. The game tries to load for a splitsecond and then kicks me back to the splashscreen.



      I have since tested it with my other savefiles; created prior to this beta and saved in this beta, created durin the beta, created prior to the beta and not having been opened in the beta yet.
      Only those that were created IN the beta load, everything else returns me to the title, even if they have been saved and have progress from the 1.3 updates.
      But again, if I launch the game through stream, things are fine.
       
      • Katzeus

        Katzeus Community Manager Chucklefish

        Version 1.3.17 is now live
        • (Fixed) Farmhands not able to interact with bundles inside community center
        • (Fixed) Farmhand tools disappearing after logging out while being upgraded
        • (Fixed) Museum donations disappearing
        • (Fixed) Farmhand profession sale bonuses not applying
        • (Fixed) Artifact donation message appears in English for all languages
        • (Fixed) Profit margin mistranslated in German
        • (Fixed) Character names appearing in English while playing non-English character languages
        • (Fixed) Unable to walk through animals while inside a building
        • (Fixed) Bug which could make farm animals disappear
        • (Fixed) Baby gender assignment issue for player/player newborns
        • (Feature) Invite code now copyable to clipboard
         
        • txiv

          txiv Yeah, You!

          @Katzeus is that "(fixed)farmhand profession sale bonuses not applying" for items sold via shipping bin?

          also want to report bug for 1.3.16 multiplayer
          1. i dc-ed while jumping on my horse in farm. after quickly reconnecting, i appeared riding on my horse in void map... my friend (host) was in shane heart event at that time (no idea if this is the cause or not). so i quit and reconnected again, normally appeared on my bed, but the horse was gone for the day. next day it came back to stable.

          2. somehow i can't trigger shane 8heart event. i want blue chicken..
           
            Last edited: Jun 7, 2018
          • yamina-chan

            yamina-chan Void-Bound Voyager

            Two bugs in 1.3.17 that have been in a few installments and that I just confirmed to be there now:

            1) The icon for the colored chest selection at the top right is broken and will display as a with a colored sign with a log instead untill you interact with it.


            2) Music at festivals does not work. Not initially and the way it's meant to, anyway. A good example for that is the Luau, where the silence and many footsteps really stand out, especially with characters dancing and commenting on the music volume.
             
            • coffeediction

              coffeediction Yeah, You!

              - (Fixed) Tree seeds not harvestable in multiplayer - farmhand still cannot recover the seeds :)
              - When robin is asked to build something, there is a construction site for 2 days, after the building is finished, farmhand still see the doorframe of this contruction site until farmhand sleeps.
               

                Attached Files:

              • tsunamiraven928

                tsunamiraven928 Space Hobo

                I've noticed an issue in a game I've been playing as a farmhand that I suddenly can't access any of the community center collections to add items toward completion, last week I could but now nothing.
                 
                • Katzeus

                  Katzeus Community Manager Chucklefish

                  Should be - yes! Please report if it's not working as intended now

                  What game version are you playing? This should have been fixed in this morning's update
                   
                  • Frostdraga

                    Frostdraga Poptop Tamer

                    I'm not sure if this is a bug, or a feature, or maybe only happening to us, but..

                    - Farmhands are unable to collect produce from the Junimo Huts. We have about 8 Junimo Huts, but only the host seems to be able to interact/collect the produce that the Junimos have harvested.

                    20180607223226_1.jpg

                    Edit: The screenshot taken was from today's update (1.3.17), but the problem has persisted since we got the Junimo Huts in about... 1.3.15?
                     
                    • MrBootybreath

                      MrBootybreath Void-Bound Voyager

                      Unfortunately whenever I attempt to do that, this error comes up:
                       

                        Attached Files:

                      • Blorp

                        Blorp Big Damn Hero

                        Zip the whole folder, and upload that, rather than just the file. The folder will be named like "farmername_numbers".
                         
                        • DogeDoggo

                          DogeDoggo Space Hobo

                          Hello! My friend and I are having a lot of trouble with the Skull Mines in the desert in the save I have. It will often completely crash our game, it gets stuck when we jump through the "holes" - it will just show that "you fell x levels" window and won't let you close it for a minute. Sometimes it eventually works, sometimes it crashes, and the last time everything on the level just completely froze. I would hit rocks, and everything would stay in place and I couldn't pick it up either - monsters also wouldn't move. The white motions from my pickaxe would stay in the air. When I tried to hit a monster with my sword, the whole game crashed.
                          It also crashed when we were both in the Halloween Festival as well. First her game, then mine went next before I could save. (This all happened on the same day. We hadn't had any crashes until the event, then after we re-started the save trying to wait for the 10pm festival again)

                          It's not a big problem - but we can also always hear whenever the other person is cutting hay no matter where we are - lol!

                          I just tried for like 20 minutes digging through my steam files, but I am unable to locate the error logs/save file... I easily located the Stardew Valley folder within steamapps, but there are no folders named "Saves" or "ErrorLogs" anywhere that I can find. Any ideas?
                           
                          • Gravedance

                            Gravedance Space Hobo

                            Hello, i have a problem.
                            Today my friend bought me a copy of the game on Steam. We tried to play together, but there's an issue. I can only connect with LAN, there's no other option.
                            I tried to fix it with reinstalling Visual C++ Redistributable Packages for Visual Studio 2013 x86, but it's not helping at all! 20180607232208_1.jpg
                            Also i can't invite friends when i'm hosting. Buttons are missing. I tried to wait a few minutes in main menu, but again it didn't help. 20180607233416_1.jpg 20180607232238_1.jpg
                            And i can't join my friend's game using invitation. Just nothing is happening when i accept it.

                            My version of the game is 1.3.17, Windows 10. All Privacy Settings in Steam profile are set on "public" and "for friends". Please, help.
                             
                            • MrBootybreath

                              MrBootybreath Void-Bound Voyager

                              Aces, thanks mate
                              There we go, hopefully that works. Recap on my issue: After my friend joined my farm, Harveys gifts dont reset weekly. Been about 2 years in game since I last gifted something to him and it's been stuck since then.
                               

                                Attached Files:

                              • Seyph

                                Seyph Void-Bound Voyager

                              • thaurane

                                thaurane Space Hobo

                                It seems like that when someone (usually the host) goes down a floor in the mines the other players experience a lag spike regardless of their location ingame. It doesn't happen every time though maybe 50% of the time? This has been going on for a few versions now.
                                 
                                • Kababesh

                                  Kababesh Space Hobo

                                  Games crashed twice attempting to talk with Marlon at the Winter Star Feast. A blank dialogue window opens, then the client crashes.
                                   

                                    Attached Files:

                                    Last edited: Jun 7, 2018
                                  • OracleCat

                                    OracleCat Intergalactic Tourist

                                    When I ride my horse across the bridges in Cindersap Forest, it makes water splashing noises instead of hoofbeat noises.
                                     
                                    • Mitmenschin

                                      Mitmenschin Space Hobo

                                      Hi, my friend and I witnessed another bug.
                                      When we built the slime hutch and Marlon came a few days later, he stands in front of the house, my character goes around him and then the game crashes.
                                       

                                        Attached Files:

                                        morgarine likes this.
                                      • corana

                                        corana Void-Bound Voyager

                                        Hello, I've updated to v1.3.17 and today attempted the Flower Dance. Talked to a bunch of villagers but when I got to Marlon, the game crashed. Tried again, this time talking to him first, same exact crash. The dialog box appears for a split second before freezing and then the entire game closes. I guess he doesn't like me ;)

                                        Save files attached.
                                         

                                          Attached Files:

                                        Share This Page