Stardew Valley Multiplayer Beta: Known Issues & Fixes 2

Discussion in 'Support' started by Katzeus, Jun 4, 2018.

Thread Status:
Not open for further replies.
  1. Noobfarm

    Noobfarm Space Hobo

    I had no rain for around 25 days. (15th of Spring till 10th of Summer) I modified my save file to force a storm. Not sure how often its supposed to occor, raining I mean.
     
    • rainydaydance

      rainydaydance Intergalactic Tourist

      Hullo there. How's everyone's time frame doing? Good I hope. I just noticed a bug appear during the fair in the fall of yr 2. I started the fishing game, I couldn't fish at all. I could only run around and wait for the timer to run out, then it would give me no score and kick me out of the game back out into the fair. Just to make sure I also tried the sling shot game. It wouldn't let me move what so ever, so I once again had to wait for the game to end and receive a no score and be kicked out into the fair. I've also just noticed that if I click on an option that "freezes time", my person continues to keep moving while standing in place until I "unfreeze time". Wait. Are the other people suppose to move while my tab is open during the festival since it's "outside" time? Or is that a bug? Also, after the judging, Mayor Lewis has a chat bubble, but I can't get him to talk. Sorry, if it reads weird.
       
      • tccoxon

        tccoxon Procedurally Generated Programmer Chucklefish

        You've both reported something that sounds similar, however I'm unable to reproduce it with vanilla Stardew 1.3 beta. Do you have any mods installed?

        And @rainydaydance, you mentioned not being able to move during the slingshot game - you're not meant to be able to. Were you able to use the slingshot during that minigame though?
         
        • Katzeus

          Katzeus Community Manager Chucklefish

          Update 1.3.24 is live now
          • (Fixed) Players stuck on "Connecting to online services..." screen
          • (Fixed) Crystalarium item swap exploit
          • (Fixed) Furniture can be used to complete bundles
          • (Fixed) Milk requirements for certain cooking recipes (now can accept either Milk or Large Milk)
          • (Fixed) Summer weather forecast bug
          • (Fixed) Furniture duplication bug
          • (Fixed) Long tool use animation bug
          • (Fixed) Warp tile player & shadow animation bug
          • (Fixed) "Cloud Country" not being added to the jukebox if you create a game via the co-op menu
          • (Fixed) Cooking food in the kitchen using ingredients from the wrong fridge
          • (Fixed) Item debris duplication bug
           
          • rainydaydance

            rainydaydance Intergalactic Tourist

            I haven't added any mods. I don't particularly like them. Too great of a chance to ruin the game, and waste all my hard work. In the sling shot game, I also couldn't do anything, not just move, my mouse didn't do anything to aim or fire.
             
            • tccoxon

              tccoxon Procedurally Generated Programmer Chucklefish

              Thanks. Would you be able to send me your save file in case something in it sheds some light on the issue?
               
              • margotbean

                margotbean Scruffy Nerf-Herder

                Nooooooooooooooo!!!!!!!!!!!!!! Put it back put it back put it back! That exploit has been around forever! It's a 7-hour jumpstart to the Crystalarium, nothing more. Argh!
                (Thank you, rant over)
                 
                • Amphy2332

                  Amphy2332 Void-Bound Voyager

                  It seems that barn and coop doors being left open overnight when the server closes (finishing a game session) causes weird bugs with the animals. When we have left them open, the animals will refuse to eat or go inside for a day or two, and one incident we had our pig go into our coop. We sold her because we were worried the game would crash.

                  This doesn't happen when we shut the coop and barn doors before logging out.
                   
                  • Gecko133742

                    Gecko133742 Intergalactic Tourist

                    Hi there!

                    I would like to post a huge, game breaking, and very annoying bug here. Hopefully it can be fixed soon because, well... I can't fish any more. Whenever I fish, I only catch trash. Literally.

                    There is no crash and nothing special happening. It's just, I catch only trash.

                    May be some specs here that might help narrowing down the cause:
                    • Windows 7, 64bit, AMD FX 6350, EVGA NVidia GTX 960
                    • The game is on the latest Version BETA branch (as of writing).
                    • I'm playing together with one other person.
                    • The house of the other person is max upgraded.
                    • The player house it on the latest upgrade.
                    • Fishing is skill 9 with Fisher spec on skill 5.
                    • Time is Spring 26, year 3.
                    • Bug was noticed around Autumn year 2.
                    • Neither of the two fishing events (winter & fair) yield other catches than trash.
                    • I'm using a iridium rod, the bug happens with or without bite/hook.
                    • Also the bug occurs with lower tier fishing rods.
                    • Also the other player only catches trash with skill 0.
                    • I tried various 'have you switched it off and on again?'-type fixes. Nothing helps.
                    • The other player is catching secret notes (with skill 0!) like crazy. At least every other catch. I don't even catch those.
                    EDIT: I attached my save file (at least what I think is the save file).
                    Please help, I love fishing! And... you need a 'fish' for the lucky lunch!

                    Thanks in advance!
                     

                      Attached Files:

                      Last edited: Jul 10, 2018
                    • jbrianj

                      jbrianj Void-Bound Voyager

                      Don't forget to attach your savefile: %APPDATA%/StardewValley
                       
                      • Mr. Shingles

                        Mr. Shingles Void-Bound Voyager

                        I've noticed some long running bugs like the animal happiness ones, and crystalarium dupes being fixed!

                        I was wondering if it would be possible to fix scythe crops not granting XP when being harvested? I'd love to grow kale, wheat, and amaranth but according to the official wiki they do not grant exp due to a bug with scythe harvesting. I've done a test as a new character with level 0 farming and harvested 40 kale (which is around 17xp each, or a little more than twice as much as one parsnip) and haven't leveled. Kale is also good money early on... maybe not the best, wheat has it's beer use, and amaranth looks really nice! It's a shame I don't usually want to touch these things until I'm a much higher farming level though. Kale is also a good compliment to potatoes early on to get money for the inevitable first backpack brawl with a full multiplayer game, or a multiplayer game with reduced profit margins. It would be nice if I could keep up in terms of farming skill too!

                        Another one that has been around for a bit, and that my friend was quick to point out (he didn't play the game until the multiplayer testing, he wanted to play co-op with me) was when certain crops fail to grow the next day. This one has modestly low chance of happening but when crops are watered, sometimes one (or in other cases more than one) of the crops do not grow to the next stage the following morning, yet remain watered. It's not too big an issue unless you like nice full fields, in which case this bug can take wonderful regrowing crop fields (like blueberries, cranberries, ect) and out-of-sync a couple plants (I've seen 4 or 5 at once!) meaning you either have to keep them on the ready-to-harvest stage to re-sync them to the other plants, or have the odd crop every now and then to harvest which bugs my OCD greatly!

                        Hopefully these are fixable, so we can grow scythe crops for things other than beer, and give that one-day-behind parsnip another chance!
                         
                        • unsocialbunny

                          unsocialbunny Intergalactic Tourist

                          Hey! I have unlocked the green house and I have a 10 heart relationship with Evelyn, but she won't give me the garden pot recipe. Is it because I never had the other cutscenes with her?
                           
                          • Koihime Nakamura

                            Koihime Nakamura Ketchup Robot

                            I've had Marnie not detect my barn was there on the day I started an upgrade, but before Robin did anything. AFAIK, I've seen implict conversions simply get null sometimes? I'm just not able to really test it as much as I'd like since a sample console program won't interact with it properly. It might just be that the function that checks for animals doesn't let you get any animals during construction even if it's from Big -> Deluxe Barn.

                            I apologize if that report was unuseful.
                             
                            • rainydaydance

                              rainydaydance Intergalactic Tourist

                              Sure. How do I send the save file? Also, which one?
                               
                              • lt125

                                lt125 What do you get if you multiply six by nine?

                                Pam doesn't follow you onto the bus.

                                Also, my golden Lewis statue can't be located. I am searching everywhere behind his house, hitting around with an axe and a pickaxe and it still won't show up.
                                 
                                • Frundan

                                  Frundan Space Spelunker

                                  A lot of people have reported Pam not following them onto the bus but I don't think this is a bug. In the earlier versions if the player used the return scepter to get home from the desert, she did not return with them, so they couldn't ride the bus anymore that day. She didn't get back until the player went to sleep, so her regular schedule was pretty much screwed over as well.
                                  For this reason, I never used the return scepter after my skull cavern runs, because I was afraid of the game bugging out and deciding for some reason to not respawn Pam in her house the next day.
                                   
                                  • jbrianj

                                    jbrianj Void-Bound Voyager

                                    It may be a race condition if it shouldn't be random at all.
                                     
                                    • jawsawn

                                      jawsawn Void-Bound Voyager

                                      Kale and crops that are harvested with scythe does not give any farming xp.
                                      Thus rendering them even more useless.

                                      Please fix this old issue. Thanks.
                                       
                                      • CrazyMeup

                                        CrazyMeup Space Hobo

                                        I made my 4 year farm into a multiplayer version and had 2 players in the game with me. I tried to move my slime hut around and I wasn't able to fit it in the room I was able to. I tried to put it back where I got it from and it wouldn't place down (I think because the road was basically all around the area it doesn't like that. It got to 2am and I am stuck in the moving menu (at the wizards) and I am unable to do anything and the other two players are asleep... there wasn't I could do but restart.

                                        Please let me know if you need any further information regarding this ^^
                                         
                                        • Koyukuk

                                          Koyukuk Space Hobo

                                          My wife and I have been playing on the multiplayer beta since it came out. We have also been using each update as they come out. My character is married to Abigail and her character is married to Harvey. During the Dance of the Moonlight Jellies, on my screen it showed me(the host) standing next to Abigail with my wife's character standing behind Abigail. On my wife's screen, it showed my character standing next to Harvey, with my wife's character standing behind Harvey. This was more just a funny bug, but something that may effect some of the other scenes that are similar. This is just the first one we noticed.
                                           
                                          Thread Status:
                                          Not open for further replies.

                                          Share This Page