Stardew Valley Mobile: Known Issues and Fixes

Discussion in 'Support' started by Katzeus, Oct 23, 2018.

  1. Typhoon

    Typhoon Spaceman Spiff

    You need to empty it first, then hit it with an axe (it will then appear in your inventory, assuming you have a vacant space for it).
     
    • hay1889

      hay1889 Space Hobo

      Spirit's eve lags (see attachment)

      iPhone Xs
      iOS 12.0.1
      Stardew Valley v1.02
      Save created on phone.

      I tried again, went through whole day, and it works fine now.
       

        Attached Files:

        Last edited: Oct 29, 2018
      • harryh

        harryh Developer

        Thanks everyone for the bug reports on the magnetic ring issue. This is now fixed and the fix will be rolled out in the next update.
         
        • Sanhud

          Sanhud Void-Bound Voyager

          I can now use auto attack...it was me I wasn't doing it properly...you HAVE to have the weapon in your hand first...[I didn't have a weapon because I lost it and I was trying to use the pickaxe to fight]then he will auto attack any monsters that approach.
          But on the other hand I find fishing very hard...I never get a bite at all????.
           
          • Typhoon

            Typhoon Spaceman Spiff

            Perfect, thanks Harry!

            Are you any further forward with fixing the bug in the mines that causes a crash when reaching certain levels?
             
              Last edited: Oct 29, 2018
            • heathraawr

              heathraawr Space Hobo

              Trying to give more details on the magnet ring bug:

              Magnet ring was found by breaking a chest in the mines between level 35-40 near the end of Spring year 1 (25th-28th). Immediately after equipping it I lost all "attractiveness" to items - I can still pick crops and fish, but anything on the ground anywhere won't attract to me. I tried unequipping, unequipping and sleeping, putting it in a chest and sleeping, throwing it away then sleeping, throwing it away then turning my phone off/on; nothing reverts my character back to actually attracting ground items again.
               
              • Truckerai

                Truckerai Intergalactic Tourist

                Game crashes upon going to sleep after buying a chicken on an imported save from Mac. Successfully repeated multiple times. iPhone 7+
                 
                • Sunil

                  Sunil Intergalactic Tourist

                  Not a major problem. Could you please stop dogs and cats sitting in the door way/ corridors. Have them sit somewhere like the dog bowl indoors. It’s ruining the fun of the game and harder to get past on mobile devices unless you sleep. I know others have the same problem.
                   

                    Attached Files:

                    Last edited: Oct 29, 2018
                  • brianphill77

                    brianphill77 Space Hobo

                    Twice it has crashed when going to a new level in the mine.

                    iPad 9.7 inch (2018) 128GB

                    Went to the mine on a rainy day, level 14 is as far as I had ever gotten. Took the elevator to 10, got down to 14 again, smashed a stone to reveal the ladder down to 15. As soon as I stepped on the ladder, game crashed.

                    Restarted the game, went straight back to the mine, took the elevator to 10, worked my way down, and got to 15 successfully. Then found the ladder down to 16, as soon as I touched it, game crashed.
                     
                    • melopok

                      melopok Poptop Tamer

                      Character movement bug where it heads towards the bottom left of the screen in some areas or shops. First happened in Pierre’s store when I was clicked on Caroline to talk to her for the first time, then my character automatically moves towards the bottom left of the screen and the controls go absolutely haywire. Nothing I click can stop my character from moving until it reaches a corner in the shop. Exiting and entering the shop again resets the bug.

                      Happened for a second time in town near Pierre’s store as well, but because the town is so huge my character doesn’t stop moving until after awhile. I remember it happened while I was heading towards the community centre so I was tapping/ tap and holding the right side of the screen. Caroline was somewhere on the right when it first happened too.

                      I’m on iPhone X.
                       
                      • Valwen

                        Valwen Intergalactic Tourist

                        Playing on iPad Air 2. Around day 16 or so. Early morning in the mines, tried to use the elevator to go to level 5 and crash.
                        I had not used the elevator before, and had only gotten to level 5 the (game) day before.
                         
                        • Jorelishe

                          Jorelishe Seal Broken

                          Transferred PC save file to iPhone 7, had the journal bug that would make it crash any time I tried to look in my journal, but has now been fixed.

                          However, now I have the bug where it crashes each time I go to bed, when it should be saving and listing money earned from box (as a previous user mentioned). I, too, did normal farming stuff. I have played the same day 5 different times, and each time it crashes.

                          It also will not allow me to upload my save file here (my phone is telling me the uploaded file does not have an allowed extension)
                           
                          • Jorelishe

                            Jorelishe Seal Broken



                            Saaaaaame
                             
                            • Davidovich

                              Davidovich Void-Bound Voyager

                              Is there a way to access lower tiered items (on the second or third rows in the backpack once you’ve upgraded) without having to open the backpack, move the item upwards then, use it? On the Switch, for example, I can press (L) or (R) to move between the rows of items in my backpack. Also, can you perhaps move the words, “New Record,” so that they’re not chopped off on the iPhone version of the game?
                               
                              • yamakirisei

                                yamakirisei Orbital Explorer

                                I had an issue where an infested floor in the mines did not open a way down to the next level, even upon defeating all enemies.

                                This was on the 9th floor of the regular mines.

                                I had gone there and "died" before, but did not save at home -- I had restarted the app and also restarted the day, before this issue occurred.

                                I never cleared out the floor before the instance of this issue, though as I had said, it had been "generated" and "explored", though not fully, and there had been no save afterward.

                                I am completely sure I killed every enemy. I walked around that floor for about 4 in-game hours, checking every area of the room, every wall and corner and the center as well. Nothing attacked me, and I tried swiping the sword around, and found nothing to hit.

                                There was no ladder down, nor was there any notification in-game of such a ladder appearing, as there should have been.

                                I am on iOS 11 (cannot update to 12 due to other essential apps I use not supporting it yet) and on an iPhone 8.
                                 
                                • Abkiz_Gamer

                                  Abkiz_Gamer Space Hobo

                                  Hey so I bought the game on iOS after being on the fence about getting it for PC for about a year, and I love Stardew Valley. I have run into a nasty bug though, which is upon completion of Penny’s 10-Heart cutscene, the game crashes when I try and ‘sleep’ to save. There seem to be a few glitches with the event itself, such as the loading screens before and after are misaligned, and after the bug their is a bug with the character model. Just wanted to tell you guys and see if you knew about it. Other than this annoying thing it’s an amazing game, and I wish you all much luck with future updates and rollouts.
                                   
                                  • Abkiz_Gamer

                                    Abkiz_Gamer Space Hobo

                                    So this is weird, and I have a new idea as to what’s causing it. I decided to ignore the bug and play around it (I.e. don’t trigger the event at all) and was messing around doing my thing and ended up finishing one of the community center bundles (The foraging one if that’s relevant). When I went to save, surprise surprise, it crashed. My theory is that cutscenes and events are having problems rendering in winter, as my first problem was on Winter 2 Year 1, and this happened on Winter 4 Year 1. Not sure if that’s helpful but that’s what my take is, if there’s anything you all need from me I’m happy to help out.
                                     
                                      Typhoon likes this.
                                    • Erich408

                                      Erich408 Space Hobo

                                      I’d like to report some bugs/problems I have with the Stardew Valley iOS port.

                                      1. Two finger touch is not well supported. I can’t interact with multiple (2 or more) on screen buttons at once, the place where this bothers me the most is in the mini-game where you shoot the zombies, because it is basically unplayable. (Tested on: iPhone 6S, iPhone 7 and iPad Air.)

                                      2. There is a clipping issue with the sleeves of both male and female characters. (Tested on: iPhone 6S and iPhone 7.)

                                      3. After tapping “Load” on the title screen and choosing the data that you wish to load, the data’s panel flashes a few times. I’m not sure if this is a problem or not, I’m just reporting it to make you aware of this, if it is a bug. (Tested on: iPhone 7.)
                                       
                                      • Davidovich

                                        Davidovich Void-Bound Voyager

                                        Just wanted to add another small bug report - After changing the padding on the sidebar, saving and exiting the app, those changes are not saved when reopening. Thank you.
                                         
                                          Typhoon likes this.
                                        • Katzeus

                                          Katzeus Community Manager Chucklefish

                                          Update 1.03 is deploying right now. Details below.

                                          1.03 (30 October 2018)
                                          • (Fixed) Pantry bundle will sometimes not open when tapped
                                          • (Fixed) iPhone XR resolution problem
                                          • (Fixed) Spring onion event incorrectly positioned
                                          • (Fixed) Removing magnetic ring causes difficulty collecting items
                                          • (Fixed) Crashing inside mines
                                          • Can now tap and hold to move then cast fishing rod
                                           
                                            Pros599 and margotbean like this.

                                          Share This Page