Stardew Valley Mobile: Known Issues and Fixes

Discussion in 'Support' started by Katzeus, Oct 23, 2018.

  1. decoded

    decoded Space Hobo

    I have now completed my first year and my fishing skill has still not increased from level 1. After reaching level 2 for the first time the app crashed and i haven't been able to level up since no matter how many times i fish. Any solutions to this?

    Thanks for what is otherwise a great game!
     
    • Happy1816

      Happy1816 Space Hobo

      I have an issue with the auto-save. The game will auto-save when I close or kill the app. But when the app crashes on it's own, it doesn't auto-save and I have to restart the day again. It used to auto-save after crash when it first came out but not anymore with latest update. Has this changed?
       
      • HappyFarm

        HappyFarm Intergalactic Tourist

        I had to turn on auto-attack after the update. (Under the controller icon.)

        It works fine now except sometimes I get stuck behind a rock and I can’t move except to slash furiously at what’s on the other side - and not being able to reach it. I wish at that point we could manually switch to the Pickaxe so we could get rid of the rock, or be able to back up or go around the rock. I’m eventually able to move, but I’m stuck for 5-15 seconds.
         
        • harryh

          harryh Developer

          Hi - there seemed to be some issues with the regular auto save causing crashes, so it is disabled for the time being. We're looking at the best way to give you that functionality soon.
           
          • harryh

            harryh Developer

            Hi Zombielisa

            Thank you for posting your save which is very helpful to us in tracking down the bug. It looks like that save file has become corrupted for some reason. Do you know if you've had the game crash at all while saving? Knowing that might help us work out exactly what's happened here.

            While sifting through the save I've manually changed the broken bits of the file and re-saved it out so, hopefully, if you unzip this zip and drag the two files inside it back onto your phone via iTunes in the same folder as before, you'll should be able to carry on playing. Sorry for the inconvenience, I hope this helps.
             

              Attached Files:

              Katzeus and Typhoon like this.
            • harryh

              harryh Developer

              Hi - we're looking into this problem which seems to have affected a few users.

              If you're finding the app isn't getting as far as the title screen, it sounds like the auto-save file has got corrupted or deleted somehow. You should be able to get back into the game by following these (slightly fiddly) steps:
              1. Follow the steps here - until you get to the point where you can see your Stardew Valley files in iTunes on a PC/Mac
              2. Rather than copying the files onto your PC, click on the file marked 'EMERGENCY_SAVE' and press delete to delete it from your phone. Don't delete any other files or folders!
              3. Confirm the file delete if asked.
              4. Click the 'sync' button in iTunes to synchronise your PC with your iPhone.


              Try restarting the game now. Without the 'EMERGENCY_SAVE' file there, the game won't be trying to load up an auto-save, and will take you to the main menu, from where you can load your last saved game.

              We're still trying to track down exactly why this has happened so can't push out a fix yet, but we hope to have a better solution in place soon.

              Sorry for the inconvenience, and thanks for reporting the issue.

              It would be really helpful if you could also copy the save files (as shown in that link above - the whole contents of your save folder) to your PC/Mac and zip them up and post them here. That will help us to work out exactly what has happened. Thanks!
               
                Typhoon likes this.
              • poemsing

                poemsing Seal Broken

                Does anyone encounter this issue?
                When I use joystick to move my farmer, he always face the left side at the end.
                It make farmer work difficultly…
                 
                • sepo

                  sepo Developer

                  That zip file is empty. Please can you attach the saves.
                   
                  • sepo

                    sepo Developer

                    @zombielisa - We haven't figured out why this happened but were able to fix your save. Attached is the fixed version. If you delete the files in the save the directory and replace them with these it should then load ok.
                     

                      Attached Files:

                      cosmic-irie and Typhoon like this.
                    • zombielisa

                      zombielisa Space Hobo

                      Thank you, that worked a treat. The game had not crashed while saving. I finished playing the night before, sent my farmer to sleep, waited for the save to finish and then closed my iPad. Overnight, the iPad auto-updated to the newest iOS, but that was the only unusual thing.
                       
                      • Sebastian-Alexander

                        Sebastian-Alexander Space Hobo

                        Hey guys,

                        I have a loading problem since I played the last time (yesterday night). If I want to load my save, the game tries to load the save and returns back to the main screen after a few seconds. I hope you can fix my save or find the problem.

                        Some facts ...
                        • I experienced no crash during gameplay
                        • iPhone 6+ with iOS 12.1

                        Thx for your help - and for Stardew Valley especially :)
                         

                          Attached Files:

                          Last edited: Nov 22, 2018
                        • sepo

                          sepo Developer

                          Attached is a fixed save file. Try replacing this for the one on your phone and see if that loads.
                           

                            Attached Files:

                            Sebastian-Alexander and Typhoon like this.
                          • sepo

                            sepo Developer

                            You'll need to rename "Melissa_200146540.xml" to "Melissa_200146540" (sorry, my bad).
                             
                              Typhoon likes this.
                            • Sebastian-Alexander

                              Sebastian-Alexander Space Hobo

                              This is amazing, thank you so much! @sepo
                               
                              • Happy1816

                                Happy1816 Space Hobo

                                Not sure if anyone is having this problem too but sometimes when I am riding my horse from town square into the woods (Marnie's Ranch), my horse disappears. Like one second I'm riding the horse, enter next scene and I'm walking now. Doesn't always happen but a few times now that I felt like reporting it. My horse is nowhere to be found and only returns back to my farm the next morning.

                                Also I just want to shoutout to all the developers working so diligently on the game! You guys are amazing and I'm so thankful for you and this game! Happy Thanksgiving to y'all! :)
                                 
                                • melopok

                                  melopok Poptop Tamer

                                  I’m on Day 16 of Fall in my Year 1, first time at the Stardew Valley Fair. Got Lewis to judge my display while I went to play the fishing mini game. The notification came in halfway through the mini game that Lewis was done with my display, but the notification box didn’t go away no matter where I clicked. The game also couldn’t be played (my rod was casted but I can’t reel in any fish) but the timer was counting down. Thought maybe I’d exit the mini game if it reached 0:00 but I was just stuck there permanently. Had to restart the whole festival day...

                                  Played on iOS version on iPhone X.


                                  Sent from my iPhone using Tapatalk
                                   
                                  • Davidovich

                                    Davidovich Void-Bound Voyager

                                    Got another small bug to report - all of Clint’s missions where he has me fetching pieces of ore don’t work. I’ve tried showing them to him and even give him a piece of ore but I’m never able to complete those missions. iPhone XR 12.1. Thanks.
                                     
                                    • Tidero

                                      Tidero Seal Broken

                                      After the last patch 1.08, I am off the horse when moving from a farm to another location. what to do?
                                       
                                        Last edited: Nov 23, 2018
                                      • Katzeus

                                        Katzeus Community Manager Chucklefish

                                        Hello everyone - a small update has just gone live, most specifically targeting a fix for an issue for players who had problems opening their saves.

                                        1.08 (17 November 2018)
                                        • (Fixed) Recover from save errors cleanly - anyone who was locked out of their save should now be able to play again
                                        • (Fixed) No longer possible to accidentally delete farm building during move
                                        • Auto save of backups when changing location is now re-enabled (switch it off in options if you encounter any problems)
                                        • Other stability improvements
                                         
                                          Typhoon likes this.
                                        • Knakriktsur

                                          Knakriktsur Tentacle Wrangler

                                          Did you get the ore after accepting contract from mines or out of your chest? Did you gave him a stack which contains more ores than he had requested?
                                           

                                          Share This Page