Stardew Valley Mobile: Known Issues and Fixes

Discussion in 'Support' started by Katzeus, Oct 23, 2018.

  1. Quaraliel

    Quaraliel Space Hobo

    iPad mini 4 on iOS 12.1
    The music randomly speeds up and slows down, mainly during walking.
    It gives really creepy experience.
    Unfortunately I can’t upload the video that I took to show my frustration with such music (I think it may be too big a file), so if anyone wants to see how that sounds like I can send an email!
     
    • kelsey_167

      kelsey_167 Space Hobo

      Hello, everyone!

      First, thanks for the Community Center pantry tile glitch; got my greenhouse finished now!

      Now, for bugs/glitches:

      Game just soft locked in the mines; Winter Day 11, year 1. Mines level 101 (mushroom floor). Previous access to the mushroom floor has been fine!

      Also; none of the bags (satchels) or mine carts in the mines release coal. It did at first, now after an update none of them released anything at all. Makes coal annoyingly scarce. ;_;

      There’s a lighting issue on some of the floors, mostly infested ones. It’ll be complete dark, then lights up as soon as you activate the ladder to go down to the next floor. Between floors 5-20 the most I think.

      I’m using an iPhone 7+ running iOS 12.1.

      Thanks!
       
      • SilverMoonWings

        SilverMoonWings Space Hobo

        Playing on the iPad version 1.03, completely up to date, and I’m still crashing when trying to progress in the mines.
        Additionally, I would upload my save here, but there was an error trying to upload it to the forum from the ipad itself ( “The uploaded file does not have an allowed extension.”)

        iPad iOS 12.1
         
        • baconcow

          baconcow Scruffy Nerf-Herder

          Game Version: 1.07
          File Playtime: 87+ hours
          Device: iPad Pro 10.5
          iOS Version: 12.1


          Critical
          • [Fixed] Crashes to iOS in the Mines Skull Cavern when descending a ladder (unsure about descending holes).
          • [v1.03] Crashes to iOS when moving from the farm to the southern region.
          • [v1.03] In the Stardew Valley Fair, I entered the fishing game while the exhibits were being judged. Once the judging completed, it told me to return to Mayor Lewis. My character became stuck while the fishing game timer counted down. When the time ran out, I could still not move my character. The game had to be closed and the day lost.
          • [Fixed] Game crashes when trying to put hay in the silo.


          Important
          • [v1.07] When entering the Witch’s Cave entrance, while on my horse, the transportation place will continuously keep teleporting me back and forth between both ends. Once I hold down to move, my character will become off-screen and will eventually ride on-screen, yet out-of-bounds. Eventually, I am able to get close enough to the initial cave entrance and walk out. During this, my character appears to be glitching through the tiles, and will even appear behind several tiles while moving. Recently warped to an area I could not return from (v1.07), losing all my day’s progress.

          • [v1.06] Cannot retrieve the crab pot, once places on a diagonal, from the land, on the middle river in the Forest Farm. I am also not able to put any bait in it. It shows green when I hold the bait, but there is no location that I can use it.
          • [v1.07] Auto-attack has poor timing on several enemies, especially the flying enemies that home in on you. Especially with slower weapons, than the Galaxy Sword, you will often swing too early, leaving you open for attack. This makes it impossible to go through the Skull Cavern without taking significant damage, with slower swords, like the Lava Katana. I never had this problem in the PC version. With auto-attack, you need to stay still and auto-attack to survive. When this doesn't not work well, it makes the game difficult for (I feel) the wrong reasons.
          • [Fixed] Built shipping box difficult to use.


          Performance
          • [v1.07] Continuous jitter while walking around. While noticeable everywhere, it is the most noticeable in the farmhouse (slightly improved within the farmhouse).
          • [v1.03] Encountered nearly 0 fps performance in the Wizard’s house. Could not properly perform actions. Performance issue remained even after leaving and re-entering.

          Movement
          • [v1.03] Pathfinding Issues:
            • Around farm animals.
            • At the edge of the farm. Sometimes the player will touch the edge square, on the way into the farm (coming from the right side of the screen, where the bus is). They will stand on the edge and turn around and step back a space. This issue is intermittent, but it happens often.
            • In the Caves and Skull Cavern, there are pathfinding issues going around enemies. You will try to avoid contact with certain enemies, causing you to get stuck and killed.
          • [v1.07] Auto-attack makes it difficult to navigate safely around some enemies. For example, those nearly-harmless bugs that fly up and down while cause you to stop and swing continuously, making you an easy target if being chased by many other enemies. It also makes it slower to getting around levels with those enemies. It would be nice if you would only auto-attack them when standing next to them, stationary. Why am I auto-attacking downed skeletons and other impenetrable enemies? It is difficult to lay bombs and navigate when you do.
          • [v1.03] If you use a chest that you place near a door, in your Farmhouse or Warehouse, you will often warp and go outside once the chest is closed. This is especially dangerous, if you open your chest at 1:50 am and it puts you outside, causing you to unintentionally fall asleep out of your Farmhouse.
          • [v1.03] When fishing, I unintentionally move to a new location when holding down to cast over a water tile that is within range. This happens often, but is intermittent.
          • [v1.07] I cannot enter a barn or coop when an animal is nearby the entrance and will not move.
          • [v1.07] I often get off my horse when tapping somewhere on the screen to move. My player will get off the horse when the destination is reached. It seems to have something to do with what I am holding (i.e. sword vs. item), but it is not clear.
          • [v1.03] Could not get back onto my horse at the edge of the map, at a farm entrance. It kept sending me to the next screen, avoiding the horse.
          • [v1.03] When I entered a chest floor, in the Skull Cavern, a purple slime was stuck in the chest tile, unable to move.
          • [v1.07] Sometimes cannot enter the Farrmhouse basement from the right side of the stairs.
          • [v1.07] Entering the basement, from the right side of the stairs, always ends up with the player on the left side of the stairs.

          Animation
          • [v1.03] Sometimes (rare) when casting my fishing line, the sound of casting occur but there will be an improper casting animation. My character will stand there in a fishing post, but you cannot see the fishing pole, line, or anything else to do with fishing. When I click to end the fishing, there will be an odd animation where the fishing line shoots off to left side of the screen, and I will be able to walk around normal. Fishing right after has no issue. This issue is also intermittent and quite rare, but I have seen it about 5 times in my time.
          • [v1.03] When casting my fishing line, I pressed again mid-cast to cancel as I realized I didn’t use enough power. It showed two fishing line and bobber animations at once, once going in and one going out.


          Interaction
          • [v1.03] When I go to leave my bed, in the morning, I am always given the prompt to sleep. This is bad, as it is not difficult to unintentionally click on the option to sleep, thus throwing away your day, making it so that you have to quite the game immediately to avoid throwing away a day, unintentionally. I was able to work around this, partially, by placing my TV to the right side of my bed. I am now able to move off of my bed without getting this prompt. This is not ideal as it means I cannot place my TV or other items in my room the way I want.
          • [v1.03] Sometimes, the pickaxe and hoe hit the incorrect space (not the one highlighted and selected). This can be bad as it can result in you destroying (rare seed at day 23!) or uplifting things, unintentionally.
          • [v1.06] When I try to pick up an item or use a tool, when my horse is nearby, I will get on my horse instead, despite the horse not being the thing highlighted or selected when I performed the action.
          • [v1.03] Often, I cannot pick up an animal product (i.e. egg), off the ground, if an animal is nearby. It sometimes selects the animal, instead (improved when getting eggs).
          • [v1.06] When picking up an item to place it elsewhere, in the farmhouse, the item often deselects and cannot be easily picked up or moved.
          • [Fixed] Cannot close fence door.
          • [v1.04] Fences close and open too fast. Especially, with the Apple Pencil, they just close and open immediately.
          • [v1.07] Attacking grass and boxes, in various caves, tends to result in the player facing away from the object being hit.


          Item
          • [v1.02 or v1.03] I placed a cloth spinning machine in the tile two over left from the entrance of the warehouse. When I came back, the next day, the machine and cloth (I had placed on it) was gone. Little confused with this one. It has not happened again.
          • [v1.07] The hit box, for the crab pots, is off. When selected, I have to tap slightly off the crab pot, to activate it (i.e. to bait or remove).
          • [v1.03] When I went to the Sewer cave, a second time, I was went to open the chest and received nothing (as expected). The chest also disappeared (not expected). Has not happened a third time.
          • [v1.06] Crafting your last single capable batch of Winter Seeds will always make 100, instead of 10. Simple exploit.

          Audio
          • [v1.07] When you return to the top level of the Skull Cavern, while it is raining, you can hear the sound of rain from within the entrance of the Skull Cavern. It was not raining in the desert, but it was raining in Stardew. When you exit and re-enter the Skull Cavern, the sound of rain will be gone.
          • [v1.03] Received Facebook Messenger video call (not answered) and sound cut off. Had to restart the game to get the sound back.
           
            Last edited: Nov 17, 2018
          • AidenVennis

            AidenVennis Intergalactic Tourist

            It seems that the framedrop in the library occurs after I exit and reenter the app. First saw it happen when I got a call while playing. Also the music and sound stop working after re-entering the app while it worked before. Totally closing the app via the task manager solves these issues for me, but they reappear as soon as I temporarily exit the app again.

            This is on a iPhone X.
             
            • Fishille

              Fishille Void-Bound Voyager

              Playing on Iphone Xs I have experienced item duplication bugs when delivering items to bundles. I.e. when delivering a blueberry (only had quantity 1) to the summer crop bundle I completed the bundle but was left with my blueberry.
              I have also had issues donating items on the right side of my inventory to the museum. My work around has been to place items in the left hand side to deliver. clicking on the right side of the inventory ends up closing the donation screen.
               
              • Lam330

                Lam330 Space Hobo

                Ok, newest patch on mobile, October 30th. Ever since then I cannot build a farm building and then sleep without it crashing, so far I cant find any other help that actually works, please fix this. Thank you!
                 
                • hollabec

                  hollabec Space Hobo

                  Hi, as seen below by the red box behind the main menu button highlighting where I clicked, I cannot access my main menu. Any time I click it registers as though the menu isn’t there and I’m selecting the ground/objects around me. I can’t craft, select items, see relationships, much of anything. It’s a real damper on my game.

                  It started at the beginning of a new game day. I rebooted the game and even my phone itself multiple times to no avail. Only after starting a new quest did the error fix itself. It seems the main menu is unavailable when the quest menu disappears
                   

                    Attached Files:

                  • Otten

                    Otten Master Chief

                    I'm using an IPhone SE iOS 10.3.
                    Whenever i complete the introductions quest, when I save, close the app and then come back, the quest is back, with the last person I greeted. This is really annoying. If it helps to know, the only one left on the quest is Elliot.
                     
                    • Truckerai

                      Truckerai Intergalactic Tourist

                      Crashes when purchasing any animal and also the stable. I was able to move my save from my iPhone to Mac and purchase animals via the desktop version and the game is functional, but I stil can’t buy animals
                       

                        Attached Files:

                      • Jorelishe

                        Jorelishe Seal Broken

                        Is there any news as to when the next patch will come out? I DESPERATELY need to talk to Marnie for purchasing animals and a heater (she triggers my crash). I have played through an entire year since transferring (I transferred my PC save file over to my iPhone) but not being able to talk to her is really affecting my ability to move forward in the game ¯\_(ツ)_/¯
                         
                        • Moonmoon413

                          Moonmoon413 Intergalactic Tourist

                          I built a drop bin right next to my coop and I can't get into it at all. I tried moving it, thinking it was getting blocked or something, but it's still not working.

                          iOS 12.1 on iPhone 7
                           
                          • Hoov10s

                            Hoov10s Seal Broken

                            Playing on IPhone X - can not get into crafting/inventory screen via top right button (three stripes). When I press the button now the character just walks there. For some reason it was working when I had a task to complete and that additional button was present. I can’t craft right now - frustrating
                             
                            • Hitgirl911

                              Hitgirl911 Big Damn Hero

                              I got myself a shed and I can’t seem to put any wall decorations even when I tap on the wall decorations. I tried everything from cleaning the shed, to changing the item, to changing the flooring and the wallpaper, and I still can’t put anything on the wall. I could place wall decorations in my house and not my shed.
                               
                              • Tidero

                                Tidero Seal Broken

                                My chickens live outside even in the rain. and do not want to go into your aviary. the door is open. when you choose a chicken by hand and try to appropriate the house, it writes that it is full, but there is no one there. what to do then? how to get them back home????
                                 
                                • Katzeus

                                  Katzeus Community Manager Chucklefish

                                  Hello everyone, a new update with some big adjustments is being deployed right now. Changes include new control options and some improved saving functionality;

                                  1.04 (13 November 2018)
                                  • New control system options and improvements (full details):
                                    • Virtual joystick, invisible joystick options
                                    • Action / attack button option
                                    • Auto-Attack - targeting improved to always face the nearest foe. Easier to flee from monsters
                                    • Joypad adjuster tool - complete customization of your onscreen controls
                                    • MFi controller support
                                  • Slide toolbar up and down to access whole inventory
                                  • Game auto-saves so you can continue where you left off even if you kill the app or the device unloads it*
                                  • Game saves optional backup each time you exit an area
                                  • Option to increase the size of numbers in UI
                                  • (Fixed) Mine crashing when using ladder
                                  • (Fixed) Crash during night market after collecting a pearl
                                  • (Fixed) Casino currency bar hidden by UI
                                  • (Fixed) Monsters appearing during day on wilderness farm
                                  • (Fixed) Player constructed shipping bins not always accessible
                                  • Other minor bug fixes
                                  *Does not save during festivals/cutscenes. Only ‘end of day’ saves can be loaded to/from other platforms.
                                   
                                    Typhoon likes this.
                                  • Typhoon

                                    Typhoon Spaceman Spiff

                                    That's some very welcome additions and fixes, thanks to all those responsible. :)
                                     
                                    • Typhoon

                                      Typhoon Spaceman Spiff

                                    • Typhoon

                                      Typhoon Spaceman Spiff

                                      From reddit -

                                      "Can anyone else confirm that fishing is broken? I applaud the UI change when the reeling dialog opens, but you can’t see the fish in the gauge anymore. Big time bug!"

                                      https://www.reddit.com/r/StardewVal...ch_104_adds_mfi_support_more_control/e9mt9ig/

                                      User is playing the game on an iPhone XS Max

                                      Also from the same user -

                                      "Every time I fish. I also restarted the game to see if it would resolve with no luck. I mentioned them about the issue on Twitter. But yeah, gonna keep trying to get it to work."

                                      https://www.reddit.com/r/StardewVal...ch_104_adds_mfi_support_more_control/e9mu2nd/
                                       
                                        Last edited: Nov 13, 2018
                                      • Typhoon

                                        Typhoon Spaceman Spiff

                                      Share This Page