1. Lose your pre-order key? Try using Humble's key resender. Also, please check the support FAQs before posting: http://playstarbound.com/help/

Closed Starbound stuck at loading and unable to launch server

Discussion in 'Support' started by Raichael, Dec 12, 2013.

Thread Status:
Not open for further replies.
  1. Raichael

    Raichael Intergalactic Tourist

    Hi! Previously I had been having no problems with launching Starbound, but after I downloaded the new patch something seemed to have happened. I can launch the game but it sits at the loading screen for eternity. Also, when I try to use my server, which had previously worked fine, I get the message "StarException Named config function 'depth2' defined twice, second time from /biomes/oredistributions.configfunctions
    0041A34F (C:/starbound/source/game/StarRoot.cpp:130)
    ... (3)

    I've deleted my Starbound files twice and re-installed them, but nothing seems to be working at all.
  2. Bahumat

    Bahumat Space Hobo

    Having this same problem since update evening of December 11th. Just stuck on 'Loading' forever, no changes. Error code I get for Server startup:

    StarException: Named config function 'depth2' defined twice, second time from /biomes/oredistributions.configfunctions
    0041A34F (C:/starbound/source/game/StarRood.cpp:130)
    ... (3)



    The game isn't sanity checking the files in the directory. I had a backup of oredistributions.configfunctions titled 'oredistributions.configfunctions - more coal' in the directory, and evidently it was loading either that or both files. Deleted the backup file, everything worked fine.
    Last edited: Dec 12, 2013
  3. CeeDub

    CeeDub Void-Bound Voyager

    You made a backup copy of your oredistributions.configfunctions file, and left it in the folder. The game client tries to load -everything- under the assets subdirectory, regardless of file extension. Remove the oredistributions.configfunctions backup file and try again.
  4. Raichael

    Raichael Intergalactic Tourist

    I deleted this file and then my game told me that I had more duplicate files of another file. I don't though, so I don't really understand what is going on.

    DALAVISTIA Space Hobo

    im just stuck on the loading screen i didnt have any message pop up
  6. TapTap

    TapTap Void-Bound Voyager

  7. GrayWolfSev

    GrayWolfSev Space Hobo

    I to am stuck just on the loading screen. I figured maybe if I just wait but I have roughly 20 min in the game and all of it was spent on the loading screen. no error messages or anything.

    MLKMLK Space Hobo

    Im stuck on the loading screen also with no popoups and never even got to play the game once. So far i have waited about 15 min
  9. TapTap

    TapTap Void-Bound Voyager

    My solution was right clicking it in Steam selecting properties, then selecting Local files and clicking Verify Integrity of Game Cache...

    Hope this helps ;3
  10. dumb noob

    dumb noob Aquatic Astronaut

    my loading screen just takes a millenium but it still works, lol
  11. Jonesy

    Jonesy Sarif's Attack Kangaroo Forum Moderator

    The thing is, this thread is referring to an older version of the game. Since it's is no longer relevant, locking.
Thread Status:
Not open for further replies.

Share This Page