Tool Starbound Server GUI

Discussion in 'Starbound Modding' started by Senerio, Jul 25, 2014.

  1. Dunto

    Dunto Guest

    To detect if the server is operational (responding), you can open a TCP connection on port 21025 (or whatever port the server is listening on), the server will immediately send you a 32-bit integer containing the protocol version after a successful TCP handshake. If you don't get anything from the server, then you know that it crashed or locked up (can't initiate connection or server does not send version to you). See for more on this, this info is still relevant to the current version as far as I know.
    RatixFarrence likes this.
  2. Shinobi

    Shinobi Scruffy Nerf-Herder

    I had a check into the server.log of todays crash, and it appears that it didn't write to log fast enough before going down.
    I made a new empty log for today, so we'll see if that has any interesting info some time tomorrow probably.

    I'm listed on, and they have an API to their uptime system.
    There's a possibility you could use this to verify online status, because I have occasionally been able to login from LAN, but not been online outside. You'd think that was a router or DNS problem, but rebooting the server fixes it immediately.

    This is their text:

    To get the full detail of your server in json format. Can be used to create your own status page for example.


    ParameterValueDescriptionData TypeRequired
    keyxxxxxxxxYour Server API KeyStringYes

    And a result looks like this:

    { "name":"Shinobi's FFA Starbound Server", "address":"", "port":"0", "location":"Sweden", "hostname":"A Starbound Server", "is_online":"1", "players":"0", "maxplayers":"64", "version":"Beta v. Enraged Koala - Update 8", "uptime":"88", "score":"0", "rank":"188", "votes":"0", "favorited":"1", "comments":"2", "last_check":"September 26th, 2014 08:20 AM EDT", "last_online":"September 26th, 2014 08:20 AM EDT" }
    RatixFarrence likes this.
  3. Senerio

    Senerio Pangalactic Porcupine

    There you go. I added the crash handle. Hope it works.
    RatixFarrence likes this.
  4. Sykes

    Sykes Hard-To-Destroy Reptile

    Hey, so I'm trying to run this on the Unstable update (which people say it works fine). I've pointed it toward starbound_server.exe and I also pointed it toward the "universe" folder, but whenever I click "Start" I get an error that starts with this:

    (IOException) Cannot open filename 'sbboot.config' : No such file or directory
    And then the Server GUI gets stuck in "Starting..." mode and I have to reset the program. Am I doing something wrong?
  5. Senerio

    Senerio Pangalactic Porcupine

    I haven't tested it on unstable. I know there are issues with the nightly, but it still works. Perhaps since they pushed stuff on the unstable recently it made it inoperable.

    I might check it out. As far as I know you're doing it right.

    Edit: I quickly checked it out and it might be that you have to delete a few files in the Starbound directory. When you change from a version to another, some files need to be renewed. The error you get is not an error from the application, it's an error from the starbound_server.exe.
  6. Consumer of Souls

    Consumer of Souls Big Damn Hero

    I deleted every .dll file located in "C:\Program Files (x86)\Steam\SteamApps\common\Starbound\win32" and also that sbboot.cfg, then went to steam library and verified the integrity of the game cache. This fixed the error for me.
  7. ancientanubis

    ancientanubis Big Damn Hero

    so guys, I need your help...

    i constantly get an error message (seen below)

    and I can not seem to get around it, I have tried deleting all .dll files, deleting .config files (both sbboot and starboundconfig), I have also tried re-installing and i continue to get this same error, knowing my luck it is something simple and I am just derping hardcore, but I could use assistance


    [1:11:22 PM] Error: Fatal Exception Caught: (JsonParsingException) Error parsing json: expected JSON object or array at top level at 1:1
    [1:11:22 PM] JsonParsingException::JsonParsingException(string)
    [1:11:22 PM] Variant inputUtf32Json<U8ToU32Iterator<__gnu_cxx::__normal_iterator<char*, string>, char32_t> >(U8ToU32Iterator<__gnu_cxx::__normal_iterator<char*, string>, char32_t>, U8ToU32Iterator<__gnu_cxx::__normal_iterator<char*, string>, char32_t>, bool)
    [1:11:22 PM] Variant::parseJson(String)
    [1:11:22 PM] Root::Root(String, String, LogLevel, bool, String, Map<String, Variant, unordered_map<String, Variant, hash<String, void>, equal_to<String>, allocator<pair<String, Variant> > > >)
    [1:11:22 PM] Root::initialize(Map<String, StringList, unordered_map<String, StringList, hash<String, void>, equal_to<String>, allocator<pair<String, StringList> > > >)
    [1:11:22 PM] _main
    [1:11:22 PM] ___mingw_CRTStartup
    [1:11:22 PM] _mainCRTStartup
    [1:11:22 PM] RtlInitializeExceptionChain
    [1:11:22 PM] RtlInitializeExceptionChain
  8. Senerio

    Senerio Pangalactic Porcupine

    Which Starbound version are you using it with?
    Since when do you have this problem?
    Can you run the server fine for a while and then it crashes, or is it always on start up?

    I haven't updated this thing in a long time. It might be out of date. Though I can say since you're having the bug pop into the server output, it's not a bug from the GUI. Really I'm not an expert in the matter but if you wipe the entire folder and re-install (which I think you said you did), it should work. Beyond that you gotta contact the devs cuz it's a bug on their side.

    I might just do a little work on the GUI though, I had notice a few bugs last time I used it.
  9. ancientanubis

    ancientanubis Big Damn Hero

    im using the most current version (upbeat giraffe update 2)
    ive always had the problem
    i have never been able to get the program to boot

    your program is the only one out there that I have found to be worth anything, which is why i am (to put it bluntly) bothering with this instead of going to another program
  10. Senerio

    Senerio Pangalactic Porcupine

    I'm having the same issue. I'm figuring this out right now and I'll post a working version.

    Edit: Yeah so it seems the problem is more at the root than I thought it would be. This will take longer to fix.
    Last edited: Feb 21, 2015
  11. ancientanubis

    ancientanubis Big Damn Hero

    im no stranger to coding, what exactly is the trouble at the root?
  12. Senerio

    Senerio Pangalactic Porcupine

    I'm not sure, but from what I saw, the class I'm using to redirect the server output into my program is unable to properly start the server process.
  13. ancientanubis

    ancientanubis Big Damn Hero

    sorry, bit of a crazy week

    is the function that you use to use no longer viable or is it just being blocked for some unknown reason??
  14. Senerio

    Senerio Pangalactic Porcupine

    I'm guessing the new version of the server can't have its output redirected with it anymore. I haven't searched too much yet though.
  15. sethjd

    sethjd Void-Bound Voyager

    any news on an update to get it working?
  16. tomjim

    tomjim Void-Bound Voyager

    I would really like to help out, if this is built in dot net, or C++
    Is this project open source?
    Would you be willing to share your source?
    Is there a repository?

    I would interested in helping with the wrapper as it is simple clean and straight forward.

    So after moving about some files I have this thing working! And its really nice.

    Thanks Soren!

    The offer for help is still there
    Last edited: Mar 11, 2015
  17. Sepherchorde

    Sepherchorde Void-Bound Voyager

    THANK YOU FOR THIS PROGRAM! Seriously, it's exactly what I have been trying to find for the past few days. :D
  18. RowanFN

    RowanFN Yeah, You!


    I have this program and receiving a Json Paring Exception error, how do i resolve this to work with my server? If i run it normally without the GUI the server works fine.

    Also any idea for Mod Selection enable/disable support?
  19. Senerio

    Senerio Pangalactic Porcupine

    This tool is unfortunately outdated. Sorry :nurusick:
  20. Senerio

    Senerio Pangalactic Porcupine

    Hey everyone, it's been a while. I'm back on track after a long long long time.

    I found out that placing the server GUI with the starbound_server.exe actually fixes the problem the GUI was encountering when starting the server. So I made a couple of adjustments and the GUI should be working again if used properly.

    The GUI should now be compatible with both Stable and Unstable branch. If anything turns up, feel free to post a reply on these forums.

    I amended the first post but here's the tiny bit you have to do to set things right :

    How To Use :
    Simply download the executable and place it in the same folder as starbound_server.exe and launch it from there. (You can make a shortcut on your desktop)


    Download here : Starbound Server GUI
    danks_ likes this.

Share This Page