1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Closed Starbound and Visual C++ 2015 installer issues

Discussion in 'Starbound Support' started by Healthire, Aug 26, 2015.

Thread Status:
Not open for further replies.
  1. Healthire

    Healthire Can't Most Program the Least

    UPDATE: Your Starbound install no longer requires you to install the Visual C++ runtime.

    Last edited by a moderator: Sep 14, 2015
    Titanium, Dunto, matenebula and 3 others like this.
  2. Healthire

    Healthire Can't Most Program the Least

    Best Answer
    Kyren is working on a solution that doesn't require installing the visual c++ runtime. We did not anticipate this many people having trouble with what should have been a simple install. We will push out a new version as soon as possible.

    UPDATE: Your Starbound install no longer requires you to install the Visual C++ runtime.
    Last edited by a moderator: Sep 14, 2015
  3. Shooting Star

    Shooting Star Existential Complex

    So in other words, if you can't solve the issue, you are pretty much doomed to not being able to play SB ever again
    Titanium, BlastRed and BurgerBum like this.
  4. The | Suit

    The | Suit Agent S. Forum Moderator

    A bit overly dramatic - but after a little research some of the issues revolves around a bad windows installation which prevents certain Microsoft updates from being installed properly.
    There are certain things which can be controlled and there are certain things that can't. Simply put Microsoft tends to make sure everything it releases works on its own fully functioning unmodified operating system.
    If it doesn't, there is an issue with the operating system [ either caused by modifications - bad registry - file corruption ] or bad drivers.
  5. Healthire

    Healthire Can't Most Program the Least

    Are you still unable to install visual c++ 2015 after performing the steps above? Do you have any information to share about the problem? Error messages, logs, etc?
  6. roidanton

    roidanton Void-Bound Voyager

    it doesn`t work

    error: 0x80070005

    Attached Files:

    Titanium likes this.
  7. Healthire

    Healthire Can't Most Program the Least

  8. Shooting Star

    Shooting Star Existential Complex

    Ya after researching it a bit after a couple of hours I know what the issue is, just gotta update my windows version in the end and then it should work. But mine is pirated so it's my fault really in the end, I'll find a way around it or might consider putting a different operating system on my pc
    Like Healthire said it's the error you get given when trying to update the C++ without sufficient windows updates. So just updating it should do the charm. Unless yours is pirated that is
  9. godtier

    godtier Phantasmal Quasar

    I get the api-ms-win-crt-runtime-l1-1-0-dll error, and when I try to install Visual C++ 2015, I get an "access denied" error
    I'm on Windows 7 ultimate, do I need to instal service pack 1 ? I thought windows 7 ultimate already had it
  10. Mixizm

    Mixizm Void-Bound Voyager

    So, I have tried virtually everything suggested to me.

    Checking the win32/64 folders for the left over files: Not there.
    Making sure Windows 8.1 was COMPLETELY up to date: DONE
    Trying to run the prerequisites: Didn't work.
    Tried repairing: Didn't work.
    All the fancy command console work: Didn't work. (yes I followed it step by step)

    Does my game launch and work?
    No, still no. Can't even touch it. Havn't been able to enjoy one slice of Starbound recently.
    Titanium likes this.
  11. guiguijill

    guiguijill Void-Bound Voyager

    I have service pack 1 and win7 and Visual C++ 2015 don't want to install[DOUBLEPOST=1440612418][/DOUBLEPOST]the installation stop when it arrives in "Windows7_MSU_x64"
    Please guys i really wanted to play today ...
  12. ras464

    ras464 Scruffy Nerf-Herder

    I have SP1, updated everything, but I get an unspecified error each time I install the redists. According to the log it's because it can't execute a certain MSU file. After trying to install it manually (which it didn't), I found out I couldn't install it, because my laptop already supports the features in it and thus doesn't need it. I'm at a loss. I'll try digging some more, hopefully with better results. I've enjoyed the game up until this point.
    guiguijill likes this.
  13. Brekke K'ktus

    Brekke K'ktus Void-Bound Voyager

    I fixed it this way - read it somewhere on the forums yesterday... :DD

    EDIT: also installed again directX from _CommonRedist folder, dunno if that helped...

    Evor likes this.
  14. guiguijill

    guiguijill Void-Bound Voyager

    Same error like Ras464
  15. roidanton

    roidanton Void-Bound Voyager

    redownload of all windows patches fixed it for me
    i use windows 8.1
    Last edited: Aug 26, 2015
  16. guiguijill

    guiguijill Void-Bound Voyager

    So we need to wait right ? ...
  17. Varixai

    Varixai Hard-To-Destroy Reptile

    I'm in the same boat as everyone else unfortunately, can't play any version of Starbound right now, or unpack any assets. Can't get the redistributable to install. (have tried the steps in this thread and every other related thread I can find on the web)

    BurgerBum likes this.
  18. Healthire

    Healthire Can't Most Program the Least

    Some people have reported the issue stemming from a broken .NET framework install. Try uninstalling and reinstalling .NET and see if that helps.
  19. guiguijill

    guiguijill Void-Bound Voyager

    Framework 3.1 and 4.0 ?
  20. DatMusk

    DatMusk Space Hobo

    Reporting in. I'm running win7, Service pack 1 installed, net framework re-installed. I've followed along the thread and tried all the distinct steps listed there. When I attempt to install the visual studio 2015 package I receive a failure 0x80240017 - Unspecified error.[DOUBLEPOST=1440620933][/DOUBLEPOST]I have attached for your review a screenshot of the error as well as the error log.

    Please advise. Thanks!

    Attached Files:

  21. The | Suit

    The | Suit Agent S. Forum Moderator

    Windows 7 Ultimate is just a version of windows. Just like Pro \ Home \ RT etc.
    To learn if Windows 7 SP1 is already installed
    • Click the Start button [​IMG], right-click Computer, and then click Properties.
      If Service Pack 1 is listed under Windows edition, SP1 is already installed on your computer.
    More info here: http://windows.microsoft.com/en-us/windows7/install-windows-7-service-pack-1

    If you are getting access denied - chances are you are not administrator of your computer.

    If some of you have a Windows Live Account \ Hotmail Account \ Outlook Account
    You probably will get a bit of better help here


    Since the issue is a related to windows it self - Microsoft community would be more knowledgeable in it.
    Issue being Unable to install Visual C++ 2015 Resdistibutable.
    Last edited: Aug 26, 2015
Thread Status:
Not open for further replies.

Share This Page