Dev Blog Starbound 1.2.1 Changelog

Discussion in 'Dev Blog' started by mollygos, Dec 21, 2016.

  1. Hey everyone! We've pushed a small update . Here's a changelog!

    • Update bundled steam api
    • Various fixes to the ancient vault dungeon
    • Fix chat tabs not being clickable
    • Fix a potential threading issue related to steam p2p networking
    • Allow players to repeat the quest to unlock the vaults in multiple universes. Fixes an edge case where doing the quest on a server would make you unable to unlock the key trader in single player, and vice versa.
    • Fix issue where non-vault mission worlds would not reset after leaving
    • Make adjustments to texture atlasing to resolve certain framerate issues related to using larger texture sizes
    • Add "limitTextureAtlasSize" option in starbound.config to manually limit texture atlas sizes. Should only necessary for video cards significantly below the minimum requirements.
    If you're still suffering from severe framerate issues caused by the 1.2 update and not resolved in 1.2.1, please try:

    1. Disabling Multiplayer With Steam Friends in the Starbound menu
    2. Launching the game directly from the executable in the installation folder
    3. Enabling "limitTextureAtlasSize" in starbound.config

    While we are still interested in reports of general performance issues, only performance issues caused by 1.2 are in the scope of this major version update.

    This may well be our last blog update for 2016! Happy Holidays everyone, and thanks for
  2. Yavor

    Yavor Big Damn Hero

    Thank You for all your hard work! Starbound has become a part of my daily routine, and I love it! I wonder what do you plan next in the future content of this game?
    Titanium and CorruptedMathias like this.
  3. DragonsForce

    DragonsForce Weight of the Sky

    Oh thank goodnes for the mission reset fix :D That was annoying when farming bosses....

    Happy holidays to all of the CF team!
  4. treforza

    treforza Void-Bound Voyager

    I love you Molly! OXOXOXO
  5. CorruptedMathias

    CorruptedMathias Space Hobo

    Esse update ta ó, uma delícia! hauehaue vlw ae Molly pelo changelog ♥

    This update is such a delight! Hauehaue vlw ae Molly by changelog ♥
    Last edited by a moderator: Dec 21, 2016
  6. BatPetersAKAEnderzilla747

    BatPetersAKAEnderzilla747 Pangalactic Porcupine

    Yay. Now I must continue my adventures up to 1.2 content.
  7. DraikNova

    DraikNova Spaceman Spiff

    I've noticed that with 1.2, food sometimes remains in my inventory even after I eat it. The same thing happens with some mods: if I pick up certain items from them, I get both the mod version and the basic version. The mod in question is "Improved Containers". I'm including the name of this mod because it makes it really easy to see what's going on: with this mod installed, putting an item in a chest and breaking the chest should result in the inventory-format chest keeping the items; however, due to the bug, both an empty and a filled version of the inventory-format chest spawn when the chest is broken.

    To sum up: Due to a bug (that I've only seen in 1.2 and onwards), certain items effectively duplicate, with one being used and one being left behind in the normal fashion.
  8. supaflybirdy

    supaflybirdy Aquatic Astronaut

    I've noticed that outlaws always end up turning into soldiers or normal village npcs if they surrender, but never an actual outlaw for me.
  9. ViewtualR2

    ViewtualR2 Space Spelunker

    An error caused when try to play the mini arcadegame at outpost.And the log is like this:
    [Error] Exception while invoking lua function 'update'. (LuaException) Error code 2, [string "/objects/generic/arcadegame/raycaster.lua"]:28: bad argument #1 to 'cos' (number expected, got nil)
    stack traceback:
    [C]: in ?
    [C]: in function 'math.cos'
    [string "/objects/generic/arcadegame/raycaster.lua"]:28: in method 'castRays'
    [string "/objects/generic/arcadegame/arcadegamegui.lua..."]:111: in function <[string "/objects/generic/arcadegame/arcadegamegui.lua..."]:105>
    [0] 13ff33ee3 Star::captureStack
    [1] 13ff32c6e Star::StarException::StarException
    [2] 13ff07e81 Star::LuaEngine::handleError
    [3] 1400d5847 Star::LuaEngine::callFunction<float>
    [4] 1400d9194 Star::LuaFunction::invoke<Star::Variant<Star::Empty,bool,__int64,double,Star::String,Star::LuaTable,Star::LuaFunction,Star::LuaThread,Star::LuaUserData>,float>
    [5] 1400d9021 Star::LuaBaseComponent::invoke<Star::Variant<Star::Empty,bool,__int64,double,Star::String,Star::LuaTable,Star::LuaFunction,Star::LuaThread,Star::LuaUserData>,float>
    [6] 1406b13ec Star::LuaUpdatableComponent<Star::LuaBaseComponent>::update<Star::Variant<Star::Empty,bool,__int64,double,Star::String,Star::LuaTable,Star::LuaFunction,Star::LuaThread,Star::LuaUserData>,float>
    [7] 140725aeb Star::ScriptConsole::tick
    [8] 14064ca64 Star::paneManager::update
    [9] 1406f1d72 Star::MainInterface::update
    [10] 13fe7e083 Star::ClientApplication::updateRunning
    [11] 13fe7c88f Star::ClientApplication::update
    [12] 1405ed941 Star::SdlPlatform::run
    [13] 1405edafd Star::runMainApplication
    [14] 13fe7f9a6 WinMain
    [15] 1407d3db3 __scrt_common_main_seh
    [16] 76ef652d BaseThreadInitThunk
    [17] 7702c541 RtlUserThreadStart

    I didnt install any mod that includes the arcadegamegui.lua or raycaster.lua, so i think it may be a bug of 1.2.1.
  10. Stan1012

    Stan1012 Seal Broken

    What happened to the gardening tool station that made decorations for us. I miss it souch pls add it back again!
  11. Hurtwolf

    Hurtwolf Void-Bound Voyager

    Happy holidays CF!
    - I cannot wait for what 2017 has in store for this game!
  12. Hedix

    Hedix Void-Bound Voyager

    Hi, I played Starbound yesterday and everything was working just fine but today, when I tried to play after this update, my game got really laggy, as in 5-8 fps. I disabled/unsubscribed from all my mods, even checking the mod menu in-game to make sure they were no longer installed, to see if they were causing the problem, but that wasn't it. I'll try the solutions you listed to solve any problems with the "severe framerate issues caused by the 1.2 update and not resolved in 1.2.1", but I wanted to let you guys know first that something in this update has caused framerate issues for me and as such might be causing problems for others.

    Update: Disabling Multiplayer With Steam Friends in the Starbound menu stopped the framerate issue, but I am disappointed that an issue like this is in the game. I would hope to be able to play the game with friends without having to go through extremely low fps. Hope this can be fixed for the future.
    Last edited by a moderator: Dec 24, 2016
    Titanium likes this.
  13. VampyreNeko6669

    VampyreNeko6669 Void-Bound Voyager

    Hey there. Is anyone else having an issue where after being in the ancient vaults for more than a minute causes you to teleport to your ship? I've tried this three different times, and I've wasted a lot of material in buying keys cause of it.
    Everything in my game has been running fine so far until I got to the new content. I'll try the fixes listed, but I don't know if that will fix my problem. Or is my problem because I am playing with mods?

    EDIT: Tried the fixes, and while my computer runs the game better, still didn't help with the problem. Also, it teleports me everytime I kill an enemy. I was wrong, it wasn't a time factor.
    Last edited: Dec 23, 2016
  14. Dekadrachm

    Dekadrachm Heliosphere

    After this update it takes a considerably longer amount of time for starbound to launch. I have a good PC and I experienced no performance issues with 1.2, this however seems to have extended launch time about 5-10 minutes.
  15. Titanium

    Titanium Existential Complex

    did this little old thing get improved by any chance

  16. Ludux

    Ludux Void-Bound Voyager

    Also removed food bowls for your pet.

    That's right.

    You can't feed your pet anymore. :(
  17. Kawa

    Kawa Tiy's Beard

    Your pet no longer requires food.
  18. DraikNova

    DraikNova Spaceman Spiff

    I'm encountering the same issue now. A human outlaw turned into a soldier, another turned into a villager, and a Floran outlaw turned into yet another villager.
  19. Tanek

    Tanek Pangalactic Porcupine

    I don't require white chocolate macadamia nut cookies. Still nice to have the option once in a while, though. :p

    (did they really remove pet food bowls entirely?)
    Titanium likes this.
  20. Kawa

    Kawa Tiy's Beard

    ...mmmm, chocolate macadamia nut cookies...

Share This Page