Modding Help spawn a modded monster

Discussion in 'Starbound Modding' started by iamyoyoman, Jun 28, 2018.

Tags:
  1. iamyoyoman

    iamyoyoman Star Wrangler

    i made a monster and i can spawn it with commands and obgects like the monster spawner but when i tried to add it to a planet spawn pool it didnt work, that the code that i used.
    Code:
    [
        {
            "op":"add",
            "path":"/spawnProfile/groups/-",
            "value":{
                "select" : 1,
                "pool" : [
                [ 0.5, "hesha" ],
                [ 0.5, "poptop" ]
                ]
            }
        }
    ]
    "hesha" is my monster, i did it at desert.biome.patch and in every second planet i couldnt spawn ( and at the others poptops spawn like it ment to be) does any one knows why i cant spawn the modded monster like that? (when i try to get to the planet i get back to the ship)
     
  2. projectmayhem

    projectmayhem Ketchup Robot

    im assuming something is wrong with your monster. can post an error log? Since the poptop spawns fine, it seems its only messing up when attempting to spawn your monster. It could be anything from its movements to aggro action
     
    Last edited: Jun 28, 2018
    iamyoyoman likes this.
  3. iamyoyoman

    iamyoyoman Star Wrangler

    no error log, i just spown back to the ship insted of the planet https://streamable.com/o8tge BTW what happend at the first time didnt happend before.
     
  4. projectmayhem

    projectmayhem Ketchup Robot

    There is still an error log. Log in, beam down and get teleported back to your ship. Then go to your Starbound folder, open the Storage folder, then open Starbound.log
    Copy the entire contents of that log and paste them here. Make sure to use the CODE tags so it doesnt convert have your log into smiley faces.
     
    iamyoyoman likes this.
  5. iamyoyoman

    iamyoyoman Star Wrangler

    ty i find the problam
     
    Last edited: Jun 29, 2018
    projectmayhem likes this.

Share This Page