Modding Help (solved) mods not working post patch

Discussion in 'Starbound Modding' started by Shamyi, Dec 10, 2013.

  1. Shamyi

    Shamyi Big Damn Hero

    I somewhat expected that changes would need to be made given that the patch was such a drastic one
    but now it seems the majority of the mods that were running alright pre patch now all cause roughly
    the same error for me and I'm not really sure how to go about fixing it.. :/

    anyone have an idea as to what causes this?

    Knowing that combat and gear was changing I didn't touch anything pertaining to that.

    Last edited: Dec 10, 2013
  2. yohanu

    yohanu Orbital Explorer

    Unless someone else responds first, I'll find find the solution when I get off work in 2 hours.
  3. Shamyi

    Shamyi Big Damn Hero

    thanks :D

    hopefully by then it's solved, I'll post if anything changes
  4. TheWall

    TheWall Phantasmal Quasar

    If the mods included sword type weapons then there are a few property name changes.


    was moved into a "primaryStances" object along with the original "stances" object

    EDIT - you can see these changes in any of the existing vanilla swords

    EDIT - I can't seem to do anything without editing it five or six time... need to stop that. Anyway I believe this is part of the "stances system" Tiy hinted at in the update notes that will hopefully deal with the problem of aiming melee weapon or at least give variance to swings for hitting different targets.
  5. Shamyi

    Shamyi Big Damn Hero

    I usually end up doing the same, 4 or 5 edits tho usually
    to slightly change around wording cuz I feel the new wording says
    the same thing slightly better xD

    I've stayed away from modding any gear as I knew the change
    would likely break it so it's most likely not that .

    do you know of any changes to crafting, such as the way crafting tables are codded?
    I'll check out the post patch files but without the vanilla ones im not sure what i'd be looking for exactly
  6. TheWall

    TheWall Phantasmal Quasar

    One thing I found really helpful when my mods crash the client on load was the starbound.log file. If you search for every occurrence of the "Error" keyword, one of them usually gives a very good reason for the failure. Note that the other 30 errors make little to no sense and were likely caused by the one actual error.

    I backed up my old assets folder before the patch so I will start comparing files.
  7. TheWall

    TheWall Phantasmal Quasar

    Okay I think I found it. It was even in the stack trace that you sent and I didn't see it.
    in the Player.config file there is a line that has been added

    "bottomOfWorldTouchMargin" : 4,

    this line is missing from the old Player.config files.

    I will keep looking through the player.config for other differences

    EDIT - There are actually a lot of changes to the Player.config including some new items. I would recommend just adding in your recipes to a new copy of the Player.config
  8. Shamyi

    Shamyi Big Damn Hero

    all great finds :D

    I've managed to at least launch the game now by replacing the player.config with the new one
    tried just adding that "bottomOfWorldTouchMargin" : 4 line to the old player.config first and that still crashed it
    so I'm assuming there are other differences as well.

    now just to get the mod itself to work within the game or maybe it is..
    I'll try with a mod that would be easy to tell from the start xD

    edit: YESS!!! replacing the player.config with the new one and then
    reentering the lines for the mod fixes it. :D

    looking back.. i feel kinda silly for not realizing that player.config
    would most likely be the major change to mods x.x

    thanks for the info TheWall
    Last edited: Dec 10, 2013
  9. TheWall

    TheWall Phantasmal Quasar

    No problem. Actually I feel kinda silly for not seeing "player.config:bottomOfWorldTouchMargin" in your stack trace in the first place
  10. Saravind

    Saravind Tentacle Wrangler

    i can get all old mods to work that need to be added to player.config

    you need to add them to the newer player.config (if they need to be that is) because there is a fair few new lines in there now that it looks for and if not present it spams errors
  11. EvilEngineer

    EvilEngineer Starship Captain

    The player.config has to be recreated for each of your mods. And from what I can tell so far, stacking multiple player.configs between different mods isn't working right. The only one that will load say a new recipe is the bottom one in the chain.
    Shamyi likes this.
  12. Shamyi

    Shamyi Big Damn Hero

    o_O that solves my second issue of only my first character having the recipe for the mod.

    thanks :D
  13. EvilEngineer

    EvilEngineer Starship Captain

    You can currently get around this in one of two ways.

    1. Combine all new recipes into a new player.config that is in the bottom of the bootstrap load order.
    2. Load the character with the mod, have them learn the recipe, then quit and swap the order in the bootstrap for the next mod. Then log in and learn the new recipe... continue as needed.

    I'm thinking long term we need the modloaders to run the player.config and keep it in a folder of its own at the bottom of the boot order. Changes made to the mod loader will process into that single instance of the player.config to keep it consistent.
  14. googleben

    googleben Void-Bound Voyager

    I had the same error, redoing the recipes for my mod in the config fixed it for me. This is why you use the bootstrap method.
  15. TheWall

    TheWall Phantasmal Quasar

    doesn't the bootstrap method replace the entire Player.config (virtually)?
  16. EvilEngineer

    EvilEngineer Starship Captain

    yes, seems to only load 1 version it though. So if you have 3 mods inside your mod folder each with their own player.config , it will only choose one of them to load.
  17. TheWall

    TheWall Phantasmal Quasar

    yeah, the OP's problem was that his player.config was missing some new properties. Even if the modded player.config was outside the assets folder using the bootstrap method, it would have still thrown the error.

Share This Page