Tool SMAPI: Stardew Modding API

Discussion in 'Mods' started by ClxS, Mar 6, 2016.

  1. Marchen

    Marchen Aquatic Astronaut

    Hi, I'm new to this stuff, so sorry if I do/write something wrong.
    Recently I decided to replay SDV, this time with some mods. But something went wrong. I got an error after crafting a chest on a new save file. At first I couldn't hover my cursor over anything in my inventory, it skipped items and jumped over them, while I was holding the chest, so I dropped it on the ground and closed the backpack and then the game closed. I think it is a problem with some loose xnb files that I put in the XnbLoader because before I played for a while with mods alone and had no errors. Is there a way to find out which file causes problems or do I need to delate those xnb files one by one and check the game?
     

      Attached Files:

    • Pathoschild

      Pathoschild Space Kumquat

      Marchen likes this.
    • Pathoschild

      Pathoschild Space Kumquat

      SMAPI 1.15 beta is now available (see attached). This update mainly revamps TrainerMod's item commands, adds new features and changes for modders, cleans up the console a bit, and prepares for the upcoming SMAPI 2.0 release. See the release notes for a full list of changes. Let me know if you run into any problems using the beta (especially with mod key bindings); SMAPI 1.15 will be released this weekend if nothing comes up. :)

      [Edit: download removed; use the latest version instead.]
       
        Last edited: Jul 8, 2017
      • clueless frog

        clueless frog Intergalactic Tourist

        Hi, my game crashed when I used a hoe on a cask in my basement and now it won't reopen. Anyone know how to fix this?
         
        • 13akoors

          13akoors Big Damn Hero

          Do you have the error log?
           
          • clueless frog

            clueless frog Intergalactic Tourist

            I'm trying to pull it up, but its not showing anymore
             
            • clueless frog

              clueless frog Intergalactic Tourist

              I fixed it! I just reinstalled smapi
               
              • Pathoschild

                Pathoschild Space Kumquat

                @clueless frog That sounds like a known game bug (not related to SMAPI). I'm guessing reinstalling SMAPI didn't fix it, but something else you did at the same time (like rebooting) did.
                 
                • Kyluridae

                  Kyluridae Intergalactic Tourist

                  Hey, my game is crashing when it tries to save. I get into bed and it tries to save then goes black and crashes. I have not downloaded any new mods since the last time I opened the game so I'm not sure what it is. This is the first time I've tried to read the error logs so sorry if it's something obvious :confused: I see that SMAPI is about to update so I might download the beta and see if that helps. Here's the crash log.

                  EDIT: It's not crashing on my dummy save file which is a bit annoying. So it's something that I'm doing in the game. It also crashes if I exit out of the game to the menu and try to open a different game. Don't know if it's related. Didn't give me a crash log for that.
                   

                    Attached Files:

                    Last edited: Jul 6, 2017
                  • Yober

                    Yober Space Hobo

                    I tried to host a game for me and my friend. I had him join earlier today as a test and it worked fine but now i made a new character and world and tried to get him to join and it just instantly crashed my game multiple times. please help.
                     

                      Attached Files:

                    • Pathoschild

                      Pathoschild Space Kumquat

                    • Pathoschild

                      Pathoschild Space Kumquat

                      @Kyluridae We don't get much information from update-loop errors, so you'll need to narrow it down. Does the problem happen if you temporarily remove all mods? If not, install each mod one at a time; after each install, check if the problem is back.
                       
                      • Pathoschild

                        Pathoschild Space Kumquat

                        Stardew Valley 1.2.31 is released (see the release notes). This update shouldn't affect any XNB or SMAPI mods.
                         
                          Ladysarajane likes this.
                        • Kyluridae

                          Kyluridae Intergalactic Tourist

                          Okaaay so update on my problem. First of all it seems to be only the one file. I haven't run into the issue on any of my other files. The only difference I can think of is I have a horse and a stable in this file. I redownloaded SMAPI and was slowly uninstalling mods but nothing was changing. Then I accidentally ran the game through my backup folder that's in a completely different location. It's where I keep backups of all my things when trying new mods, except I just copied everything so its got the everything it needs to run. I've never done this before. And it worked there. Even though it still had all my mods installed. Steam could detect I was running the game and said I was running the game, but I don't know if I was actually running it through Steam at that point. Discord could not detect that I was running the game, but can detect it if I run it in the normal C:\Program Files (x86)\Steam\steamapps\common\Stardew Valley location. Also my file in the normal location detected I was able to save in the other location, however It won't even allow me to open the save file now. One thing to note is that I have all the normal .xnbs in the different location file. So no animal reskins or map retextures. However these are all working fine in my other files. Included latest crash log but it doesn't really look any different from the other one.

                          EDIT: Ok so I just tried running this file in the other location in my newest backup. This backup literally shouldn't be different from the normal one at all. Besides that I was running the game for a few days. Like, has all the same mods, all the same retextures, everything. It's just not located in C:\Program Files (x86)\Steam\steamapps\common\Stardew Valley. It's in my documents. Still worked fine.

                          ...while I was typing the edit thought I should try opening it in the normal location. Everythings fixed now....I'm so confused. Happy ending though? I opened it in a different, weird location and it fixed itself.
                           

                            Attached Files:

                            Last edited: Jul 7, 2017
                          • Pathoschild

                            Pathoschild Space Kumquat

                            @Kyluridae I'm guessing the problem was caused by one of your XNB mods. If so, playing the backup copy of the game let you continue past the error, so when you went back to your main copy you'd already progressed past whatever was triggering the error condition so it worked fine.
                             
                            • Pathoschild

                              Pathoschild Space Kumquat

                              SMAPI 1.15 is now available on Linux/Mac/Windows! This update mainly adds new features and changes for mods, prepares for the upcoming SMAPI 2.0, cleans up the console a bit, and revamps TrainerMod's item commands. See the release notes for a full list of changes. This is the last big release planned before SMAPI 2.0.

                              Feel free to post bugs/suggestions/comments in this thread. :)
                               
                                Karmylla likes this.
                              • Xuomi

                                Xuomi Zero Gravity Genie

                                @Pathoschild I installed the new SMAPI update and for the first time ever, Avast didn't seem to like the file and Steam locked up. Even after I added exclusions to the program, Steam was locked instantly and would not run. I've restarted my laptop 4 times after uninstalling and reinstalling the update only for Steam to freeze immediately (Avast no longer flagged the file). I uninstalled it for a fifth time and reverted back to the 1.14.1 update and everything works fine again. I don't have an error log to provide since I was never even able to open the game, sorry.
                                 
                                • Pathoschild

                                  Pathoschild Space Kumquat

                                  @Xuomi Antiviruses often block SMAPI for a while after a new release, because it's a new install they haven't seen before. As more users install it, most antiviruses should stop blocking it. I'm not sure what's causing Steam to lock up, though; maybe Avast is still doing something to the file even though you excluded it?

                                  I'm looking into code signing for SMAPI 2.0+, which should reduce false positives like this in the future.
                                   
                                    Xuomi likes this.
                                  • Xuomi

                                    Xuomi Zero Gravity Genie

                                    I'm not sure what's causing it to lock up either, but I'm going to stick with the previous version for a little while today and I'll try updating again later tonight or tomorrow. Hopefully everything works out better then. :)
                                     
                                    • koobish

                                      koobish Space Spelunker

                                      Before this update, SMAPI would hang on "starting game..." for no more than ten seconds. With this update, it seems to be hanging there for a few minutes and then delivering this error.

                                      (SMAPI 1.14 also f'ed up my game pretty horrifically, but that's a separate issue that I hope will be resolved with this update. I didn't submit error logs because it made my computer freeze and crash & could only be fixed with manual restart.)
                                       

                                        Attached Files:

                                        Last edited: Jul 8, 2017

                                      Share This Page