RELEASED [SMAPI 1.8] Smart Mod

Discussion in 'User Interface' started by KuroBear, Mar 5, 2016.

  1. XxhexerxX

    XxhexerxX Subatomic Cosmonaut

    Ikr. :(

    Have requested it on Ento's thread but it went without any mention, guess it was overlooked or something.
     
    • Kappreh

      Kappreh Void-Bound Voyager

      Any chance this mod will be updated?
       
      • wooby6

        wooby6 Scruffy Nerf-Herder

        Incorrect this mod doesn't conform with one of Entoarox rules

        The author was last seen Aug 30, 2016,
        It hasn't been 2 moths yet.
         
        • PipN

          PipN Void-Bound Voyager

          Would love and appreciate an update.
           
          • tobi1449

            tobi1449 Void-Bound Voyager

            Do you have any more detailed crash reports? I might be able to look into it.
             
            • chojustin

              chojustin Void-Bound Voyager

              Hi, I get this whenever I press the F1 button to open up the menu. It doesn't appear, but nothing crashes.
               

                Attached Files:

              • KuroBear

                KuroBear Subatomic Cosmonaut

              • Borodin

                Borodin Oxygen Tank

                I must admit I'm still using a really old SMAPI, because it works with several mods I prefer that have never been updated. But thank you for mentioning this. I'll reevaluate the mods I've got, and see if it's time to upgrade all around.
                 
                • SilentTrack

                  SilentTrack Void-Bound Voyager

                  Awesome mod and awesome update, thanks a lot!

                  算了老哥应该是个国人,还是说中文方便。游戏和SMAPI更新以后多了改了不少特性,我之前一直在用这个mod(突出一个好用),更新以后没了这个感觉玩的好累。今天上来看看居然真的更新了,谢谢大佬,感激涕零。

                  不过我发现按f1并不能打开mod菜单呀……物品栏的锁点了也去不掉,不过在游戏的option里找到了mod选项。游戏是steam的1.11,SMAPI版本是1.8。可能是我安装的姿势不对(content夹子不知道怎么处理,我就直接原样全扔在mods里了)?

                  一点小建议,大佬要不要考虑放到NexusMods上?这么好的mod放上去绝对点赞数爆炸呀。

                  277/5000
                  Suànle lǎo gē yīnggāi shìgè guórén, háishì shuō zhōngwén fāngbiàn. Yóuxì hé SMAPI gēngxīn yǐhòu duōle gǎi liǎo bù shǎo tèxìng, wǒ zhīqián yīzhí zài yòng zhège mod(túchū yīgè hǎo yòng), gēngxīn yǐhòu méiliǎo zhège gǎnjué wán de hǎo lèi. Jīntiān shànglái kàn kàn jūrán zhēn de gēngxīnle, xièxiè dà lǎo, gǎnjītìlíng.

                  Bùguò wǒ fāxiàn àn f1 bìng bùnéng dǎkāi mod càidān ya……wùpǐn lán de suǒ diǎnle yě qù bù diào, bùguò zài yóuxì de option lǐ zhǎodàole mod xuǎnxiàng. Yóuxì shì steam de 1.11,SMAPI bǎnběn shì 1.8. Kěnéng shì wǒ ānzhuāng de zīshì bùduì (content jiázi bù zhīdào zěnme chǔlǐ, wǒ jiù zhíjiē yuányàng quán rēng zài mods lǐle)?

                  Yīdiǎn xiǎo jiànyì, dà lǎo yào bùyào kǎolǜ fàng dào NexusMods shàng? Zhème hǎo de mod fàng shàngqù juéduì diǎn zàn shù bàozhà ya.
                  Forget the old brother should be a national, or Chinese convenience. Game and SMAPI update later changed a lot of features, I have been using this mod (highlight a good use), after the update did not feel the fun of playing tired. Today, look up actually really updated, thank you big brother, grateful.

                  But I found that f1 can not open the mod menu ah ... ... item bar can not afford to lock the point, but in the game option to find the mod option. The game is steam 1.11, SMAPI version is 1.8. I may be installed in the posture is not right (content clips do not know how to deal with, I was all the original exactly in the mods)

                  A little bit of advice, big brother should not consider put on NexusMods? So good mod put up absolute point praise burst ah.
                   
                    Last edited by a moderator: Mar 23, 2017
                  • Jonesy

                    Jonesy Sarif's Attack Kangaroo Forum Moderator

                    Please note that all posts must be in English, or provide a translation. I've added one for you, but you need to include one yourself from now on.
                     
                    • KuroBear

                      KuroBear Subatomic Cosmonaut

                      Thx for your support, Mod Menu has moved into Game Setting Menu, and some keybind has changed, All keybind can found in Mod Menu
                      -
                      感谢支持, Mod菜单已经移到游戏设置菜单里面了, 有些快捷键绑定改了, 可以再Mod菜单中找到所有的按键绑定

                      1.jpg
                       
                        Last edited: Mar 24, 2017
                      • SilentTrack

                        SilentTrack Void-Bound Voyager

                        Okay boss, sorry for that.
                         
                        • MK-I

                          MK-I Void-Bound Voyager

                          Love this mod, but i was so used to Inventory Rotator/Slot Switch I can't play without it. Why did it get removed? Too many bugs?

                          And did anyone find a way to use xbox RB or LB to switch rows?
                           
                          • KuroBear

                            KuroBear Subatomic Cosmonaut

                            Im waiting for SDV 1.2 and SMAPI 1.9
                            I will release new version including Inventory Rotator and Controller Support after that
                             
                            • MK-I

                              MK-I Void-Bound Voyager

                              Ah its a built-in feature in the beta! Going to have to wait til official release then, hopefully its April and not 3 months from now.

                              Thanks for the quick response, and for the great mod!
                               
                              • KuroBear

                                KuroBear Subatomic Cosmonaut

                                Update to 2.02, ! Serious ! Fix a bug about Store All To Container
                                 
                                  khai9999 likes this.
                                • khai9999

                                  khai9999 Void-Bound Voyager

                                  Latest version (2.02) will be compatible with SMAPI 1.9 right?
                                   
                                  • KuroBear

                                    KuroBear Subatomic Cosmonaut

                                  • khai9999

                                    khai9999 Void-Bound Voyager

                                    Just test with v2.10 for smapi 1.9 ... Load only your mod then bam! Error
                                     

                                      Attached Files:

                                    • KuroBear

                                      KuroBear Subatomic Cosmonaut

                                      Only for SMAPI 1.9 beta 15 or later
                                       

                                      Share This Page