Modding Help Reset collision detection?

Discussion in 'Starbound Modding' started by FizzyGalacticus, Jan 5, 2016.

  1. FizzyGalacticus

    FizzyGalacticus Scruffy Nerf-Herder

    This is my first time posting here, so please pardon me if this is not the right area. I'm trying to modify a teleporter object, but I cannot seem to get rid of the base collision bounds. I'm trying to make it so that there is no "step" to step onto.

    I've looked around here and elsewhere, without much help. I've found entries about the "collisionSpaces" variable, but changing/removing that doesn't help at all. I've also toyed with "spaceScan", still no effect.

    I've tried looking for formal documentation, but there doesn't seem to be much, especially anything outlining specific variables and usage.

    Thanks in advance!

    Attached Files:

  2. lazarus78

    lazarus78 The Waste of Time

    Get rid of this line:

    "collisionSpaces" : [ [-2, 0], [-1, 0], [0, 0], [1, 0] ]

    Removing it wont undo collision already set. You need to break it and replace it.
    FizzyGalacticus likes this.
  3. FizzyGalacticus

    FizzyGalacticus Scruffy Nerf-Herder

    I've tried removing that line, yet it does nothing. I've also tried changing the values. I'm under the impression that each of those values is a coordinate relative to the object?
  4. lazarus78

    lazarus78 The Waste of Time

    Reletive to its origin location which is effected by it's offset values, yes. It represents one gridspace.

    Did you remove the object and replace it? I generally will remove the object entirely, as in delete it from my inventory, then restart the game. I find old values tend to linger at times.
  5. FizzyGalacticus

    FizzyGalacticus Scruffy Nerf-Herder

    I've removed the object and completely replaced them after restarting the game. Still the same thing. I've even turned on debugging and it shows the red collision/sensor lines.

    I'm new to modding, so pardon me if this is a dumb question: Is there a chance that there are universal rules set for teleporters that would give it this step? I'm not really sure what it is, but in the object file, there is a line like this:

    "npcToy" : {
    "influence" : [

    Any chance that has something to do with it?
  6. lazarus78

    lazarus78 The Waste of Time

    No dumb question, unfortunatly its not the case. What does your whole teleporter json look like? I tested it and it worked for me, so me thinks there is something else in there.
  7. FizzyGalacticus

    FizzyGalacticus Scruffy Nerf-Herder

    Alright, I got it. I'm not sure exactly where the problem was, but I completely shut down everything, changed that line to:
    "collisionSpaces" : [ [-2, -1], [-1, -1], [0, -1], [1, -1] ]

    ...and restarted. Now it works as planned. =)

    Thank you for your help!
    lazarus78 likes this.
  8. lazarus78

    lazarus78 The Waste of Time

    Glad you got it working.
    FizzyGalacticus likes this.

Share This Page