Modding Help Racial patch for FU/Race compatibility not working sometimes, other times works fine?

Discussion in 'Starbound Modding' started by Cuddlycuttlefish, Mar 19, 2021.

  1. Cuddlycuttlefish

    Cuddlycuttlefish Void-Bound Voyager

    Hello! I'm coming here in hopes of getting some help. I'm extremely new to modding, but I made a patch recently for the "mollopods" race that adds frackin universe's racial stats & BYOS function

    For reference that mod is here on the workshop: https://steamcommunity.com/sharedfiles/filedetails/?id=2427232435&searchtext= (I can also share some sort of github of all the files if that's useful!)

    Now the issue is that SOMETIMES the patch doesn't work, & other times it works totally fine. I've triple checked all my files & they match other similar patches, I've even tried breaking the patch into two parts (so that BYOS and racial bonuses are separate) -- I've tried with and without FU's modded races mods, too, to the same effect.

    I've only been able to recreate the issue with an entirely new universe file, & when it happens there's many "failed to load" errors for mollopod items from the original "mollopods!" race mod

    for example:
    [Error] Could not load image asset '/items/armors/mollopod/mollopod - dress/bsleeve.png:idle.5', using placeholder default.
    (AssetException) No associated frames file found for image '/items/armors/mollopod/mollopod - dress/bsleeve.png' while resolving image frame '/items/armors/mollopod/mollopod - dress/bsleeve.png:idle.5'
    these types of error are not there without my patch, & its not there when I'm on my original universe with the patch, but is there consistently when I start over with brand new player/universe files.

    Long story short, has anyone run into a similar experience? is there a file I'm maybe missing? Is this something to do with mod priorities? I just can't figure out why it only happens sometimes & not other times, but again... I'm so new to this, I made my mod mostly by referencing similar patch mods lol

    Any help would be appreciated! ;v; tyty~
     
  2. Cuddlycuttlefish

    Cuddlycuttlefish Void-Bound Voyager

    Update: (after an hour and a half of trying to find some sort of typo or mistake somewhere)

    I uninstalled every other mod I have other than one of the functioning patched races, & ofc the two dependent mods mine needs

    Here I have my mod downloaded from the workshop, & it happens to be working fine : https://pastebin.com/Wpb198yU
    Here I have that exact same mod unpacked and in my mods folder, not working: https://pastebin.com/XTszdXrd

    Two days ago neither was working, unless I was on my old universe & players

    I can't seem to reliably recreate this issue, which is making it impossible to solve. Dx
    I even unpacked the workshop mod & tried to run that with the same issues xD I do not get it

    UPDATE update:
    ok so while trying to figure out how to add priority I noticed the metadata didn't include the required mods that I added in the workshop... so, after adding that file it seemed to allow the mods to load correctly every time now?

    I'm HOPING that fixes the bugs in the bugs discussion on the workshop, so I'm not closing this 100% until I hear back from the couple of folx having issues but.... if this does fix it then... well, go figure, 3 days of debugging work & as soon as I make a post asking for help I find the possible issue xD
     
    Last edited: Mar 20, 2021

Share This Page