1. These forums have moved. You can find the community for Lenna's Inception on Reddit or joining the developers on Discord.

Prevent Screen From Sleeping [Please Read Mr. Tom]

Discussion in 'Suggestions' started by rchpweblo, Jan 22, 2016.

  1. rchpweblo

    rchpweblo Void-Bound Voyager

    This is killing me! So I have my screen set to turn off after 5 minutes of inactivity. Every time I play this game, whether I'm using a keyboard or controller, the screen sleeps after 5 minutes. You would not believe how extremely annoying this is! Normally this does not happen with other games as they (most likely) use this API (or an equivalent). Now I'm no code expert here but that API seems like it would be pretty simple to implement. Implementing this would mean the world to me because I would finally be able to play your glorious, glorious, game without constant interruption. I very much hope you read this, Mr. Tom, and decide to implement it, because this little problem detracts from the game experience in a very large way.

    Thanks for reading,

    P.S. I just ordered a Sega Saturn USB controller to use with this game. I think they were meant for each other! Also, I'll be sure to report how the controller works with the game after I use it for a bit.
    • tccoxon

      tccoxon Procedurally Generated Programmer

      Which version of Windows are you using? It seems like there should be a setting in the control panel to stop Windows going to sleep while it's receiving keyboard / controller input.

      Please do let me know how the Sega Saturn controller works out! I have a USB SNES controller I've been testing with. It should just work after you configure it in Options, but more controller compatibility info is always useful!
      • rchpweblo

        rchpweblo Void-Bound Voyager

        I'm using windows 10, and I checked the mouse and key board settings and they are set to wake windows. I noticed my controller has the wake option grayed out, but it is a Bluetooth controller so that may be why.

        Anyway the controller arrived today but they sent me the wrong one! :facepalm: It was a Genesis controller not a Saturn controller! I'll have to return it and order the correct one.

        Oh, and I guess I should tell you the compatibility of my current controller (which is Bluetooth), the ipega Extending Game Controller. Everything works great except a small bug where pressing the R2 trigger causes the character to start walking up until you press another button or move the d-pad/control stick.

        I'll post to this thread when the Saturn controller arrives and tell you how it works.
        • Dunto

          Dunto Guest

          Probably because your controller doesn't use the right Bluetooth profile, so Windows won't let it wake the computer:
          Basically it depends entirely on what kind of device your controller's driver registers itself as (keyboards/mice are HIDs). Unfortunately changing that requires changing drivers, but there's a couple things you can do to work around your driver issue if it doesn't register as an HID:
          1. Use a program that virtually presses keys like Caffeine (with the usual warnings about running third-party utilities, it's your decision and entirely your risk, I won't be responsible, etc) and run it in the background when you play. I'm pretty sure anti-cheat software would take exception to this type of program though, so watch out if you're running a VAC-protected game or similar.
          2. Create a new power profile that doesn't ever sleep/suspend/hibernate and switch to it when you're using that controller. I believe Windows 10 lets you quickly switch power profiles from the battery/AC icon (if you have it shown), then you can switch back to your regular power profile when you're done with the controller.
            tccoxon likes this.

          Share This Page