1. This forum is primarily for mobile related issues - for support for PC/Console visit the support section of forums.stardewvalley.net

Bug/Issue Please help! Game crashes when loading save game after update

Discussion in 'Support' started by mercif17, Oct 11, 2016.

  1. mercif17

    mercif17 Intergalactic Tourist

    (I am not very tech savvy so please bear with me as I try to explain what happened)

    Yesterday I updated my Windows game to 1.1 through GOG. At first I just deleted all of my mods and SMAPI because I hadn't updated them yet and I just downloaded the game from GOG and it replaced some of the files in my folder but it crashed when I tried to open it. Then I actually uninstalled the game and reinstalled it but this time it crashed when trying to open my save file. So I downloaded the updated version of SMAPI so I could see the red text error it was getting. It runs fine at first and says it's loaded 0 mods but then when I try to open my save game, the game crashes again and I get a lot of red text.

    I've attached the most recent error log.

    Can someone please point me in the right direction?
     

      Attached Files:

      Last edited: Oct 11, 2016
    • Ladysarajane

      Ladysarajane Phantasmal Quasar

      What mods did you have, before you updated? It may be one of those mods may needed back in before you can load the game up again. Are you able to start a new save?
       
      • mercif17

        mercif17 Intergalactic Tourist

        Let's see, it says I had BundleMod, CJBCheatsMenu, MoreArtifactSpot, TrainerMod, LovedLabels, and XmlSerializerRetool. I found updates or updated equivalents of the ones I want to keep but haven't added them in yet because I was trying to test what was making it crash without the mods in the picture. Do you think I should add them in one by one and see if any of them make it not crash? I've already tried it with all of them added back in and with none of them but I don't think I've tested each one.

        I haven't tried doing a new save because I didn't want to have to go through the super long intro and then have it crash. Maybe I'll try that tonight and see if it helps, but I'd like to be able to keep my original character if possible.
         
        • Ladysarajane

          Ladysarajane Phantasmal Quasar

          I am not familiar with BundleMod, MoreArtifactSpot or XmlSerializerRetool so I don't know if those would crash the game if they were not there. I know the game should run without CJBCheatsMenu and LovedLabels. The error is occurring I believe with the missing XmlSerialzerRetool.

          Try to start a new save. If it crashes let me know, but it should run with the vanilla. If it runs, add the XMLSerializerRetool back into it, as long as that mod has been updated for 1.1. Once you added it back in, try the original save. It should run.

          Edit: My thought is correct, unless you have a save backup prior to the XMLSerializerRetool being added the first time, your save will NOT run, and unfortunately according to Nexus, it is not updated and will not run in 1.1
          A new save should run just fine.
           
            Last edited: Oct 12, 2016

          Share This Page