1. This forum is primarily for mobile related issues - for support for PC/Console visit the support section of forums.stardewvalley.net

Bug/Issue No Invite Codes/Invite Friends Buttons

Discussion in 'Support' started by jaykingplays, May 5, 2018.

  1. jaykingplays

    jaykingplays Space Spelunker

    SOLVED

    Introduction:
    Hello again my fellow critters and creeps, the local fool has arrived to ask for your sympathies to ease my pleas during these fine salutations.

    Problem: We have finally got the game working, but now a new problem has arose. When trying to host an online game, I'm not given the option to invite a friend or given a button for an invite code. To put it simply...

    This is what my screen is supposed to look like:

    [​IMG]

    This what my screen looks like:

    [​IMG]

    Troubleshooting done before coming to the forum:

    As mentioned, this is my second time posting. The first time I posted, I was trying to understand why my game wasn't loading at all. However, after much consideration I repaired all of my C++ files, and ran steam as administrator and got the game rolling. I did that just this afternoon.

    Any other information we should know?

    My friend was online so we did a few other ways to see if there was a work around

    1) We tried having my friend, who can see invite codes and invite friends, invite me through steam. Didn't work

    2) We tried me hosting the game and giving him my IP address seeing if he could connect that way. Didn't work

    3) We made sure all the files were verified. The update was patched. We reinstalled both versions of the game, restarted the computer. Didn't work.

    4) I tried starting an entirely new farm all together, going through the Host new farm tab, and seeing if it would work by showing me the codes or invite buttons, did not work

    5) We tried to see if I could right click in the steam friend messenger to see if it would show, the only thing it showed was that I was allowed to invite my friend to watch

    Please let me know what other information you require. As of now, the only farm on the game is the farm made specifically to host friends. It does have a cabin to host my friend.

    UPDATES:

    Problem solved, here's what happened:

    I went to double check to see if my firewall was off by making sure that my windows firewall was off. It was off, but the Comodo Firewall was not off, despite being in silence mode. Make sure to go through all your settings and confirm that the firewall is not just in "silent mode" but completely off. If you have Comodo Firewall, here's how you turn it off:

    How to Disable Comodo Firewall:

    1) Open Comodo
    2) On the main window (not the widget), you can turn off the firewall by clicking Disable/Enable Firewall
    3) If not shown, open settings
    4) Go to Firewall Settings
    5) First option should allow you to check it on and off, check to see what other options you may or may not want to disable.
    6) Make sure to turn on firewall once you're done playing your game/at your convenience to protect your computer from potential malware if visiting dubious sites/checking your email

    BTW, if you have Windows Defender as your only firewall, whenever there is a major update on the computer you need to make sure to go into your settings and disable it every time. It's why I got a third-party firewall in the first place because this firewall is very difficult to get to (comparatively to the above situation), and it will automatically set as hardcore SAFE MODE be unless you get a third-party firewall protection.

    How to Disable Windows Defender Firewall:

    1) Go to Windows Settings
    2) Click "Open Windows Defender Security Center"
    3) Click "Firewall & Network Protection" (it will also show you if your third party firewall is on and have a hyperlink to your third party firewall)
    4) Click your network between the three choices (each choice is technically a different mode you can set for your computer, this was made more for laptops/smart devices that have the ability to connect to multiple modes, depending on what you claimed your current network is, it will be affected by this modes settings).
    5) Go to the Windows Defenders Settings
    6) Click Hyperlink that will turn on/off your Firewall
    7) Make sure to turn on firewall once you're done playing your game/at your convenience to protect your computer from potential malware if visiting dubious sites/checking your email

    There may be a way to exempt the game and have the firewall (most 3rd party firewalls have this) be automatically turn on and off when playing a game, but I have find most firewalls aren't very well at automatically turn on/off without detection issues on a consistent basis.
     
      Last edited: May 6, 2018
    • Myoux

      Myoux Void-Bound Voyager

      I'm having this exact same issue, and none of these fixed mine either. If you find a fix for this, please let me know.
       
        Aquariae and jaykingplays like this.
      • o0Yarrow0o

        o0Yarrow0o Space Hobo

        I am also having this issue and none of the above have helped for us either.
         
          jaykingplays likes this.
        • jaykingplays

          jaykingplays Space Spelunker

          My issue was solved, check original post and see if the troubleshooting fixes the issue. If not I would recommend making a new thread.
           
          • jaykingplays

            jaykingplays Space Spelunker

            My issue was solved, check original post and see if the troubleshooting fixes the issue. If not I would recommend making a new thread.
             

            Share This Page