1. Hey Guest! Our new game Wargroove has released! Check out the forums or wiki for more information!
    Dismiss Notice

Resolved No "_commonredist" folder in Program Files (x86) ... Stardew Valley

Discussion in 'Support' started by Jiigenn, Apr 12, 2019.

  1. Jiigenn

    Jiigenn Intergalactic Tourist

    Hello,

    I'm having the white screen on launch crash and I've tried everything except "Run xnafx40_redist.msi in C:\Program Files (x86)\Steam\SteamApps\common\Stardew Valley\_CommonRedist\XNA\4.0" because that folder doesn't exist for me.

    https://i.imgur.com/9VAUAb3.png

    I have:
    Uninstalled and reinstalled the game through Steam
    Deleted startup_preferences
    Uninstalled and reinstalled Microsoft XNA Framework redistributable in Windows
    Changed the fullscreen and windowed mode value in the config
    Pressed F12 while launching the game

    The only solution I haven't tried is running or repairing xnafx40_redist.msi because _CommonRedist is not in my (x86) file path.

    I have played hundreds of hours without a problem, took a break for about 6 months, and now the game won't launch anymore. I have attached my error log. Any advice is appreciated.

    Windows 10
    Build ID : 3611060


    Thank you!

    Jiigenn
     

      Attached Files:

      Last edited: Apr 12, 2019
    • Pathoschild

      Pathoschild Cosmos Killer

      Steam changed how files are distributed, so the _CommonRedist folder no longer exists. Sounds like you're following an old guide; see these steps on the wiki instead. Try reinstalling the .NET Framework and XNA Framework versions linked from that section.
       
      • Jiigenn

        Jiigenn Intergalactic Tourist

        Thanks for the reply Pathoschild! I tried the steps in the wiki but unfortunately it didn't fix it. Also, I found xnafx40_redist in C:\Program Files (x86)\Steam\SteamApps\common\Steamworks Shared\_CommonRedist\XNA\4.0 and ran it but it didn't work either. Oh well, thanks again and I'll keep searching.
         
        • Pathoschild

          Pathoschild Cosmos Killer

        • Jiigenn

          Jiigenn Intergalactic Tourist

          Hi Pathoschild, I found a comment you left on reddit and advised to close RivaTuner. That fixed it! You're the best, thank you! :) Anyone having white screen on launch problem and running RivaTuner, close it (and MSI Afterburner too because it will just re-launch RivaTuner).
           
          • Pangaea

            Pangaea Forum Moderator

            Marking as resolved.
             

            Share This Page