Modding Help New To The Forums, Please Help (SMAPI Issue)

Discussion in 'Mods' started by Fabbu, May 15, 2017.

  1. Fabbu

    Fabbu Void-Bound Voyager

    Hello there! I've been an avid player of Stardew Valley for almost a year now, and just recently I've decided to beef up my game experience by using mods. I have quite a few mods installed now, and I downloaded SMAPI 1.9 to deal with my mods. It worked perfectly.

    I ignored future updates because I'm an idiot and should not be trusted with things and played on.

    When I got a mod that needed the latest version, specifically Seasonal Immersion (and by extension the Seasonal Victorian Buildings and Flowers mod by Eemiestardew) I downloaded the newest version of SMAPI and followed the standard procedure. Except, when I loaded up the modding API, this happened -


    I tried using SMAPI versions 1.10 and 1.11 the same thing happens again.

    After that I uninstalled Seasonal Immersion and downgraded back to 1.9, which works fine for me.

    Is there a problem with SMAPI or is it just the mods I'm using?

    Currently using the Trainer Mod, CJB Item Spawner, Get Dressed, and Clean Farm.

    Thank you!
    • Entoarox

      Entoarox Oxygen Tank

      Update stardew valley, you are not using the latest SDV 1.2 version that SMAPI 1.10+ are made for.

      Share This Page