Modding Help Need help with patching hairs for specific race mods

Discussion in 'Starbound Modding' started by Mightyfarmer3, Jun 4, 2020.

Tags:
  1. Mightyfarmer3

    Mightyfarmer3 Big Damn Hero

    Hello. I have some trouble with patching. Hairs are not showing when in character creation. Here are my codes I'm working with in the zombie.species.patch file. I have the hair files and the base mod is unaltered but still it doesn't work.


    Code:
    [
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman01" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman02" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman02b" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman03" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman04" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman05" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman06" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman07" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman08" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman09" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman10" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman11" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman12" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_fhuman06" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman13" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman14" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman15" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman16" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman17" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman18" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman19" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman20" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman21" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman22" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman23" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman24" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman25" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman26" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman27" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman28" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman29" },
    { "op" : "add", "path" : "/genders/0/hair/-", "value" : "anti_mhuman30" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_fhuman01" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_fhuman02" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_fhuman03" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_fhuman04" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_fhuman05" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_fhuman06" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_fhuman07" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_fhuman08" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_fhuman09" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_fhuman10" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_fhuman11" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_fhuman12" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_mhuman08" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_fhuman13" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_fhuman14" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_fhuman15" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_fhuman16" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_fhuman17" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_fhuman18" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_fhuman19" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_fhuman20" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_mhuman21" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_mhuman22" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_mhuman23" },
    { "op" : "add", "path" : "/genders/1/hair/-", "value" : "anti_fhuman21" }
    ]
    
     
    Last edited by a moderator: Jun 4, 2020
  2. projectmayhem

    projectmayhem Ketchup Robot

    Are you making sure that your mod is loading after the other mod, so that you're hair styles are being added
     
  3. Mightyfarmer3

    Mightyfarmer3 Big Damn Hero

    OMG. It worked. Thank you very much for reminding me the load order! I just added in "priority" parameter and put a number of 1+total amount of mods I have and it worked.
     
  4. projectmayhem

    projectmayhem Ketchup Robot

    Not a problem :)
     

Share This Page