Modding Help Need help making a recipe

Discussion in 'Starbound Modding' started by fluffbun, May 7, 2022.

  1. fluffbun

    fluffbun Space Hobo

    I'm officially stuck. I thought I was doing it right, but after it not working no matter what I tried, something must be screwed up.

    I modded in a new clothing item, it's legwear with the item id "socksandshorts". I tried making a recipe for it but it didn't work. Here's the original contents of the .recipe file:

    "input" : [
    { "item" : "fabric", "count" : 2 },
    "duration" : 5,
    "output" : { "item" : "socksandshorts", "count" : 1 },
    "groups" : [ "craftingwheel", "clothes" ]

    I don't know what's wrong with it. I don't know what's causing it. Someone please help. Additional information can be given if necessary
  2. DrPvtSkittles

    DrPvtSkittles Master Astronaut

    I know I responded to you on discord, but I am just going to paste what I replied here for those who are interested

    { "item" : "fabric", "count" : 2 }, remove that comma at the end

    starbound creates a log of errors and its very handy

    Starbound\storage its the one called 'starbound' with no numbers

Share This Page