Modding Help My unpacked folder is missing files

Discussion in 'Starbound Modding' started by Melendroach, Jul 23, 2018.

  1. Melendroach

    Melendroach Subatomic Cosmonaut

    I tried unpacking the packed.pak file using three different methods:
    1. typing the command in the cmd
    2. by using a downloaded unpacker
    3. using an online unpacker
    But some files in my unpacked folder are still missing. For example, most armor sets only have 1 or 2 parts instead of 4 (head, torso, legs and both sleeves). I tried to search for the missing files, but there are no results.

    The only thing I can think of is downloading the unpacked files from the internet, is there any way I can do this?

    Or can any of you just send me the file I'm looking for, which is the dragonhead folder with all the contents?
    (This is of course a temporary solution, but if nothing else can be done...)
     
  2. Kordharin

    Kordharin Big Damn Hero

    There are some useful things in a folder that's called "osx" on my system. It has a couple commands called "asset_unpacker" and "asset_packer". Try again, if possible, with a refreshed Starbound.

    1. Open cmd.

    2. Open Starbound's main folder.

    3. Drag & drop "asset_unpacker" into cmd

    4. Drag & drop "packed.pack" into cmd.

    5. Drag & drop "asset_unpacker" into cmd again, and change the last bit a little. Probably by adding a slash, which depends on which system you're using.
     
  3. NexusTheBrony

    NexusTheBrony Spaceman Spiff

    the unpacking process has to finish before you press any keys in the CMD window. try using the unpacker batch file i have in my signature. when it is done, it will say "press any key to continue"
     

Share This Page