1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Bug/Issue Mod-Related Item on Ship Causes Crash On Character Select

Discussion in 'Starbound Support' started by KnifeDavis, May 15, 2018.

  1. KnifeDavis

    KnifeDavis Space Hobo

    Hey everybody,

    I’ve searched the forums for a thread that relates to this kind of problem, but haven’t found anything that's applicable to my situation, and I'm still waiting on a response from Chucklefish support about this after 2 months. If I somehow missed a thread with a solution to this problem, or if I’ve posted this in the incorrect area, let me know.

    So, here’s my problem: A friend whose game I had joined (not on a dedicated server, just via the Steam interface) placed an item from a mod that I was not subscribed to on my ship. The game crashed and I got the error message “Exception caught in client main-loop (MaterialException) No such material id: 33791”. When I opened I attempted to rejoin her game, the same error occurred, and when I tried to run a solo game, the application crashed with no error message before the ship and all the assets on it could finish loading. It’s done this every time I select my character since.

    I’ve tried the following, none of which have resolved this:

    1) uninstalling and reinstalling the game

    2) uninstalling the mods that I had

    3) installing the mod that caused the error (namely, Pokèmon Plushies)

    4) installing all of the other mods my friend had at the time

    5) verifying the game files – Steam verifies them successfully

    6) creating a new character to see if the crash still occurs – it doesn’t, and game runs normally

    7) replacing the current storage folder with one from a backup I made a long time ago – game runs normally, with the save data from back then

    I’m sure the crash occurs when the game is trying to load objects in on launch and gets to that one, but I don’t know if there’s a way to remove its code from my files, or how to do it if there is one, so I’ve attached my .log to this post. I play Starbound on a MacBook Pro running High Sierra (OS 10.13.3) and have never had a problem with it before now. Like I mentioned, it seems that I can successfully get it working using an old save from not long after I’d just started playing the game, but I’d really like to find a solution that allows me to restore my broken save and not lose all of my progress if at all possible.

    Thanks! I’m looking forward to hearing from anyone who can help.

    Attached Files:

  2. KnifeDavis

    KnifeDavis Space Hobo

    Oh yeah, and I have version 1.3.3.

Share This Page