1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Notice Looking for help reproducing Multiplayer via Steam framerate issue

Discussion in 'Starbound Support' started by Healthire, Jan 24, 2017.

  1. Healthire

    Healthire Can't Most Program the Least

    We are having trouble reproducing an issue where having the "Multiplayer via Steam friends" option enabled causes constistently low framerates of around 5-10 fps. In order to investigate the causes of this an update has been put on Starbound - Unstable, providing some hopefully useful log information.

    If you have this issue and want to help out, please follow these steps:

    1. Download and run Starbound - Unstable on steam
    2. Go into single player, with a new character if you don't already have one
    3. Open the options menu and check/uncheck the "Multiplayer via steam friends" option, and confirm that having it enabled causes your framerate to drop.
    4. Close the game
    5. Find your starbound.log file, which will be located in <your steam folder>/steamapps/common/Starbound - Unstable/storage/starbound.log
    6. Either upload the starbound.log file here, or put it on http://pastebin.com, or if you're particularly concerned with privacy (the log may contain your steam user id) you can send it to me in a private message

    All help reproducing and fixing this issue is highly appreciated!

    For this thread we are only interested in framerate issues directly related to and caused by enabling the "Multiplayer via steam friends" option. Unrelated reports and discussion of issues will be removed to keep the thread clean and readable.

    Thank you!
  2. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    Fps mostly at 60. Sometimes it went down to 40 when loading new sprites/effects/npcs which were off-screen before.
    Went to a garden planet, collected core fragments, got to outpost and doing the EMF.
    Log is attached.

    Edit: it seems there is a remnant of the workshop. But it shouldn't affect the results.

    ~ Iris ~

    Attached Files:

  3. Hel

    Hel ✨ Johto's Finest ✨ Forum Moderator

    I just gave it a go for you.

    I was roaming and digging on my starter planet. Found the gateway and dug down near it. I made a big drop which I kept falling down, still 60, had 61 in places. Lowest I saw was 57.

    It made no difference to me.

    Attached Files:

  4. NuclearSlayer52

    NuclearSlayer52 Subatomic Cosmonaut

    for me i fixed it by restarting my pc...

    if it doesnt fix you can technically launch it through steam while preventing the lag by clicking "ADD A GAME" at the bottom left of default layout of steam games then go to your starbound install directory area.... if you add it itll allow launching through steam and having the steam overlay.... problem is that this is only a solution for those who dont use steam servers.....

    though if anyone having the problem left their pc on playing music through VLC Media Player on repeat overnight or anything else thats similar then maybe thats what caused it... im not sure but its likely a memory issue or something from not restarting or shutting down or whatever....

    basicly restart your pc/laptop/something that has starbound on it and hope for the best....

    also for those having the 27 fps thing go into the settings and disable vsync...

    btw just a thought but both of these had that happen for me.... the frame drops just started happening for both... i wasnt having the vsync issue until suddenly it happened and same with this...

    btw it is possible mazebound caused this too if everyone else having the issue recently got its achievement.... but again try restarting your pc and see if that also fixes it preferably after testing with the unstable so that theres ways to find something similar between everyone as for me since i managed to fix it through a restart i cant really do it again (even playing the music cause my mom and sister had to listen it all day as my keyboards pause buttons dont actually work with VLC lol but if needed i can say which song)

    also is there a spoiler page length stopping thing? as in not like on steam where it basicly puts a background on it until hovering but you shorten my typing into like 3 lines rather then 300?

    EDIT: appears to be happening again so im gonna restart my pc again and ill edit this again if that fixes it again k

    EDIT 2: restart is what fixes it btw

    EDIT 3: by fixes it i mean for me for those who dont read mass messes of words and just skip to the end so preferably if it works for you say so pls
    Last edited: Feb 12, 2017
  5. LordZeon

    LordZeon Void-Bound Voyager

    Here's my log file. I can confirm that I have severe framerate issues when "Multiplayer via Steam Friends" is enabled. As the log says, I:
    - started Starbound - Unstable for the first time
    - switched to Borderless Window
    - started a new character in the tutorial
    - experienced the issue
    - turned off "Multiplayer via Steam Friends"
    - instantly experienced normal framerates
    - turned "Multiplayer via Steam Friends" back on
    - experienced the issue again
    - quit the game

    I took a peek in the log file, but I didn't see anything out of the ordinary. My developer spider senses aren't really giving me any bright ideas about what might be happening, either. It's not sucking up any significant amount of CPU time, or memory, or even network capacity. It's almost like the Steam P2P component is just getting priority over the UI thread. Super weird. Weirder still, I have no idea what would cause my instance to be unique among so many others.

    If you guys need any further help debugging the issue, don't hesitate to contact me. I'm in the US, so I might take a while to get back to you, but I'll be happy to help.

    Attached Files:

  6. Healthire

    Healthire Can't Most Program the Least

    Thank you so much for testing, this is very useful information. I have pushed an update to Unstable. When you have some time, do you think you could try that and see if it's any different?
  7. LordZeon

    LordZeon Void-Bound Voyager

    I did the same test again and got the same results. It looks like there has been no change. While Steam says it downloaded a 63.9MB update, I haven't been able to precisely verify that I'm using a new binary (other than the last modified timestamp), since version numbers in game don't change. I also attached the log because why not.

    EDIT: I do see that the steam_api64.dll has been updated at some point between the Stable and Unstable branches to (and, via ListDLLs, it is the version that is loaded for Starbound.exe), so that may be confirmation enough that the test environment is what we expect it to be.

    Attached Files:

    Last edited: Feb 14, 2017
  8. Healthire

    Healthire Can't Most Program the Least

    Thanks, yeah that update was an update to the bundled steam api so you were probably on the right version.

    My best theory now is that some other service in the steam api causes the p2p networking service to wait for a lock for ~100ms every update. If you want to help test, I've uploaded another update to Starbound - Unstable that will allow you to test this. If you download the update, delete your starbound.config, and run the game again it will create a new starbound.config. This will have this key in it:

    "platformServices" : {
       "statistics" : true,
       "p2p" : true,
       "ugc" : true,
       "desktop" : true
    Try setting all of the services except "p2p" to false, then run the game. Check in the log to make sure the log says "UGC platform service disabled" and "Statistics platform service disabled", and check/uncheck the multiplayer via steam option in the options menu a few times.

    If disabling the other services makes the issue go away, try re-enabling each one to see which combination of services causes the issue to appear again.

    Sorry this is so convoluted, but not being able to reproduce this issue ourselves makes finding it very hard. Thank you for taking the time to help us so far, it has been very helpful!
  9. LordZeon

    LordZeon Void-Bound Voyager

    I'm afraid I'm going to have to shoot that theory down, at least in its current form. Turning off all the settings but P2P didn't make any difference. Still experienced the same behavior.

    One interesting, but probably irrelevant, quirk I've noticed is that at random intervals of <60 seconds the game seems to catch up for maybe a full second. I've timed these moments and I don't see any pattern or regularity (45s, 15s, 25s, etc.). I initially thought this might be a sort of timeout waiting period, but it doesn't seem to have any rhyme or reason.

    The thing that keeps getting stuck in my head is: why me? There has to be a reason that my instance, and a handful of others, is behaving like this. It seems to be most likely related to the implementation of the Steamworks P2P service, but that would either have to be some sort of config problem with Steamworks or a very selective piece of logic in that implementation. Of course without source code I'm just guessing, but this bug is pretty well wedged into my head and leaves me wondering.

    It's my pleasure to help. I know full well how much of a pain it is to try to debug something that you can't reproduce, so I'm happy to lend my time.

    Attached Files:

  10. Healthire

    Healthire Can't Most Program the Least

    Could you also try running a dedicated server and joining it? There should be a Starbound Unstable Dedicated Server app in your steam tools section, so you can run it externally from your main game. After joining it see if having "Multiplayer via steam" enabled on your client still causes the same issues.

    EDIT: I've also done yet *another* Starbound Unstable update, so if anyone who *can reproduce the issue* and wants to run that and post a log that would be very helpful.
    Last edited: Feb 15, 2017
  11. LordZeon

    LordZeon Void-Bound Voyager

    WELL THAT'S INTERESTING. Using a local dedicated server works fine, as you would expect, but the log file is filled to the brim with "Disable P2P connections: p2p networking not in use in multiplayer mode" every 20ms or so.

    I still get the same results from the standard test, though. Slow with P2P on, and fine turned off.

    Attached Files:

  12. Healthire

    Healthire Can't Most Program the Least

    There's a new unstable build. I'll save the courtesy for later and just say: more logs please!

    Only single player necessary, the information that it doesn't happen in multiplayer is actually very useful.

    That's my bad, I put that log statement in there and didn't realize it prints on every update.
  13. LordZeon

    LordZeon Void-Bound Voyager

    One single player log comin' up. And holy verbose timer logging, Batman! And, for clarity, it still behaves the same way.

    Attached Files:

  14. TheLegitimantis

    TheLegitimantis Void-Bound Voyager

    I've been having some performance issues lately as well. I just tried out the newest Unstable update and the game seems to perform pretty well.
    I don't have the issue with Steam Multiplayer, but the game generally runs pretty poorly anyway (My specs are well above the minimum).

    At 2x zoom everywhere, the game runs pretty well. Solid 50-60 FPS planetside, flawless 60 on my ship, and 30-40 in the Outpost.
    No idea if it'll be useful or not, but my log is attached.

    Attached Files:

  15. Healthire

    Healthire Can't Most Program the Least

    That's a bingo! I have put a potential fix on Starbound Unstable, could you download that and see if you still get the issue?
  16. LordZeon

    LordZeon Void-Bound Voyager

    You've done it! It works flawlessly with the P2P component turned on! What was happening?

    Attached Files:

  17. Downfall

    Downfall Intergalactic Tourist

    Disabling my "multiplayer via steam" fixes the terrible performance it seems. Keep up the good work! I was just given this game from a friend but we cant even play because of the performance issue.
  18. Healthire

    Healthire Can't Most Program the Least

    One of the steam api functions inexplicably takes about 1000 times longer for a very small fraction of users. I made it so it's called not so often. ¯\_(ツ)_/¯

    Thank you! Couldn't have fixed it without all your help!
  19. sacredbishop

    sacredbishop Subatomic Cosmonaut

    i have a problem, with all of the changes in the unstable version, my game performance has improve a lot, but i still have some issues with fps when i'm visiting other parts of my world, or mostly when any mobs appears on the map. is there any possibility that is conected with de steam issue ?

    i don't have my logs because i¿m not on my pc.
  20. LemonLeman

    LemonLeman Void-Bound Voyager

    We've talked about this before on Discord, but...
    I've tried this and my game still lags when I'm in-game. Either my computer isn't enough to handle this game and the problem is unsolvable, or something else is happening. I think it might be the former, though, so for now I've kind of given up. I'm sure this solution works on some computers, but for my low-end laptop it hasn't.

    Even the extra config option added in the unstable version a couple months ago didn't do much for me, and I still get unplayable fps. Again, my computer may be poor for running this game anyway, so I'm hoping that when I get a cover keyboard for my tablet I can play the game again.

Share This Page