Tutorial Installing mods for Starbound 1.0

Discussion in 'Starbound Modding' started by The | Suit, Jan 20, 2015.

  1. The | Suit

    The | Suit Agent S. Forum Moderator

    I generally keep all backups on Github and mediafire for the very reason.
  2. Arfloglo

    Arfloglo Space Hobo

    If you could explain to me how to do the steam way, that would be great. My mods are crashing my game when It tries to load. ;e;

    I've subscribed to all available species mods on Steam, and I have the XBawks mod too.

    I also don't know where to go in order to uninstall any of the mods, if need be. I realize that I am quite ignorant.

    Fixed it myself, sorry for this. All I had to do was unsubscribe from one of the mods that didn't work. ;e;
    Last edited: Jul 22, 2016
  3. The | Suit

    The | Suit Agent S. Forum Moderator

    Steam is just hit subscribe.
  4. Arfloglo

    Arfloglo Space Hobo

    Thanks, didn't see that until I refreshed the page. :p
  5. Shaadaris

    Shaadaris Existential Complex

    Um... Something that hasn't exactly been clear. I would make a thread but I feel this is relevant to installing mods in general - do .modpak files not function anymore?
    I have two .modpak mods installed and they are suspiciously missing from the mod manager and their effects are not showing (they are just graphical mods.)
    Can I convert .modpak to .pak, and if so, how?
  6. Fauxglove

    Fauxglove Subatomic Cosmonaut

    I'm so happy that Starbound mods now have steam support! Quick question. If I've previously installed mods for earlier versions, do I need to go in and delete files or anything before installing mods through Steam? or can I just subscribe and be on my way?
  7. KaleShibata12

    KaleShibata12 Subatomic Cosmonaut

    You're failing to mention that even if you pak itwith CMD paking it will not fix the mod not working if there's no metadata somewhere and all other kinds of hitches. a more fluid description in your explaining how to take a zip file lacking a obvious metadatafile should be handled. as it is this update has made modding for people with spare time to pull their damn hair out. been up for two hours trying to get the vespod mod and the avali mod to work...unpacking it to the storage labeled 'storage' at one point also does not fix the fact is is now no longer registered by my game at all, and the steam versions do not specificy all these so I'm left in the figurative dust here. And no I already tried unpaking it to the mods folder...that wasn't a typo it was me testing something to see if my computer was that stupid. anyone got a less irritating way to figure this crap out?

    Draw me a roadmap if you must even.
  8. The | Suit

    The | Suit Agent S. Forum Moderator

    Metadata file is not required for unpacked folders - if it not registered by the game you are making the mistake as listed above. The metadata file is just an easy marker to make sure you are installing it correctly.

    You should ask the mod author to properly pak their files for 1.0
  9. Tavinhu

    Tavinhu Intergalactic Tourist

    I am subscribing to mods but they do not appear in the mod section on the start menu
  10. The | Suit

    The | Suit Agent S. Forum Moderator

    Did steam start a download?
    Unless it downloads first you won't have them.

    You might need to restart steam so the download begins.
  11. CBWX

    CBWX Subatomic Cosmonaut

    what is this .metadata you speak up i see no .metadata in my folder.
  12. cryomancer27

    cryomancer27 Intergalactic Tourist

    I have the same problem, workshop content is listed in the downloads page for me and the files are in workshop\content\211820, at least I think they are(there are a bunch of numbered folders with content.pak in them with times which seem to correspond with my subscribing of the mods). Should I move these somewhere or something? Nothing is showing up in the ingame mods list other than the regular two, and the features aren't appearing as far as I know.
  13. agmoyer

    agmoyer Scruffy Nerf-Herder

    Okay I did not know .pak files actually made it that much easier, I plan to be making mods (maybe move some) for the Workshop. How would I turn the mod into a .pak file?
  14. The | Suit

    The | Suit Agent S. Forum Moderator

    Create a .bat file with the code
    "location of asset packer" "location of folder to pack" "<Location of where to put the file>name of file.pak"
    Of course without the less than and greater than -
  15. KaleShibata12

    KaleShibata12 Subatomic Cosmonaut

    Also at 3 am every thing is irritating and a brain is tired. forgot i even made that post since that reason...

    also Modinfo files are evidently metadata files as well. so either or I suppose could be mentioned. Though the pak process, if this is going to be a sticky it should probably be including the commands for paking files that are zip files. Placing a folder with the datafile in it does nothing, however paking the zip file if it has the metadata/modinfo file in it seems to accomplish the same exact thing. worth mentioning under that point.
  16. Jerboy33

    Jerboy33 Void-Bound Voyager

    How intalling mod's with format .modpak?
  17. The | Suit

    The | Suit Agent S. Forum Moderator

    modpak is no longer supportd in 1.0
  18. Shadox2.0

    Shadox2.0 Ketchup Robot

    EDIT : solved

    About the .pak my first try was ok , but when trying to instal 2 mod with a folder it dont work :/ , i'v trying to place the folder next to the .pak but dont work , same if i put the .rar in the folder without extract them , and if i want copy past the folder content from the mod it ask for overwrite a common file with another mod (the player.config.patch) so IMO its ot good too.

    So you said what we must do with the .pak file but not with a mod in a folder x) , i've try check youtube tuto but they are all outdated (except a video of 10m for something who didnt work even in the video lol) , so i'm lost.

    Edit ; its for that :

    (the .pak one is EnhancedStorage(HoarderEdition)_v2.2 and work well , i'll try PerenialCrop .pak but IMO it'll work since i dont have problem for instal pak mod) edit ok the other .pak work)

    EDIT nevermind it was in an advanced crafting station , so i didnt see them , but folder mod work nice for me too now.
    Last edited: Jul 27, 2016
  19. Megaman X Fusion

    Megaman X Fusion Void-Bound Voyager

    ERROR: 1)TStarbound 1.0 has no 'Giraffe' storage folder 2)some mods are not .pak or have metadata
    Last edited: Jul 29, 2016
  20. Shadox2.0

    Shadox2.0 Ketchup Robot

    Strabound Girafe was a version before starbound 1.0 , so you dont need a girafe folder since its not our version.

    If its a .pak , drag it to mod folder , if its a folder mod , just drag the folder in same folder (mod).

    My mod folder look like this if it help you
    (2 folder mod / 3 .pak mods)

Share This Page