Modding Help How to release mods in V. Offended Koala

Discussion in 'Starbound Modding' started by tifel100, Dec 15, 2013.

Thread Status:
Not open for further replies.
  1. G4M5T3R

    G4M5T3R Cosmic Narwhal

    Yea that was stable and running for me, unless I did something wrong at the last second it should be working. It's really reading it as if they are separate mods?
    This is how I got SoME mod running again. A SoME inside a SoME with a .modinfo didn't work for me. Which is what happes if I select and zip the folder instead of the contents inside.

    * Do I want my mods folder to look like this then?
    Last edited: Dec 15, 2013
  2. tifel100

    tifel100 Void-Bound Voyager

    yeah, but the .modinfo inside not outside each folder.

    Also, I couldn't fix the It has too much files and depends alot on the normal game. Kept getting Access Violation errors. :(
  3. CatBerry

    CatBerry Subatomic Cosmonaut

    thank you very much for that easy to understand explantion :)
  4. Who-hoo

    Who-hoo Big Damn Hero

    Yeah, I fixed it. Should be working now.
  5. Heliostorm

    Heliostorm Phantasmal Quasar

    Fortunately I was using the bootstrap method before, so updating my mod was as simple as adding the modinfo file.
  6. Spacerogue

    Spacerogue Void-Bound Voyager

    I got mine working again as well (it was a stupid error ,all my own fault harhar)

    but since I'm making a race, can someone point me in the direction of this Kawa mod for custom races ? I'm using preset 6 just like very other custom race and I can see this becoming problematic when more and more races get released.
  7. G4M5T3R

    G4M5T3R Cosmic Narwhal

    Spacerogue likes this.
  8. mvx

    mvx Tentacle Wrangler

    are player.config files overwriting each other still, or is it able to parse and include changes?
  9. Xuhybrid

    Xuhybrid Scruffy Nerf-Herder

    They overwrite the entire file. The last mod in your mods folder to overwrite it will be the primary one.

    Im adding support for Tabula Rasa to all my mods.
  10. mvx

    mvx Tentacle Wrangler

    ty Xu :D
    Xuhybrid likes this.
  11. poster55

    poster55 Scruffy Nerf-Herder

    Not sure if someone else answered this for you, but your structure is off. You have assets inside of your mod folder, but the way the game reads your mod folder would be that Cjacobs_DS_RIGs in this case would be the assets folder. So basically pull items out of the asset folder and put it right in the Cjacobs folder.

    It should look like Cjacobs_DS_RIGs\items\armors\human etc etc etc.

    As opposed to how it is currently setup where you have it Cjacobs_DS_RIGs\assets\items\armors\human

    The game is going to read this as assets\assets\items etc etc... :)
  12. Patchumz

    Patchumz Pangalactic Porcupine

    It should be noted, for modders, that you need to use the proper file structure for your mods now. Simply dumping edited files in your mod won't work anymore. So make sure your structure mirrors the asset structure or the mod won't work.
  13. tifel100

    tifel100 Void-Bound Voyager

    Not 100% true I have this directory:
    Still works.
    Basically, if you're editing something, you put it in the same structure. If you're adding something new, you can place it in a file called anything.
  14. Xuhybrid

    Xuhybrid Scruffy Nerf-Herder

    The only thing that matters is your file extensions, for example .beamaxe

    You could put all files into a single directory if you wanted.
  15. Patchumz

    Patchumz Pangalactic Porcupine

    Well, for example: The Ultratech mod, and the Teletech mod both wouldn't work unless I properly structured the tech files. And those were completely new things. Previously this wasn't the case and they could be simply dumped into the folder.
  16. tifel100

    tifel100 Void-Bound Voyager

    They are new things, and I got mine to work by just putting /modName/Telekinesis/fileshere
  17. Patchumz

    Patchumz Pangalactic Porcupine

    Ah, maybe that was the problem. They dumped their files in the root folder, as opposed to having a Techname folder. Well then, either way you can't use the root folder as a dump spot anymore :p. Though that should be obvious.
  18. Visigoth

    Visigoth Space Hobo

    Hey it works... Cool Beans thx :D
  19. RockyTV

    RockyTV Big Damn Hero

    This new method doesn't merge the .config files.
  20. Marrond

    Marrond Space Hobo

    Hmmm... for some reason I can't get custom item to working. I put custom armor while preserving original structure and it's working but I can't get simple stick to working - game hangs on loading screen before even showing main menu.

    Everything goes back to normal once I delete .item files from :

    I've tried dumping it into
    but it doesn't load either (and I already have there one custom item that's craftable through furnace and it's working perfectly fine).
    What I am doing wrong? Armor in
    is working perfectly fine for example.

    As for item code, I copied it from previous game version (it worked back then):
      "itemName" : "darkwoodstick",
      "rarity" : "Common",
      "inventoryIcon" : "darkwoodstick.png",
      "description" : "A stick",
      "shortdescription" : "Stick"
Thread Status:
Not open for further replies.

Share This Page