1. This forum is archived for reference. For support & bug reports visit the help section of forums.stardewvalley.net

Bug/Issue Horse Riding Bug

Discussion in 'Support' started by Feweo, Jul 16, 2016.

  1. Feweo

    Feweo Void-Bound Voyager

    This is more of a 'be aware' thread than 'fix it NAOW!' thing.

    So, I was riding my horse through the forest south of the farm to go fishing for pike for Maru. Being the multi-tasker that I am, I tried to switch from the sword (in slot 1) to the fishing pole (in slot =), but I fumbled a key and hit the - key before the = key in quick succession.

    Suddenly, this happened (open images in new tab if they do not via right clicking on the broken image icon):






    As interesting as it is that my character became a battle maiden, this sort of ruins the day because of the following reasons:

    1. Upon gaining Chippedcalibur, my character is rooted to the spot. My character can 'turn' and make motions of moving in a direction, but stuck. Very stuck. So very stuck. Love that running in place.

    2. Cannot select ANYTHING. Mouse moves and the items along the toolbar expand and contract when I wave the cursor over them... but I cannot click on anything. Along with this, I cannot select items via keyboard keys either with numlok on or off.

    3. Esc key no longer works. I cannot access my inventory or menus.

    Time still passes though and the game/sound plays as normal given someone off to the right just entered/exited a building off to the right somewhere.

    This makes it so I have two choices - A) Allow the day to run out and suffer the money consequences, but hope it frees my character (or see if the bug still exists even after my character being teleported) or B ) Shut down the game externally and lose my progress (and boy howdy, progress was made, son!) Will try option A and see how that works after making a backup.

    Of other note: I'm not running mods and I have not modified the game in any way.

    On the upside, I now have a new icon and a battlecorn!
    • Minakie

      Minakie Cosmic Narwhal

      My God, I had that happen to me before, my game decided to act out when I entered the barn and I got stuck in place and couldn't get back out. Luckily for me, unlike you, I have mods, and I could just use CJB CheatsMenu to warp my character to a different location, which solved the issue for me.
      • Feweo

        Feweo Void-Bound Voyager

        Heh heh, I haven't found a reason for modding yet. However, upon hitting 2am, it teleported me to bed and I was able to move and interact per normal.

        Share This Page