Modding Help Help figuring out my modlist

Discussion in 'Mods' started by heegh, Jun 23, 2019.

  1. heegh

    heegh Space Spelunker

    Hi! I hope its ok to ask for general help with what mods are causing issues here. I haven't had to ask for help before.

    So I found this mod to allow for unlimited players in Stardew and this other mod to allow for people to play while I'm afk. So I wanted to make a server for all my friends that they could go on even when I couldn't play. I also found this mod to allow infinite cabins. So I downloaded all these mods, set up the infinite cabins mod, and my friend joined. Unfortunately, they couldn't leave their room. I removed the infinite cabins mod and tried again with a new farm. They still couldn't leave their room. Additionally, I found I could only craft 3 cabins even though the unlimited players mod is supposed to allow for much more. I'm not really a modder myself, so I was hoping someone could look at my mods and help me figure out what's wrong.

    My recent SMAPI log is here. Im also uploading screenshots of my mod folder jic.
    1.PNG 2.PNG
     
    • Digus

      Digus Ketchup Robot

      First thing:
      Can't parse JSON file at C:\Program Files (x86)\Steam\steamapps\common\Stardew Valley\Mods\UnlimitedPlayers\config.json. This doesn't seem to be valid JSON.
      Technical details: After parsing a value an unexpected character was encountered: . Path 'PlayerLimit', line 3, position 2.


      You probably wrote something wrong in the config.json file.
      Post it content here so we can help you find out what.
       
      • SpringsSong

        SpringsSong Scruffy Nerf-Herder

        You mentioned that you are attempting to do this with friends. Do your friends have the exact same mods list? If there are discrepancies between the host's list and the farmhands' list, that will usually cause issues.
         
        • heegh

          heegh Space Spelunker

          I accidentally put the config options for Always on Server into the config file for Unlimited Players, but I changed that as soon as I noticed. I believed this fixed the issue; I don't think I see the same error in the log.
           
          • heegh

            heegh Space Spelunker

            These are the mods I told my friends they should have, it is not the exact same however.
             

            Share This Page