Modding Help Custom item descriptions not showing up

Discussion in 'Starbound Modding' started by Nabesima, Nov 13, 2020.

  1. Nabesima

    Nabesima Void-Bound Voyager

    Hey there!
    I am attempting to make a small custom race mod for personal use, mostly hoping to edit the text that pops up when some item is inspected. I unpacked the game assets in a different folder (the game folder only has the packed file), then tried using the Racial Description Batch Editor, tested it out with an item from the prologue. And, while my race shows up in the game correctly, when I inspect the said item, my character says the default description, not the custom one I've set up.

    The patch file in question, generated by the RDBE:

    The file contains the following: [{"op": "add","path": "/nauruanDescription","value": "Testing."}]

    Am I missing something? If it matters, I used Skittles Template Race Mod for creating the race, and my game is on Steam.
    Literally never touched modding before, so sorry if it's something basic :'> Thanks in advance!

    UPDATE: it's not my mod, it's... my game, apparently? As no mod race, installed via Steam or manually put into the mods folder, has the custom dialogue, despite the patch files with the said dialogue being right there. Tried reinstalling the game and removing all mods other than the said race mod and the extension, with no effect. Getting more confused by the day, hah.
    Last edited: Nov 16, 2020
  2. Nabesima

    Nabesima Void-Bound Voyager

    Yep, both are named "nauruan", lower case.
  3. Nabesima

    Nabesima Void-Bound Voyager

    Updated, as the issue doesn't seem to be in my mod specifically...

Share This Page