1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Closed Colony Deed Freezing Game

Discussion in 'Starbound Support' started by Brekke K'ktus, Dec 18, 2015.

Thread Status:
Not open for further replies.
  1. Brekke K'ktus

    Brekke K'ktus Void-Bound Voyager

    As seen on picture, I have tried to put a Colony Deed inside this fish-tank-thingy I made.

    When placed it will run that scanning animation forever, and when I tried to remove it or something else from the room, or even to add something it just does nothing or plays that sound when you are forbidden to dig tiles.

    I tried returning back to the ship but just ended up with infinite teleport animation and had to forcefully terminate the game. Afterwards the colony deed was missing from the room and my inventory.

    Tried again with new colony deed (also added some random lights in the room) it happened again, so I tried to move from that point, instead of teleporting this time, but next screen over, planet stopped loading (like here on the left) returned to the room - that side disappeared too... Had to forcefully terminate the game again. :(

    Windows 7 x64
    Stable version
    used Strarbound x64 exe



    Attached Files:

    Last edited: Dec 18, 2015
  2. bouffant

    bouffant Poptop Tamer

    This has happened to me twice when building with glitch castle themed items.
  3. Pilchenstein

    Pilchenstein Ketchup Robot

    Colony deeds are causing the game to sort-of hang in the current version if they're not placed in a sealed space. In your screenshot above, the wooden platform isn't counted as solid by the deed and I suspect that it's then looking past that and trying to scan the entire planet. In any event, colony deeds are pretty dangerous right now.
  4. Xylia

    Xylia Tiy's Beard

    That screenshot looks glitchy as all crap... what's up with the furniture hanging in mid-air?

    Anyways, I've placed like 10 colony deeds within the past week and none of them glitched, but it is as another poster pointed out -- wood platforms are NOT solid. I tried to make a house and I had a basement and an upper part of the house, and I was intending to put two NPCs in this house. In the basement, I had 2 large wooden crates (for a normal merchant) and in the upper part of the house, I had placed a cooking table and a campfire.

    Imagine my surprise when I placed a colony deed in the basement and wound up with a chef. Then I'm like "OH derp, this ain't Terraria... Wood Platforms are NOT solid."

    The game counted my "two" houses as one house, and spawned the chef because of the kitchen table and the campfire.

    I would assume the game crashing is because it is scanning the whole planet as someone else said. Try replacing the platforms with solid blocks and put a normal door in the wall and try again.

    EDIT: Here's the house in question:


    I planned on making 3 houses out of this, but you can see the game considers the bottom left and top left as being one big house, because wood platforms are not solid unlike Terraria. So I had to "try again" with the wood crates in the house on the right to get my merchant.
    Last edited: Dec 28, 2015
  5. Brekke K'ktus

    Brekke K'ktus Void-Bound Voyager

    I hadn't thought of that - that the deed is scanning the whole planet in this instance... I was unsure if (after patching) the platform still doesn't count as a door of a sorts, and was actually testing that assuming that it will as before just scan the room but no tenant will appear (I tried this on my ship), so then I would change my design.
    Also, I have used Glitch Hidden Trapdoor sometimes, when I want a horizontal door for my houses (so that deeds would work). It is not the prettiest, but it works for now. It can be left open so it melts into the background.
    As for the hanging furniture on my screenshot, it is not hanging, just that the ground hasn't loaded somehow and when I hit the invisible line I just start falling in slow-mo.
Thread Status:
Not open for further replies.

Share This Page