1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Bug/Issue Client ship world has errored.

Discussion in 'Starbound Support' started by vlamer12, Nov 25, 2017.

  1. vlamer12

    vlamer12 Big Damn Hero

    Hey everyone,

    I can no longer play starbound due to an annoying bug. Here is what happened: I was bored and rarely ever play online on open servers so decided to join one, I joined: sb.ilovebacons.com (the info stated this server was vanilla). This worked just fine, however, I quickly grew bored and decided to go back to singleplayer. When I tried to join it gave me the error: "You were disconnected from the server for the following reason: Client ship world has errored". I then tried another character but it gave me the same result. I tried rejoining the server and strangely enough it worked just fine.

    I looked up the error and what I found often had to do with either mods or permissions, so just to make it clear: 1) I haven't ever used mods 2) Starbound worked fine (servers with friends as well) up until now 3) I checked the starbound directory and if I delete it by removing metadata, shipworld, etc. files it recreates new files when I start the game again so it has permissions.

    I tried running my own server and joining the local network, but it gave me the same error.

    I also tried creating a new character and play singleplayer but this still gave the error. I uninstalled and reinstalled the game but still it gave me the same error. Please help solving this issue.

    Yours sincerely,

    Vlamer12
     
  2. Iris Blanche

    Iris Blanche Master-Pudding Forum Moderator

    Please attach your full starbound.log located in the storage folder of your starbound install.

    ~ Iris ~
     
  3. vlamer12

    vlamer12 Big Damn Hero

    Thank you for the quick reply, I see a starbound.log text document and 5 seperate logs, would you need all of them? (They are named as starbound.log.1, starbound.log.2... etc.) Or just the standard log text file? If so here it is:

    [22:14:49.750] [Info] Root: Preparing Root...
    [22:14:49.752] [Info] Root: Done preparing Root.
    [22:14:49.752] [Info] Client Version 1.3.3 (windows x86_64) Source ID: c21069b204d626bfe673a047a2100d2fcd0766d4 Protocol: 743
    [22:14:49.752] [Info] Root: Scanning for asset sources in directory '..\assets\'
    [22:14:50.130] [Info] Root: Scanning for asset sources in directory '..\mods\'
    [22:14:50.130] [Warn] Root: Unrecognized file in asset directory 'mods_go_here', skipping
    [22:14:50.130] [Info] Root: Detected asset source named 'base' at '..\assets\packed.pak'
    [22:14:50.130] [Info] Root: Detected unnamed asset source at '..\assets\user'
    [22:14:50.130] [Info] Loading assets from: '..\assets\packed.pak'
    [22:14:50.646] [Info] Loading assets from: '..\assets\user'
    [22:14:51.424] [Info] Assets digest is 563ff626b877e7d080472517395bc6c4eda613eaf6ac1576e95136a4ca9b3d64
    [22:14:51.424] [Info] Root: Loaded Assets in 1.67164 seconds
    [22:14:51.430] [Info] Application: Initializing SDL Video
    [22:14:51.437] [Info] Application: Initializing SDL Joystick
    [22:14:51.538] [Info] Application: Initializing SDL Sound
    [22:14:51.627] [Info] Initialized Steam services
    [22:14:51.628] [Info] Application: Creating SDL Window
    [22:14:51.696] [Info] Application: Enabling VSync with late swap tearing
    [22:14:51.762] [Info] Application: Opened default audio device with 44.1khz / 16 bit stereo audio, 2048 sample size buffer
    [22:14:51.767] [Info] OpenGL version: '4.4.0 - Build 20.19.15.4624' vendor: 'Intel' renderer: 'Intel(R) HD Graphics 5500' shader: '4.40 - Build 20.19.15.4624'
    [22:14:51.772] [Info] Application: initialization...
    [22:14:51.774] [Info] Root: Loaded Configuration in 0.0012531 seconds
    [22:14:51.785] [Info] Application: renderer initialization...
    [22:14:51.798] [Info] detected supported OpenGL texture size 16384, using atlasNumCells 128
    [22:14:51.799] [Info] detected supported OpenGL texture size 16384, using atlasNumCells 64
    [22:14:51.802] [Info] Root: Loaded ImageMetadataDatabase in 1.86614e-06 seconds
    [22:14:51.830] [Info] Application: main update loop...
    [22:14:51.833] [Info] No subscribed user generated content
    [22:14:51.853] [Info] Root: Loaded NameGenerator in 0.0184537 seconds
    [22:14:52.042] [Info] Root: Loaded PlantDatabase in 0.18984 seconds
    [22:14:52.344] [Info] Root: Loaded ObjectDatabase in 0.510012 seconds
    [22:14:52.623] [Info] Root: Loaded MonsterDatabase in 0.279023 seconds
    [22:14:52.694] [Info] Root: Loaded NpcDatabase in 0.0708274 seconds
    [22:14:52.696] [Info] Root: Loaded StagehandDatabase in 0.0021857 seconds
    [22:14:52.702] [Info] Root: Loaded VehicleDatabase in 0.00528347 seconds
    [22:14:52.708] [Info] Root: Loaded PlayerFactory in 0.0056413 seconds
    [22:14:52.750] [Info] Root: Loaded ProjectileDatabase in 0.707831 seconds
    [22:14:52.754] [Info] Root: Loaded VersioningDatabase in 0.00313883 seconds
    [22:14:52.754] [Info] Root: Loaded EntityFactory in 0.0461181 seconds
    [22:14:52.819] [Info] Root: Loaded ParticleDatabase in 0.065683 seconds
    [22:14:53.170] [Info] Root: Loaded MaterialDatabase in 0.416748 seconds
    [22:14:53.177] [Info] Root: Loaded TerrainDatabase in 0.00670173 seconds
    [22:14:53.227] [Info] Root: Loaded BiomeDatabase in 0.0502399 seconds
    [22:14:53.228] [Info] Root: Loaded LiquidsDatabase in 0.0009228 seconds
    [22:14:53.239] [Info] Root: Loaded StatusEffectDatabase in 0.0102404 seconds
    [22:14:53.624] [Info] Root: Loaded DamageDatabase in 0.385101 seconds
    [22:14:53.636] [Info] Root: Loaded EffectSourceDatabase in 0.0122796 seconds
    [22:14:53.641] [Info] Root: Loaded FunctionDatabase in 0.00467791 seconds
    [22:14:53.675] [Info] Root: Loaded TreasureDatabase in 0.0340727 seconds
    [22:14:54.004] [Info] Root: Loaded DungeonDefinitions in 0.328399 seconds
    [22:14:54.004] [Info] Root: Loaded TilesetDatabase in 3.68559e-05 seconds
    [22:14:54.007] [Info] Root: Loaded StatisticsDatabase in 0.00247075 seconds
    [22:14:54.007] [Info] Root: Loaded EmoteProcessor in 7.23125e-05 seconds
    [22:14:54.014] [Info] Root: Loaded SpeciesDatabase in 0.00754055 seconds
    [22:14:54.036] [Info] Root: Loaded QuestTemplateDatabase in 0.0215006 seconds
    [22:14:54.038] [Info] Root: Loaded AiDatabase in 0.00187779 seconds
    [22:14:54.039] [Info] Root: Loaded TechDatabase in 0.00127316 seconds
    [22:14:54.046] [Info] Root: Loaded CodexDatabase in 0.00691307 seconds
    [22:14:54.399] [Info] Root: Loaded BehaviorDatabase in 0.352607 seconds
    [22:14:54.403] [Info] Root: Loaded DanceDatabase in 0.00391467 seconds
    [22:14:54.412] [Info] Root: Loaded SpawnTypeDatabase in 0.00925179 seconds
    [22:14:54.416] [Info] Root: Loaded RadioMessageDatabase in 0.00370006 seconds
    [22:14:54.760] [Info] Root: Writing runtime configuration to '..\storage\starbound.config'
    [22:14:56.423] [Info] Root: Loaded ItemDatabase in 3.67229 seconds
    [22:14:56.571] [Info] Root: Loaded CollectionDatabase in 2.15536 seconds
    [22:14:57.561] [Info] detected supported OpenGL texture size 16384, using atlasNumCells 256
    [22:15:01.084] [Info] UniverseServer: Acquiring universe lock file
    [22:15:01.086] [Info] UniverseServer: Loading settings
    [22:15:01.089] [Info] UniverseServer: Starting UniverseServer with UUID: 5d12a4794830c7179d820653001abffe
    [22:15:01.104] [Info] UniverseServer: Logged in player 'Vlamer12' locally
    [22:15:01.104] [Info] UniverseServer: Logged in account '<anonymous>' as player 'Vlamer12' from address local
    [22:15:01.170] [Info] UniverseServer: Loading system world (-578015994, -776769064, 97525962) from disk storage
    [22:15:01.178] [Info] UniverseClient: Joined server as client 1
    [22:15:01.217] [Info] UniverseServer: Reviving player at ClientShipWorld:ba5b21dba9fdbbbbf146d9879cf8df28
    [22:15:01.218] [Info] UniverseServer: Client 'Vlamer12' <1> (local) connected
    [22:15:01.270] [Info] UniverseServer: Loading client ship world ClientShipWorld:ba5b21dba9fdbbbbf146d9879cf8df28
    [22:15:01.274] [Error] UniverseServer: Could not load client ship ClientShipWorld:ba5b21dba9fdbbbbf146d9879cf8df28, resetting ship to default state! (IOException) could not open file 'C:\Users\Robin\AppData\Local\Temp\starbound.tmpfile.e6a8e94430aa5dc7db8d2fe2ed384018' 3
    [22:15:01.274] [Info] UniverseServer: Creating new client ship world ClientShipWorld:ba5b21dba9fdbbbbf146d9879cf8df28
    [22:15:01.510] [Error] UniverseServer: error during world create: (IOException) could not open file 'C:\Users\Robin\AppData\Local\Temp\starbound.tmpfile.f083bd461d7b8d92ed048270f3996bbd' 3
    [0] 7ff7d3fd7153 Star::captureStack
    [1] 7ff7d3fd5ede Star::StarException::StarException
    [2] 7ff7d3fcef2a Star::IOException::format<char const * __ptr64,unsigned long>
    [3] 7ff7d3fcff47 Star::File::fopen
    [4] 7ff7d3f5e650 Star::File::eek:pen
    [5] 7ff7d3f5e600 Star::File::eek:pen
    [6] 7ff7d3fd1213 Star::File::temporaryFile
    [7] 7ff7d3fcfd73 Star::File::ephemeralFile
    [8] 7ff7d44a98a2 <lambda_b7d664bc5694634169a6e275ccf1e4a2>::eek:perator()
    [9] 7ff7d4491d1f std::_Invoker_functor::_Call<<lambda_b7d664bc5694634169a6e275ccf1e4a2> & __ptr64>
    [10] 7ff7d4498f76 std::invoke<<lambda_b7d664bc5694634169a6e275ccf1e4a2> & __ptr64>
    [11] 7ff7d4494fb9 std::_Invoke_ret<std::shared_ptr<Star::WorldServerThread>,<lambda_b7d664bc5694634169a6e275ccf1e4a2> & __ptr64>
    [12] 7ff7d44ab4a6 std::_Func_impl<<lambda_b7d664bc5694634169a6e275ccf1e4a2>,std::allocator<int>,std::shared_ptr<Star::WorldServerThread> >::_Do_call
    [13] 7ff7d438a337 std::_Func_class<std::shared_ptr<Star::DamageDatabase> >::eek:perator()
    [14] 7ff7d44a8662 <lambda_770d99c769b4950d94783c330804382d>::eek:perator()
    [15] 7ff7d3fcea42 Star::WorkerPool::WorkerThread::run
    [16] 7ff7d3fd3c5e Star::ThreadImpl::runThread
    [17] 7ffa7fd88364 BaseThreadInitThunk
    [18] 7ffa80837091 RtlUserThreadStart
    [22:15:01.546] [Info] UniverseServer: Client 'Vlamer12' <1> (local) disconnected for reason: Client ship world has errored
    [22:15:01.597] [Info] detected supported OpenGL texture size 16384, using atlasNumCells 64
    [22:15:01.597] [Info] detected supported OpenGL texture size 16384, using atlasNumCells 128
    [22:15:01.608] [Info] detected supported OpenGL texture size 16384, using atlasNumCells 256
    [22:15:01.608] [Info] detected supported OpenGL texture size 16384, using atlasNumCells 256
    [22:15:01.608] [Info] Setting steam rich presence connection as steam id 76561198011130519
    [22:15:01.669] [Error] You were disconnected from the server for the following reason:
    Client ship world has errored
    [22:15:01.720] [Info] UniverseServer: Stopping UniverseServer
    [22:15:01.783] [Info] Clearing steam rich presence connection
    [22:15:04.816] [Info] detected supported OpenGL texture size 16384, using atlasNumCells 256
    [22:15:06.168] [Info] Application: quit requested
    [22:15:06.168] [Info] Application: quitting...
    [22:15:06.168] [Info] Application: shutdown...
    [22:15:06.302] [Info] Root: Shutting down Root
    [22:15:06.569] [Info] Application: Destroying SDL Window
    [22:15:06.728] [Info] Application: stopped gracefully


    If you do need the others as well, please let me know.

    Yours sincerely,

    Vlamer12
     
  4. Iris Blanche

    Iris Blanche Master-Pudding Forum Moderator

    Try disabling windows UAC (not much recommended) and/or add starbound to the exception list of your AV software.

    ~ Iris ~
     
  5. vlamer12

    vlamer12 Big Damn Hero

    I disabled the windows UAC temporarily and added starbound to my antivirus exception list. I then tried playing again but received the same error.
    I would like to note that starbound used to work just fine, and it is only since I joined this server that this error has occured.
    I'm turning my UAC back on as a precaution but if any of the future steps need it to be off please mention so and I will turn it off again.

    Yours sincerely,

    Vlamer12
     
  6. Iris Blanche

    Iris Blanche Master-Pudding Forum Moderator

    You could try launching the game as admin instead. Tho it seems pretty weird that the access to the temp folder is limited for an application at all.

    ~ Iris ~
     
  7. vlamer12

    vlamer12 Big Damn Hero

    I tried launching it as an admin but to no avail.

    Edit/Update: So I tried running it again just to see if there was anything that I missed... and it worked. Both for the character I used to join the aforementioned server as a different old and a completely new character. So it seems to be fixed. The curious thing is I haven't changed a thing (as I already tried running starbound as an admin yesterday). To try and determine what the cause of the issue was I stopped running it in admin mode and it still works. I haven't rebooted my computer but just let it run overnight in standby mode. In conclusion, I have no idea what caused the problem, nor how to fix it. But I suppose it seems to be solved. If you would like the log for future reference please say so and I will supply it, but in any case thank you for your help!

    -Vlamer12
     
    Last edited: Nov 26, 2017
  8. Iris Blanche

    Iris Blanche Master-Pudding Forum Moderator

    Maybe the file was locked before and when you launched the game via admin mode it finally got deleted. At least it is what i assume atm.
    If this error occurs again lemme know.

    Happy starbounding ^-^

    ~ Iris ~
     
    vlamer12 likes this.
  9. [insertnamehere]

    [insertnamehere] Intergalactic Tourist

    i have this error. please help.
     

Share This Page