Bug/Issue Can't start game

Discussion in 'Support' started by chrysop, Aug 24, 2016.

  1. chrysop

    chrysop Space Hobo


    when I tried to quit the game (version 1.2.7 from Steam) last night my PC (Windows 10) crashed. After that, I can't start the game (everything else in the PC is working ok), I keep getting the following error and the game crashes (just after displaying the laughing fish). Tried reinstalling the game but get the same results

    Bug description:

    OS: Windows 8 x86, version 6.2
    number of processors: 4
    system property hash: 0xe2c655c4

    com.badlogic.gdx.utils.SerializationException: Error parsing JSON on line 1 near:
    t com.badlogic.gdx.utils.JsonReader.parse(JsonReader.java:437)
    at com.badlogic.gdx.utils.JsonReader.parse(JsonReader.java:55)
    at com.badlogic.gdx.utils.Json.fromJson(Json.java:633)
    at com.robotality.halfway.serialisation.persistence.progress.GameProgressHandler$2.loadSaveGame(GameProgressHandler.java:168)
    at com.robotality.halfway.serialisation.persistence.progress.GameProgressHandler$2.loadSaveGame(GameProgressHandler.java:156)
    at com.robotality.framework.serialize.progress.SaveGameManager.loadSaveGame(SaveGameManager.java:44)
    at com.robotality.halfway.serialisation.persistence.progress.GameProgressHandler.loadSaveGame(GameProgressHandler.java:266)
    at com.robotality.halfway.serialisation.persistence.progress.GameProgressHandler.loadGameProgress(GameProgressHandler.java:381)
    at com.robotality.halfway.serialisation.persistence.progress.GameProgressHandler.loadGameProgress(GameProgressHandler.java:343)
    at com.robotality.halfway.serialisation.persistence.progress.GameProgressHandler.checkForGameProgress(GameProgressHandler.java:359)
    at com.robotality.halfway.screen.NewMenuScreen.<init>(NewMenuScreen.java:43)
    at com.robotality.halfway.screen.LogoScreen.skip(LogoScreen.java:144)
    at com.robotality.halfway.screen.LogoScreen.update(LogoScreen.java:88)
    at com.robotality.halfway.Halfway.render(Halfway.java:89)
    at com.badlogic.gdx.backends.lwjgl.LwjglApplication.mainLoop(LwjglApplication.java:207)
    at com.badlogic.gdx.backends.lwjgl.LwjglApplication$1.run(LwjglApplication.java:114)

    Display Modes:
    desktop resolution: 1440x900x32 (60 hz)

    Any ideas?
    • Seminus

      Seminus Halfway Developer Developer

      Hey chrysop,

      It seems that the crash has something to do with either the saves or the config files that are broken. We do save everything into json files and there it seems to crash while reading.

      One thing you can do first: Go to the steam folder and into the folders where all the games are installed. (Normally C:\Program Files (x86)\Steam\steamapps\common\Halfway) and delete the settings.json. Then try to start again.

      Second thing: Go to C:\Users\<yourUserName>\.halfway and copy everything you have there into one zip file and send it over to me. It could be that your Save game is broken as you quit while it saved or something similar. You can reach me over at "hello (at) robotality dot com".

      Third thing: Did you tried the modding tools or installed a mod or edited one file manually? If yes, this could cause the crash too if saved incorrectly. So you might want to revert the changes if you have made any.

      Hope this helps.
      • chrysop

        chrysop Space Hobo


        Thanks a lot for your prompt response! Your intuition proved correct, when I deleted the settings.json file everything went back to normal.

        Once again,

        • Seminus

          Seminus Halfway Developer Developer

          Awesome! Enjoy the game and let us know if you hit another issue.

          Share This Page