1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Can't Launch. Fatal Exception caught

Discussion in 'Starbound Support' started by DANjustYEAH, Apr 7, 2020.

  1. DANjustYEAH

    DANjustYEAH Space Hobo


    Unable to launch, even after re-install.
    Turned off overlays.
    Happens on both 64 & 32 bit.
    Tried running as admin.

    [14:56:24.665] [Info] Root: Preparing Root...
    [14:56:24.666] [Info] Root: Done preparing Root.
    [14:56:24.666] [Info] Client Version 1.4.4 (windows x86_64) Source ID: 8cbe6faf22282659828a194e06a08999f213769e Protocol: 747
    [14:56:24.666] [Info] Root: Scanning for asset sources in directory '..\assets\'
    [14:56:25.127] [Info] Root: Scanning for asset sources in directory '..\mods\'
    [14:56:25.127] [Warn] Root: Unrecognized file in asset directory 'mods_go_here', skipping
    [14:56:25.127] [Info] Root: Detected asset source named 'base' at '..\assets\packed.pak'
    [14:56:25.128] [Info] Root: Detected unnamed asset source at '..\assets\user'
    [14:56:25.128] [Info] Loading assets from: '..\assets\packed.pak'
    [14:56:25.705] [Info] Loading assets from: '..\assets\user'
    [14:56:26.720] [Info] Assets digest is 531f0b8469832a566d23a0b9870ed717c63291164883670d0ee17086a100d3cd
    [14:56:26.720] [Info] Root: Loaded Assets in 2.05399 seconds
    [14:56:26.722] [Info] Application: Initializing SDL Video
    [14:56:26.736] [Info] Application: Initializing SDL Joystick
    [14:56:26.739] [Info] Root: Shutting down Root
    [14:56:26.873] [Error] Fatal Exception caught: (ApplicationException) Couldn't initialize SDL Joystick: CoCreateInstance() DirectX error 0xx
    [0] 7ff6d35ca213 Star::captureStack
    [1] 7ff6d35c8f9e Star::StarException::StarException
    [2] 7ff6d3cda9f5 Star::SdlPlatform::SdlPlatform
    [3] 7ff6d3cdd682 Star::runMainApplication
    [4] 7ff6d3517731 WinMain
    [5] 7ff6d3ec07af __scrt_common_main_seh
    [6] 7ffdd7017bd4 BaseThreadInitThunk
    [7] 7ffdd71eced1 RtlUserThreadStart
    Caught at:
    [0] 7ff6d35ca213 Star::captureStack
    [1] 7ff6d35ca7d4 Star::fatalException
    [2] 7ff6d3f83a3c `Star::runMainApplication'::`1'::catch$76
    [3] 7ffdc0901030
    [4] 7ffdc0903328 is_exception_typeof
    [5] 7ffdd7220666 RtlCaptureContext
    [6] 7ff6d3cdd682 Star::runMainApplication
    [7] 7ff6d3517731 WinMain
    [8] 7ff6d3ec07af __scrt_common_main_seh
    [9] 7ffdd7017bd4 BaseThreadInitThunk
    [10] 7ffdd71eced1 RtlUserThreadStart
    Last edited by a moderator: Apr 7, 2020
  2. tigerfestival

    tigerfestival Cosmic Narwhal

    Try uninstalling then reinstalling Direct X and see if that helps you, it seems to be related to direct X.
  3. DANjustYEAH

    DANjustYEAH Space Hobo

    It's able to launch after restarting the PC, but not if the PC has been of for over ~ 30 mins.

    Just tried a Direct X reinstall, will update if it fixes for good
  4. DANjustYEAH

    DANjustYEAH Space Hobo

    So far so good!
  5. tigerfestival

    tigerfestival Cosmic Narwhal

    So is it working like it should?
  6. DANjustYEAH

    DANjustYEAH Space Hobo

    I take that back, it is now producing the same error again and unable to launch
  7. tigerfestival

    tigerfestival Cosmic Narwhal

    @Iris Blanche You have any other suggestions?
  8. DANjustYEAH

    DANjustYEAH Space Hobo

    This is very odd, I can't reliably reproduce the error.
    Once it starts happening the only fix is a restart.
    This solves it every time but if my PC has been on for a while the error may re-occur
  9. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    Might be some additional software interfering or it is hardware related...
    Does this issue happen after you started some other software? Maybe something is blocking some access afterwards because a remnant is still running. Would explain why it works after a restart.
  10. DANjustYEAH

    DANjustYEAH Space Hobo

    Oddly enough the same thing has been happening to a friend on a different pc. Granted I've got loads of background stuff running on mine but his is a fresh windows install

    I'll try some process killing and see if I can find the culprit
    Last edited by a moderator: Apr 19, 2020
  11. adgga

    adgga Intergalactic Tourist

    Ever found the culprit? I'm having the same error now and the only other "solution" I could find online was on reddit. (Was just to reinstall Starbound.)

Share This Page