Can't Get Farmhousetiles.xnb to change

Discussion in 'Mods' started by Arshness, Nov 14, 2017 at 4:05 AM.

  1. Arshness

    Arshness Void-Bound Voyager

    Hi!

    So this is my third time making a heavily modded setup for SDV, and I've done enough modding to know my way around stuff mostly... But I'm having an issue. I can't get the farmhouse.xnb to update no matter what I do.

    I originally wanted to see if my heavily edited farmhouse interiors from my last game would still work, so I tried using those, and the furniture works, but the farmhouse tiles didn't change. Then I tried grabbing an updated mod and using it, and to my surprise, they didn't change again. I'm overwriting and confirming, then starting a new game even, no change.

    Oddly, I had the same issue with trying to change a map. I was playing Stardew Springs and I accidentally grabbed the car version. I'd put it in directly through the content menus per the mod author's instructions in posts on Nexus to avoid SMAPI conflicts, and it works fine, but when I tried to take the version without the car and put that in over it, overwrote it and all... It never changes. Not in same save, or in a new game.

    If I hadn't tried a new save, I'd just assume the save was holding onto those files for me.
    But as is, I'm completely stumped. I'm hoping someone will go "Ah, you're doing that obvious thing that's so obvious you missed it."

    Here's hoping!
    And thanks!!
     
    • stardewbalverines

      stardewbalverines Space Spelunker

      Hi! It might be an issue with the custom map, as I've had some really weird issues with custom maps! Like, one I tried made it so the spouse patio was part of Jojamart and I couldn't get it changed no matter what.

      So if you can change the interior with a different map, that's likely the issue, which means it's a mapping/coding issue on the farm maker's end.
      And just to be sure, you want to make sure you're editing the other farmhouse maps, too! Farmhouse_1, farmhouse_1marriage and so on!
       
      • Arshness

        Arshness Void-Bound Voyager

        Oooook. That's probably it. Farmhouse_1 etc. SEe, this is why I asked, checking for the obvious. I probably missed the obvious... probably. I'll try that and see if it works! Many thanks!
         
        • Arshness

          Arshness Void-Bound Voyager

          Mmmmm. Not sure. I unpacked Farmhouse1.xnb and it has a tbin and a yaml. I don't know how to work with those. The things I'm working with have a png and a yaml. I have previously just edited the png then repacked it and it worked. But that was a while ago. I don't know how to proceed.

          >_<
           
          • Xuomi

            Xuomi Zero Gravity Genie

            Files that have .tbin are map files, meant to be opened in Tiled or a similar map-building program.

            If you're trying to edit the interior of the farmhouse, you need to unpack farmhouse_tiles.xnb and townInterior.xnb, edit and repack them, and make sure to replace both files in both the Content folder and the Maps folder. If you only place them in the Content folder, then they won't load. You need to make sure they're also in Maps.
             
            • Arshness

              Arshness Void-Bound Voyager

              Oooh that helps a lot! Thanks! When I have more time, I'll try to edit the townInterior.xnb and see if that's the issue! I'm sure it is. I guess that was one change since the time I was playing before. It was quite a while ago. I waited for the release instead of starting again, so it was a long time. I'm enjoying my playthrough now!

              Ty!
               

              Share This Page