1. Please be advised of a few specific rules and guidelines for this section.

Outdated Bulldozer 1.2 - fix

Just when planets couldn't get flat enough...

  1. Traijan

    Traijan Cosmic Narwhal

    It's a very interesting mod in what you have managed to do with it. Unfortunately very unpractical in that...

    1. Can't steer it to make it go up a hill to smooth out the side of a hill or if you happened to start on the bottom of a hill and want to clear out from the ground up.
    2. Still get attacked by enemy mobs, would think that the bulldozer would add some sort of protection to the character as he's sitting inside this monsterous beast of a machine.

    Never the less, those are my issues and not so much the mods issues and as I said, it's pretty amazing to see what you were able to come up with for this. I'm gonna try the mini dozer and see if it's easier to manage.
  2. kirbycrazy33

    kirbycrazy33 Aquatic Astronaut

    Can't dig with it. :/
  3. Mr Bubbles

    Mr Bubbles Subatomic Cosmonaut

    I found it in the coding
    its in mods/bulldozor/tech/mech/treadmech open treadmech.tech with notepad++ find "energyCostPerSecond" : 30, and change it to whatever you desire

      "script" : "/tech/mech/treadmech.lua",
      "actions" : [ "mechActivate", "mechDeactivate" ],
      "animator" : "treadmech.animation",
      "mechCustomMovementParameters" : {
        "standingPoly" : [ [-14.3, -5.0], [14.3, -5.0], [14.3, 3.0], [3.0, 3.0], [3.0, 4.5], [-8, 4.5], [-8, 2], [-14.3, 2], [-14.3, -5] ],
        "crouchingPoly" : [ [-14.3, -5.0], [14.3, -5.0], [14.3, 3.0], [3.0, 3.0], [3.0, 4.5], [-8, 4.5], [-8, 2], [-14.3, 2], [-14.3, -5] ],
        "mass" : 5.0,
        "normalGroundFriction" : 50.0,
        "ambulatingGroundFriction" : 6.0,
        "skiddingGroundFriction" : 10.0,
        "groundForce" : 160.0,
        "airForce" : 50.0,
        "liquidForce" : 70.0,
        "walkSpeed" : 5.0,
        "runSpeed" : 8.0,
        "airJumpProfile" : {
          "jumpSpeed" : 0.0,
          "jumpControlForce" : 0.0,
          "jumpInitialPercentage" : 0.75,
          "jumpHoldTime" : 0.15
        "liquidJumpProfile" : {
          "jumpSpeed" : 0.0,
          "jumpControlForce" : 0.0,
          "jumpInitialPercentage" : 0.75,
          "jumpHoldTime" : 0.1
      "energyCostPerSecond" : 30,
      "mechTransformPositionChange" : [0.0, 2.5],
      "parentOffset" : [1, 2.5 ],
      "mechCollisionTest" : [-14.3, -2.5, 14.3, 6.5],
      "mechAimLimit" : 10,
      "mechFireCycle" : 0.25,
      "mechProjectile" : "spinningrocket",
      "mechProjectile2" : "rocket",
      "mechProjectileCost" : 1,
      "mechProjectile2Cost" : 5,
      "mechProjectileConfig" : {
      "mechProjectile2Config" : {
      "bulldozeOffset" : 15,
      "bulldozeBlocks" : [
        [0, -5],
        [0, -4],
        [0, -3],
        [0, -2],
        [0, -1],
        [0, 0],
        [0, 1],
        [0, 2],
        [0, 3],
        [0, 4],
        [0, 5]
    Last edited: Jan 4, 2014
    jaaskk likes this.
  4. DragonZombie

    DragonZombie Pangalactic Porcupine

    ajem, dosent work! heres the screenshot of how i did it.... (and yes... i opened the zip) and the minidozer DOSENT WORK ALSO...?[​IMG]
  5. The Enlightened Grue

    The Enlightened Grue Master Astronaut

    so I have no idea what I'm doing wrong or if there is some Really Really nonsense mod incompatability going on...
    Minidozer works as advertized for me.
    Bulldozer is acting like just.... a big foreground box that enemies can walk through, and that makes it impossible for me to fall down small holes (noting that, because I'm seeing that the vehicle is there, but no bulldozing going on?)

    Any ideas off the top of your head?
    Path is starbound > mods > bulldozer > ( recipes, tech, bulldozer.modinfo, player.config )
    I did check that it wasn't running into problems with me wearing modarmors or anything that would put stats outside of vanilla regs.

    Any help would be appreciated :)
  6. Nukesdoom

    Nukesdoom Void-Bound Voyager

    i cant craft it!
  7. KazanaAoi

    KazanaAoi Phantasmal Quasar

    Havig a similar issue as The Enlightened Grue above, The Bulldozer just acts like a big foreground object, doesnt doze anything. Also, After the first time I used the tech, all subsequent uses result in a -huge- performance drop, And I have no idea why :(
    Edit: and I mean -ALL- subsequent uses, including after reinstalling the mod, restarting the game, etc.
    Love the minidozer. Wish I could use the big one.
    Reeddick likes this.
  8. jaaskk

    jaaskk Void-Bound Voyager

    getting that same im trying a fix.

    placing the tech folders from the mini and normal into the C:\Program Files (x86)\Steam\SteamApps\common\Starbound\assets\tech\mech folder

    there was a conflict, one file from the minidozer wanted to overwrite one from the normal dozer I didn't allow incase this was the problem ill try now and get back to you
  9. jaaskk

    jaaskk Void-Bound Voyager

    Normal bulldozer fixed. I havnt tested the little one and I don't care too but for those who want both and one to work my fix above will work
  10. KazanaAoi

    KazanaAoi Phantasmal Quasar

    After reading your post, I spent some time looking through the two mods, and I see the problem. Its that identical file, "treadmech.lua" if you install both via the /Mods folder, then the load order breaks the bulldozer, because the "treadmech.lua" from the Minidozer mod overwrites the one from bulldozer. :p Should be an easy fix for the mod author :D

    I'm guessing, based on the file names, that the one in the minidozer mod is actually supposed to be "minidozermech.lua" or something like that

    Edit: I did the above, simply renamed the "treadmech.lua" inside the minidozer mod to "minidozermech.lua" and now both work just peachy, as intended :) so that was definately the problem, somehow
    Last edited: Jan 6, 2014
  11. jaaskk

    jaaskk Void-Bound Voyager

    the mini also works with out its own seems to run off the bulldozer one

    both will work if you use my method just checked it
  12. jaaskk

    jaaskk Void-Bound Voyager

    yeah that was the file that came up ill see if I can edit my review and name the file.

    my opinion is that they both only need one

    if what you said is true the mini dozer would also need to have some text somewhere in another file that would refer to the file you have created

    they both use the same file for whatever it is that file does

    (scroll up for fix)
    Last edited: Jan 6, 2014
  13. DragonZombie

    DragonZombie Pangalactic Porcupine

    is this the fix? it dosent work, there is no tech, even when i use the all tech unlocker, recipes and that... and i dont have the minidozer installed
  14. KazanaAoi

    KazanaAoi Phantasmal Quasar

    Installing via the assets folder isnt the way you're supposed to install mods now. (Though, sometimes it still works)
    You should have the mod installed in the /mods folder,

    C:\Program Files (x86)\Steam\SteamApps\common\Starbound\mods\bulldozer
    you should have the recipes folder, the tech folder, bulldozer.modinfo, and player.config from the zip inside that path (Or to X:\Wherever\Starbound\mods\bulldozer, if you installed it elsewhere)

    Once you do that the Bulldozer tech is available from your initial crafting menu(The one you press 'C' to access) Or from the Crafting Table, This -should- apply to old or new characters alike, but if it doesnt apply to old characters, make a new one and see if it can craft the bulldozer tech, craft a few, then leave it on a planet (record the coords) and pick it up with the character/s you want to have it. :)
  15. DragonZombie

    DragonZombie Pangalactic Porcupine

    i have lots of mods right now, and i did make 3 chars... none of them work... and i installed it on the mods folder too... and then on the assets (not on both at the same time, will break) maybe one of the mods is breaking something?
  16. KazanaAoi

    KazanaAoi Phantasmal Quasar

    I'm currently using 46 different mods at the moment, But yeah, its definately a possibility that one of the others is breaking something. Check through all the mods you have and see if any use a player.config file that doesnt start with

    "__merge" : [],

    If so, That mod is (Edit: Probably) the problem, It's completely overwriting the player.config file, rather than merging into it and I'm suprised you havent had issues with other mods prior to this :p
  17. DragonZombie

    DragonZombie Pangalactic Porcupine

    i use 52, i checked them, most of them use the merge... others dont even have a player.config or that... is it the problem? they dont have that?
  18. KazanaAoi

    KazanaAoi Phantasmal Quasar

    Nah, If it doesnt have a player.config its probably something that adds items via Tabula Rasa, or that changes core things about the game, like adding dungeons, or biomes. So if there isnt one, then its fine. Hrm... I cant imagine what the cause of your issue is, and since I dont have your mods folder I cant exactly test it. Do any of the other mods overwrite/modify the "tech/mech" path? (IE: Do any of the other mods have a folder inside it named "tech" with a folder "Mech" inside it)? If so, it could be overwriting the files from bulldozer
  19. DragonZombie

    DragonZombie Pangalactic Porcupine

    i removed some mods, ITS WORKING NOW! its fixed! that was the problem! anyways thanks for the help
  20. jaaskk

    jaaskk Void-Bound Voyager

    yeah so my method is for if
    you have BOTH DOZERS
    and THE ANIMATION don't work
    and DOES NOT DIG

    (1) goto C:\Program Files (x86)\Steam\SteamApps\common\Starbound\mods\minidozer\tech\mech
    (2) see "treadmech.lua"
    (3) remove
    (4) PLAY test if it works don't worry about 5
    (5) if that still hasn't worked there will be a conflict with one of your other mech mods

Share This Page